I was naive enough to think that this issue would have been fixed in
ZoneAlarm by now, so I tried to upgrade again. Similar problems...

BUT this time I notice something even stranger!
Only one of my webapps is affected. Serving a static .html from one
webapp (or resin-doc / resin-admin pages) takes milliseconds as usual,
while serving a static .html from my main webapp takes several seconds
or more.

So back to square one - maybe Resin is at least partially guilty.
Any further tips on how to find out what is going on here???


Mattias Jiderhamn wrote (2007-10-08 12:39):
> I believe I have found the offender in this issue: ZoneAlarm.
> I had already tried to turn it off, but since I have seen some strange
> behaviour with ZoneAlarm before I now tried uninstalling it altogether.
> That seem to have solved the issue.
> I'm sorry for wasting your time, especially now that I remember I
> probably upgraded ZoneAlarm (free version to 7.0.408) around the time
> the problems started. *blush*
> Thanks for all the tips and suggestions - the supportive community is
> part of what makes Resin great.
> Hopefully the archive copy of this thread can be of help to somebody else.
>  /Mattias
> I wrote:
>> By the way, the CPU usage is peaking all the way through. Around 49% on
>> my dual core system.
>> (And there is even more memory on the computer with the problem than the
>> other one)
>>> -----Original Message-----
>>> [mailto:[EMAIL PROTECTED] Behalf Of Mattias Jiderhamn
>>> Sent: Friday 05 October 2007 11:20
>>> To: Resin
>>> Subject: [Resin-interest] Slooow file reads (really weird!)
>>> Hi list.
>>> I have my J2EE webapp on an external hard drive, which I carry between
>>> my office and my home computer.
>>> On each computer - running Windows XP and Java 1.5 - I have a Resin
>>> (3.0.22) installation and a shortcut to start Resin with the server root
>>> on the external drive.
>>> This has worked flawlessly for over a year.
>>> Now suddenly (ok, after returning from vacation), the application is
>>> immensely slow - on one of the computers!
>>> Starting Resin and the application now takes anywhere from 3 to 5
>>> minutes on my home computer, compared to the usual 30 or so seconds.
>>> Loading a simple page can take 40 seconds. It seems that most of the
>>> time is spent inside the disk access of the dependency checking.
>>> (Turning dependency checking off was much faster, but still slower than
>>> normal).
>>> I tried to copy the project to the internal drive to see if there was
>>> some interface hardware issue - no difference.
>>> I profiled the application with JProfiler, and it thinks there is a
>>> hotspot in com.caucho.vsf.JniStream.read(). Why...?
>>> I am running out of ideas on what could be wrong and how to track it down.
>>> Any tips would be much welcome!
>>>   /Mattias

resin-interest mailing list

Reply via email to