AFAIK, you either place the .war file in webapps or define the directory 
using an explicit web-app tag, but having both is not necessary and just 
seems to confuse Resin.

S!
D.

El 22/03/2011 1:03, Keith Fetterman escribió:
> I am experiencing a problem in resin 4.0.16 where resin is not expanding
> the ROOT.war file if I explicitly define the root webapp in resin.xml
> file.  In resin.xml, I have the tag "<web-app id="/"
> root-directory="webapps/ROOT"/>" defined under my"<host>" tag.  I also
> have the tag "<web-app-deploy path="webapps" versioning="true"/>"
> defined under my "<host-default>" tag.
>
> When I update the ROOT.war file in my "webapps" directory, the war file
> is not being expanded into the webapps/ROOT directory.  I have tried
> both shutting down resin, updating the ROOT.war file and then starting
> resin, and I've tried updating ROOT.war while resin is running.
>
> If I remove the tag "<web-app id="/" root-directory="webapps/ROOT"/>"
> from the resin.xml file, then ROOT.war expansion occurs.
>
> Do I need to add an attribute to the<web-app id="/"
> root-directory="webapps/ROOT"/>  tag to get the war file to expand?
>
> Also, what is the difference between the attribute "root-directory" and
> "document-directory" in the<web-app>  tag?  I noticed in the resin
> documentation that "root-directory" is mentioned in the list of
> attributes but "document-directory" is not on the following page:
>
> http://caucho.com/resin/reference.xtp#web-app
>
> But, if you look at the examples, they all show "<web-app id='/apache'
> document-directory='/usr/local/apache/htdocs'>"
>
> Thanks,
> Keith



_______________________________________________
resin-interest mailing list
resin-interest@caucho.com
http://maillist.caucho.com/mailman/listinfo/resin-interest

Reply via email to