In Resin 3.0, we had this configuration and it didn't have a problem.  
Actually, I recall that we did in an early version of 3.0.x, but the 
problem was corrected in the later versions.

There are two reasons why we explicitly had the <web-app> tag in 
resin.conf in resin 3.0:

- On our test environment only, I want to specify some security 
constraints to the root web app. to prevent access, for example:

> <web-app id="/" document-directory="webapps/ROOT">
> <security-constraint>
> <web-resource-collection>
> <web-resource-name>test</web-resource-name>
> <url-pattern>/*</url-pattern>
> </web-resource-collection>
> <auth-constraint>
> <role-name>intranet</role-name>
> </auth-constraint>
> </security-constraint>
> <login-config>
> <auth-method>BASIC</auth-method>
> <realm-name>Mariner Supply</realm-name>
> </login-config>
> <security-role>
> <role-name>intranet</role-name>
> </security-role>
> </web-app>
In production, we didn't want this security constraint.

- In our development environments, we specify a different name for the 
war file and we want to assign it to be the root application in the 
host.  For example, we have

> <web-app id="/" document-directory="webapps/go2marine_store"/>

On 03/22/2011 12:31 AM, Daniel López wrote:
> AFAIK, you either place the .war file in webapps or define the directory
> using an explicit web-app tag, but having both is not necessary and just
> seems to confuse Resin.
> S!
> D.
> El 22/03/2011 1:03, Keith Fetterman escribió:
>> I am experiencing a problem in resin 4.0.16 where resin is not expanding
>> the ROOT.war file if I explicitly define the root webapp in resin.xml
>> file.  In resin.xml, I have the tag "<web-app id="/"
>> root-directory="webapps/ROOT"/>" defined under my"<host>" tag.  I also
>> have the tag "<web-app-deploy path="webapps" versioning="true"/>"
>> defined under my "<host-default>" tag.
>> When I update the ROOT.war file in my "webapps" directory, the war file
>> is not being expanded into the webapps/ROOT directory.  I have tried
>> both shutting down resin, updating the ROOT.war file and then starting
>> resin, and I've tried updating ROOT.war while resin is running.
>> If I remove the tag "<web-app id="/" root-directory="webapps/ROOT"/>"
>> from the resin.xml file, then ROOT.war expansion occurs.
>> Do I need to add an attribute to the<web-app id="/"
>> root-directory="webapps/ROOT"/>   tag to get the war file to expand?
>> Also, what is the difference between the attribute "root-directory" and
>> "document-directory" in the<web-app>   tag?  I noticed in the resin
>> documentation that "root-directory" is mentioned in the list of
>> attributes but "document-directory" is not on the following page:
>> But, if you look at the examples, they all show "<web-app id='/apache'
>> document-directory='/usr/local/apache/htdocs'>"
>> Thanks,
>> Keith
> _______________________________________________
> resin-interest mailing list

Keith Fetterman                        Direct: 206-319-9434
Mariner Supply, Inc.                   206-780-5670     

resin-interest mailing list

Reply via email to