What can / should I do next ?

On Friday, June 15, 2012 7:46:00 PM UTC+10, jms wrote:
>
>
> Oh sorry ... I can see I have django-evolution at  django-evolution==0.6.6.
> I did not see that earlier as I was looking at what's just on top or just 
> below the line "Django==1.3.1".
>
> Can I just install django-evolution via apt-get, which will install / 
> upgrade django-evolution as follows:
>
> $ sudo apt-get install -V python-django-evolution
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following extra packages will be installed:
>    python-django (1.3-2ubuntu1.1)
> Suggested packages:
>    python-psycopg2 (2.4.2-1)
>    python-psycopg ()
>    python-flup (1.0.2-1)
>    python-sqlite (1.0.1-8)
>    python-yaml (3.10-1)
> The following NEW packages will be installed:
>    python-django (1.3-2ubuntu1.1)
>    python-django-evolution (0+svn164-1)
> 0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
> Need to get 4,334 kB of archives.
> After this operation, 36.2 MB of additional disk space will be used.
> Do you want to continue [Y/n]? n
>
>
>
>
> On Friday, 15 June 2012 19:37:14 UTC+10, jms wrote:
>>
>> Hi,
>>
>> 1) ReviewBoard version
>>
>> I started with ReviewBoard 1.6.5 several months ago.
>> Then upgraded RB to 1.6.7.1 last week. The only other thing that I did at 
>> that time was install python-imaging via apt-get.
>> Now trying to upgrade RB to 1.6.9. This was after mysql was updated via 
>> apt-get.
>>
>> 2) django-evolution
>>
>> I am not quite familiar on how to figure out what modules and versions 
>> are installed with python, as I mostly just use apt-get in Ubuntu to 
>> install and update packages. Thus, ReviewBoard is an exception as it does 
>> not have a .deb file so I used the instructions from the reviewboard 
>> website, although I did install some packages on the required list via 
>> apt-get.
>>
>> If I run"dpkg --list | grep -i django", it returns nothing which is fair 
>> enough as I do not recall install django or django-evolution via apt-get. 
>> Apart from that, the reviewboard website did say to use easy_install to 
>> install all dependencies required by ReviewBoard. On hindsight, I should 
>> have use apt-get for django and django-evolution.
>>
>> If I run pip freeze, it tells me I don't have django-evolution at all !!, 
>> but I do have django installed. That is weird, as I would have assumed that 
>> the initial installation of ReviewBoard would have installed 
>> django-evolution. ( see pip freeze output below ).
>>
>> If I look at django evolutions from ReviewBoard's admin site, I can see 
>> 28 evolutions. ( See list of evolutions below from my RB's admin site ).
>>
>> ~# pip freeze
>> Warning: cannot find svn location for flup==1.0.3.dev-20110405
>> Warning: cannot find svn location for distribute==0.6.16dev-r0
>> Django==1.3.1
>> Djblets==0.6.19
>> MySQL-python==1.2.3
>> PIL==1.1.7
>> Pygments==1.5
>> ReviewBoard==1.6.9
>> apt-xapian-index==0.44
>> chardet==2.0.1
>> ## FIXME: could not find svn URL in dependency_links for this package:
>> distribute==0.6.16dev-r0
>> django-evolution==0.6.6
>> ## FIXME: could not find svn URL in dependency_links for this package:
>> flup==1.0.3.dev-20110405
>> iotop==0.4.3
>> lucene==2.3.1
>> paramiko==1.7.7.1
>> pycrypto==2.5
>> python-apt==0.8.0ubuntu9
>> python-dateutil==1.5
>> python-debian==0.1.20ubuntu2
>> python-ldap==2.3.13
>> python-memcached==1.48
>> pytz==2012b
>> recaptcha-client==1.0.6
>> wsgiref==0.1.2
>> xmldiff==0.6.10
>>
>>
>>
>>
>> On Friday, 15 June 2012 18:02:17 UTC+10, Christian Hammond wrote:
>>>
>>> Can you tell me what version of django-evolution is installed?
>>>
>>> What version of RB did you start with?
>>>
>>> Christian
>>>
>>>
>>> On Jun 14, 2012, at 22:20, jms <jesus.m.sa...@gmail.com> wrote:
>>>
>>> Hi,
>>>
>>> I got the same or similar problem when upgrading reviewboard site ( 
>>> rb-site upgrade ) from 1.6.7.1 to 1.6.9.
>>>
>>> easy_install worked OK, but it was rb-site upgrade that failed:
>>>
>>> # easy_install -U ReviewBoard
>>> Searching for ReviewBoard
>>> Reading http://pypi.python.org/simple/ReviewBoard/
>>> Reading http://www.reviewboard.org/
>>> Reading http://downloads.reviewboard.org/releases/ReviewBoard/1.5/
>>> Reading http://downloads.reviewboard.org/releases/ReviewBoard/1.6/
>>> Reading http://www.review-board.org/
>>> Reading http://downloads.review-board.org/releases/ReviewBoard/1.0/
>>> Reading http://downloads.review-board.org/releases/
>>> Best match: ReviewBoard 1.6.9
>>> Downloading 
>>> http://downloads.reviewboard.org/releases/ReviewBoard/1.6/ReviewBoard-1.6.9-py2.7.egg
>>> Processing ReviewBoard-1.6.9-py2.7.egg
>>> creating 
>>> /usr/local/lib/python2.7/dist-packages/ReviewBoard-1.6.9-py2.7.egg
>>> Extracting ReviewBoard-1.6.9-py2.7.egg to 
>>> /usr/local/lib/python2.7/dist-packages
>>> Removing ReviewBoard 1.6.7.1 from easy-install.pth file
>>> Adding ReviewBoard 1.6.9 to easy-install.pth file
>>> Installing rb-site script to /usr/local/bin
>>> Installing rbssh script to /usr/local/bin
>>>
>>> Installed 
>>> /usr/local/lib/python2.7/dist-packages/ReviewBoard-1.6.9-py2.7.egg
>>> Reading http://downloads.reviewboard.org/mirror/
>>> Processing dependencies for ReviewBoard
>>> Searching for Djblets==0.6.19
>>> Reading http://pypi.python.org/simple/Djblets/
>>> Reading http://www.review-board.org/wiki/Djblets
>>> Reading http://downloads.review-board.org/releases/Djblets/0.6/
>>> Reading http://www.reviewboard.org/wiki/Djblets
>>> Reading http://downloads.review-board.org/releases/Djblets/0.5/
>>> Best match: Djblets 0.6.19
>>> Downloading 
>>> http://downloads.reviewboard.org/releases/Djblets/0.6/Djblets-0.6.19-py2.7.egg
>>> Processing Djblets-0.6.19-py2.7.egg
>>> creating /usr/local/lib/python2.7/dist-packages/Djblets-0.6.19-py2.7.egg
>>> Extracting Djblets-0.6.19-py2.7.egg to 
>>> /usr/local/lib/python2.7/dist-packages
>>> Removing Djblets 0.6.18 from easy-install.pth file
>>> Adding Djblets 0.6.19 to easy-install.pth file
>>>
>>>
>>> # rb-site upgrade /var/www/reviews.aas.priv/
>>> Rebuilding directory structure
>>> Updating database. This may take a while.
>>> Creating tables ...
>>> Upgrading Review Board from 1.6.7.1 to 1.6.9
>>> Project signature has changed - an evolution is required
>>> Installing custom SQL ...
>>> Installing indexes ...
>>> No fixtures found.
>>> The stored evolutions do not completely resolve all model changes.
>>> Run `./manage.py evolve --hint` to see a suggestion for the changes 
>>> required.
>>>
>>> The following are the changes that could not be resolved:
>>> In model scmtools.Repository:
>>>     Field 'extra_data' has been added
>>>     Field 'hosting_account' has been added
>>> Error: Your models contain changes that Django Evolution cannot resolve 
>>> automatically.
>>>
>>> Thus for now, I have not restarted apache or memcached, and the 
>>> reviewboard website still says 1.6.7.1
>>>
>>> One thing that happened before the upgrade of reviewboard ( before 
>>> easy_install -U  ReviewBoard  ) was that mysql was updated via apt-get:
>>>
>>> From /var/log/apt/history.log:
>>>
>>> Start-Date: 2012-06-15  14:44:20
>>> Commandline: apt-get upgrade -V
>>> Upgrade: mysql-server:amd64 (5.1.62-0ubuntu0.11.10.1, 
>>> 5.1.63-0ubuntu0.11.10.1), libapparmor-perl:amd64 
>>> (2.7.0~beta1+bzr1774-1ubuntu2, 2.7.0~beta1+bzr1774-1ubuntu2.1), 
>>> libmysqlclient-dev:amd64 (5.1.62-0ubuntu0.11.10.1, 
>>> 5.1.63-0ubuntu0.11.10.1), mysql-server-core-5.1:amd64 
>>> (5.1.62-0ubuntu0.11.10.1, 5.1.63-0ubuntu0.11.10.1), libmysqlclient16:amd64 
>>> (5.1.62-0ubuntu0.11.10.1, 5.1.63-0ubuntu0.11.10.1), 
>>> mysql-client-core-5.1:amd64 (5.1.62-0ubuntu0.11.10.1, 
>>> 5.1.63-0ubuntu0.11.10.1), mysql-client:amd64 (5.1.62-0ubuntu0.11.10.1, 
>>> 5.1.63-0ubuntu0.11.10.1), linux-tools-common:amd64 (3.0.0-20.34, 
>>> 3.0.0-21.35), linux-libc-dev:amd64 (3.0.0-20.34, 3.0.0-21.35), 
>>> mysql-common:amd64 (5.1.62-0ubuntu0.11.10.1, 5.1.63-0ubuntu0.11.10.1), 
>>> mysql-server-5.1:amd64 (5.1.62-0ubuntu0.11.10.1, 5.1.63-0ubuntu0.11.10.1), 
>>> mysql-client-5.1:amd64 (5.1.62-0ubuntu0.11.10.1, 5.1.63-0ubuntu0.11.10.1)
>>> End-Date: 2012-06-15  14:45:11
>>>
>>> Regards,
>>>
>>> John
>>>
>>> On Tuesday, 12 June 2012 18:14:46 UTC+10, Antti Paajoki wrote:
>>>>
>>>> Hi,
>>>>
>>>> We've been happily running reviewboard for some time and now tried to 
>>>> upgrade from 1.6.4.1 to 1.6.8.
>>>> Unfortunately, it was not a immediate success.
>>>>
>>>> Reviewboard upgrade with easy_install goes without errors, but the site 
>>>> upgrade fails during Django Evolution.
>>>>
>>>> [start of log]
>>>>
>>>> $ rb-site upgrade /path/to/reviewboard
>>>> Rebuilding directory structure
>>>> Updating database. This may take a while.
>>>> /usr/local/lib/python2.6/dist-packages/Django-1.3.1-py2.6.egg/django/db/__init__.py:60:
>>>>  
>>>> DeprecationWarning: Short names for ENGINE in database configurations are 
>>>> deprecated. Prepend default.ENGINE with 'django.db.backends.'
>>>>   DeprecationWarning
>>>> Creating tables ...
>>>> Creating table hostingsvcs_hostingserviceaccount
>>>> Upgrading Review Board from 1.6.4.1 to 1.6.8
>>>> There are unapplied evolutions for scmtools.
>>>> Adding baseline version for new models
>>>> Project signature has changed - an evolution is required
>>>> Installing custom SQL ...
>>>> Installing indexes ...
>>>> No fixtures found.
>>>> /usr/local/lib/python2.6/dist-packages/pycrypto-2.3-py2.6-linux-x86_64.egg/Crypto/Util/randpool.py:40:
>>>>  
>>>> RandomPool_DeprecationWarning: This application uses RandomPool, which is 
>>>> BROKEN in older releases.  See http://www.pycrypto.org/randpool-broken
>>>>   RandomPool_DeprecationWarning)
>>>> The stored evolutions do not completely resolve all model changes.
>>>> Run `./manage.py evolve --hint` to see a suggestion for the changes 
>>>> required.
>>>>
>>>> The following are the changes that could not be resolved:
>>>> In model reviews.Comment:
>>>>     Field 'issue_opened' has been added
>>>>     Field 'issue_status' has been added
>>>> In model reviews.Review:
>>>>     Field 'file_attachment_comments' has been added
>>>> In model reviews.ReviewRequest:
>>>>     Field 'inactive_file_attachments' has been added
>>>>     Field 'file_attachments' has been added
>>>> In model reviews.ScreenshotComment:
>>>>     Field 'issue_opened' has been added
>>>>     Field 'issue_status' has been added
>>>> In model reviews.ReviewRequestDraft:
>>>>     Field 'inactive_file_attachments' has been added
>>>>     Field 'file_attachments' has been added
>>>> In model accounts.Profile:
>>>>     Field 'is_private' has been added
>>>> Error: Your models contain changes that Django Evolution cannot resolve 
>>>> automatically.
>>>>
>>>> [end of log]
>>>>
>>>> Running `./manage.py evolve --hint` from the .egg/reviewboard directory 
>>>> yields:
>>>> 'Unable to import settings_local.py: No module named settings_local'
>>>>
>>>> The file settings_local.py is at the reviewboard site directory, and 
>>>> symlinking it under .egg/reviewboard/ changes the result so that the 
>>>> `./manage.py evolve --hint` seems to run correctly. However, rb-site 
>>>> upgrade does work any better.
>>>>
>>>> Apparently running the evolution manually with parameters '--hint 
>>>> --execute' would be a Really Bad Idea, so I did not try that.
>>>>
>>>> So it would seem that the problem would be related to the upgrade 
>>>> script being unable to locate the settings_local.py correctly, but I can't 
>>>> pinpoint where the problem lies. Any ideas?
>>>>
>>>> Environment details:
>>>> Linux 2.6.32-21-server #32-Ubuntu SMP Fri Apr 16 09:17:34 UTC 2010 
>>>> x86_64 GNU/Linux Ubuntu 10.04.4 LTS
>>>> Running the following versions: Apache (2.2.14-5ubuntu8.8), MySQL 
>>>> (5.1.41-3ubuntu12), Python (2.6.5-0ubuntu1)
>>>>
>>>> Upgrade history of reviewboard in this server:
>>>> 1.6beta1 -> 1.6 -> 1.6.4.1
>>>>
>>>> -Antti Paajoki
>>>>
>>>  -- 
>>> Want to help the Review Board project? Donate today at 
>>> http://www.reviewboard.org/donate/
>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>> -~----------~----~----~----~------~----~------~--~---
>>> To unsubscribe from this group, send email to 
>>> reviewboard+unsubscr...@googlegroups.com
>>> For more options, visit this group at 
>>> http://groups.google.com/group/reviewboard?hl=en
>>>
>>>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to