Hi Team, Please provide any pointers on this, how can i debug ? thanks , satish
On Thursday, 14 March 2013 18:38:04 UTC+5:30, satish singh wrote: > > Hi Sir, > > I have added mod_wsgi configuration, still facing the same issue: > > The Review Board 1.7.5 is up but images, CSS and JS files are not getting > loaded. I'm getting 404 errors for anything under /static. Screenshot > attached. It’s strange when I ran findstatic management command it’s > seems to find the static media. But review board doesn’t seem to find it. > > Log: > > (RB1.7.5)bash-3.2$ python ./reviewboard/manage.py findstatic > rb/images/convo.png > > Found 'rb/images/convo.png' here: > > > /u/satish3/envs/RB1.7.5/lib/python2.7/site-packages/ReviewBoard-1.7.5-py2.7.egg/reviewboard/static/rb/images/convo.png > > My Apache 2 configuration (httpd.conf): > > LoadModule wsgi_module modules/mod_wsgi.so > > <VirtualHost *:80> > > ServerName toolsnb01-06.lab.eng.btc.netapp.in > > DocumentRoot "/var/www/ReviewBoard175.com/htdocs" > > > > # Error handlers > > ErrorDocument 500 /errordocs/500.html > > > > WSGIPassAuthorization On > > WSGIScriptAlias "/" > "/var/www/ReviewBoard175.com/htdocs/reviewboard.wsgi/" > > > > <Directory "/var/www/ReviewBoard175.com/htdocs"> > > AllowOverride All > > Options -Indexes +FollowSymLinks > > Allow from all > > </Directory> > > > > # Alias static media requests to filesystem > > Alias /media "/var/www/ReviewBoard175.com/htdocs/media" > > Alias /static "/var/www/ReviewBoard175.com/htdocs/static" > > Alias /errordocs "/var/www/ReviewBoard175.com/htdocs/errordocs" > > Alias /favicon.ico > "/var/www/ReviewBoard175.com/htdocs/static/rb/images/favicon.png" > > </VirtualHost>. > > > > Please provide some pointers on this. I am stuck with this. > > One more question how difficult is it to migrate a ReviewBoard using > mod_python to use mod_wsgi ? > > > > Thanks, > > Satish. > > > > > > > > > On Wednesday, 13 March 2013 00:30:37 UTC+5:30, Christian Hammond wrote: >> >> In confused about your configuration. I don't even see how Review Board >> ever gets invoked. No mod_wsgi configuration. >> >> Christian >> >> >> On Mar 12, 2013, at 8:02, satish singh <[email protected]> wrote: >> >> Hi Joe, >> >> I am facing the same issue, can you please help me with it. >> My Apache 2 configuration: >> >> <VirtualHost *:80> >> ServerName toolsnb01-06.lab.eng.btc.netapp.in >> DocumentRoot "/var/www/ReviewBoard175.com/htdocs" >> >> # Error handlers >> ErrorDocument 500 /errordocs/500.html >> >> <Directory "/var/www/ReviewBoard175.com/htdocs"> >> AllowOverride All >> Options -Indexes +FollowSymLinks >> Allow from all >> </Directory> >> >> <Location "/media"> >> SetHandler None >> </Location> >> >> <Location "/errordocs"> >> SetHandler None >> </Location> >> >> <Location "/static"> >> SetHandler None >> </Location> >> # Alias static media requests to filesystem >> Alias /media "/var/www/ReviewBoard175.com/htdocs/media" >> Alias /static "/var/www/ReviewBoard175.com/htdocs/static" >> Alias /errordocs "/var/www/ReviewBoard175.com/htdocs/errordocs" >> Alias /favicon.ico "/var/www/ >> ReviewBoard175.com/htdocs/static/rb/images/favicon.png" >> </VirtualHost> >> >> Any help would be appreciated. >> >> On Tuesday, 18 December 2012 09:45:32 UTC+5:30, Joe Attardi wrote: >>> >>> I updated my site to 1.7.0.1-py2.7 and I'm still getting 404 errors for >>> anything under /static >>> >>> I added the alias for /static and restarted Apache 2, but it seems to >>> have no effect. Am I missing something obvious? >>> >>> My Apache 2 configuration: >>> >>> <VirtualHost *:80> >>> ServerName uxworks-reviewboard.mysite.com >>> DocumentRoot "/var/www/uxworks-reviewboard/htdocs" >>> >>> # Error handlers >>> ErrorDocument 500 /errordocs/500.html >>> >>> # Serve django pages >>> <Location "/"> >>> PythonPath "['/var/www/uxworks-reviewboard/conf'] + >>> sys.path" >>> SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings >>> SetEnv PYTHON_EGG_CACHE >>> "/var/www/uxworks-reviewboard/tmp/egg_cache" >>> SetEnv HOME "/var/www/uxworks-reviewboard/data" >>> SetHandler mod_python >>> PythonHandler django.core.handlers.modpython >>> PythonAutoReload Off >>> PythonDebug Off >>> # Used to run multiple mod_python sites in the same >>> apache >>> PythonInterpreter reviewboard_uxworks-reviewboard >>> </Location> >>> >>> # Serve static media without running it through mod_python >>> # (overrides the above) >>> <Location "/media"> >>> SetHandler None >>> </Location> >>> <Location "/errordocs"> >>> SetHandler None >>> </Location> >>> >>> <Directory "/var/www/uxworks-reviewboard/htdocs"> >>> AllowOverride All >>> </Directory> >>> >>> # Alias static media requests to filesystem >>> Alias /media "/var/www/uxworks-reviewboard/htdocs/media" >>> Alias /errordocs "/var/www/uxworks-reviewboard/htdocs/erordocs" >>> Alias /static "/var/www/uxworks-reviewboard/htdocs/static" >>> </VirtualHost> >>> >>> I tried running rb-site manage /var/www/uxworks-reviewboard >>> resolve-check static-media but it gave me an error: Couldn't find >>> manual update check 'static-media' >>> >>> Any help would be appreciated. Thanks! >>> >> -- >> Want to help the Review Board project? Donate today at >> http://www.reviewboard.org/donate/ >> Happy user? Let us know at http://www.reviewboard.org/users/ >> -~----------~----~----~----~------~----~------~--~--- >> To unsubscribe from this group, send email to >> [email protected] >> For more options, visit this group at >> http://groups.google.com/group/reviewboard?hl=en >> --- >> You received this message because you are subscribed to the Google Groups >> "reviewboard" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to [email protected]. >> For more options, visit https://groups.google.com/groups/opt_out. >> >> >> >> -- Want to help the Review Board project? Donate today at http://www.reviewboard.org/donate/ Happy user? Let us know at http://www.reviewboard.org/users/ -~----------~----~----~----~------~----~------~--~--- To unsubscribe from this group, send email to [email protected] For more options, visit this group at http://groups.google.com/group/reviewboard?hl=en --- You received this message because you are subscribed to the Google Groups "reviewboard" group. To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]. For more options, visit https://groups.google.com/groups/opt_out.
