Run 'svn info' in your local checkout and see what Repository Root is. If
it's https://SvnServer/SvnDirectory/, then there should be only one
repository entry for that. All the others are just there to cause problems.
That would be why your rbt post is broken.

I suspect that that's the case.

If that is the case, what you want to do is set up the SvnDirectory one and
mark all the other ones as invisible so they won't be used anymore. They
won't break existing review requests, since they'll still be in the
database, but RBTools won't look at them anymore.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
Beanbag, Inc. - http://www.beanbaginc.com


On Wed, Jan 15, 2014 at 1:23 PM, Zachary Gallagher <
zachary.gallag...@remcom.com> wrote:

> The reason there is a *SvnDirectory* at all is because there are multiple
> 'repositories' under it, all with their own branches and trunks. I put
> repositories in air quotes because I'm not sure if those branches/trunks
> parent directories are themselves the repositories, or if "repository"
> exclusively refers to the entire package.
>
>
> On Wednesday, January 15, 2014 4:21:11 PM UTC-5, Zachary Gallagher wrote:
>>
>> So this very last issue... (An optimistic claim)
>>
>> DEBUG:root:Got API Error 207 (HTTP code 400): The file was not found in
>>> the repository
>>> DEBUG:root:Error data: {u'stat': u'fail', u'file': u'/*RepositoryName*
>>> /branches/20131209-repo-P14/dev/src/modelLibraries/VTRPEAdapter/Makefile',
>>> u'err': {u'msg': u'The file was not found in the repository', u'code':
>>> 207}, u'revision': u'15168'}
>>> Traceback (most recent call last):
>>>   File "/usr/bin/rbt", line 9, in <module>
>>>     load_entry_point('RBTools==0.5.5', 'console_scripts', 'rbt')()
>>>   File 
>>> "/usr/lib/python2.6/site-packages/RBTools-0.5.5-py2.6.egg/rbtools/commands/main.py",
>>> line 127, in main
>>>     command.run_from_argv([RB_MAIN] + args)
>>>   File "/usr/lib/python2.6/site-packages/RBTools-0.5.5-py2.6.
>>> egg/rbtools/commands/__init__.py", line 158, in run_from_argv
>>>     exit_code = self.main(*args) or 0
>>>   File 
>>> "/usr/lib/python2.6/site-packages/RBTools-0.5.5-py2.6.egg/rbtools/commands/post.py",
>>> line 659, in main
>>>     submit_as=self.options.submit_as)
>>>   File 
>>> "/usr/lib/python2.6/site-packages/RBTools-0.5.5-py2.6.egg/rbtools/commands/post.py",
>>> line 534, in post_request
>>>     raise CommandError('\n'.join(error_msg))
>>> rbtools.commands.CommandError: Error uploading diff
>>>
>>> The file was not found in the repository (HTTP 400, API Error 207)
>>> Your review request still exists, but the diff is not attached.
>>
>>
>>
>> The file *is* there on the machine. The absolute path is
>>
>> /dfs/*User*/*RepositoryName*_nrl_p14/dev/src/modelLibraries/
>> VTRPEAdapter/Makefile
>>
>> And the path in svn is
>>
>> https://*SvnServer*/*SvnDirectory*/*RepositoryName*/branches/
>> 20131209-repo-P14/dev/src/modelLibraries/VTRPEAdapter/Makefile
>>
>>
>>
>> Any idea what's going on? I'm running "rbt post" from
>>
>> /dfs/*User*/*RepositoryName*_nrl_p14/
>>
>> and "Repository" in .reviewboardrc is set to the single word
>> *"RepositoryName."*
>>
>>
>> The slight confusion is that (and I didn't do this, so I'm not sure if it
>> was right or not at the time)
>>
>> as noted above, these are the repositories in ReviewBoard
>>
>>
>>
>>  Repository
>> Path <http://mercury/admin/db/scmtools/repository/?o=2>
>> Hosting
>> Show this repository <http://mercury/admin/db/scmtools/repository/?o=4>
>>  SvnDirectoryhttps://*SvnServer*/*SvnDirectory*/  [image: True]
>> RepositoryName_20131209-repo-P14https://*SvnServer*/*SvnDirectory*/
>> *RepositoryName*/branches/20131209-repo-P14  [image: True]
>> RepositoryName-Trunkhttps://*SvnServer*/*SvnDirectory*/*RepositoryName*
>> /trunk  [image: True] Results Viewerhttps://*SvnServer*/*SvnDirectory*
>> /results_viewer/trunk/  [image: False]  RepositoryName
>> https://*SvnServer*/*SvnDirectory*/*RepositoryName*/  [image: False]
>>
>> 5 Repositories
>>
>>
>> So I don't even know which one "rbt post" is trying to attach this to.
>> The second? Or fifth? Maybe the first?
>>
>>
>>
>>
>> On Wednesday, January 15, 2014 4:11:03 PM UTC-5, Christian Hammond wrote:
>>>
>>> No worries. We used to redirect calls like /api/repositories to
>>> /api/repositories/, but got rid of it.
>>>
>>> The base path is everything between the root of the repository and where
>>> the diff was taken.
>>>
>>> So basically, if you are in /trunk/myproject, and you run 'svn diff' (or
>>> 'rbt post', which runs it for you), the base path is /trunk/myproject.
>>>
>>> This requires that the repository entry is set up properly on Review
>>> Board. It must always point to the very root of a Subversion repository,
>>> and not a directory inside it.
>>>
>>> Christian
>>>
>>> --
>>> Christian Hammond - chi...@chipx86.com
>>> Review Board - http://www.reviewboard.org
>>> Beanbag, Inc. - http://www.beanbaginc.com
>>>
>>>
>>> On Wed, Jan 15, 2014 at 1:08 PM, Zachary Gallagher <
>>> zachary....@remcom.com> wrote:
>>>
>>>> Oh.
>>>>
>>>> Ok, well, that's embarrassing.
>>>>
>>>> But now I have a new error. And it's part of what my issue was before.
>>>> When Subversion speaks of "base path." Does that refer to the parent
>>>> directory of branches/, trunk/, etc. Or the parent directory of *that* 
>>>> directory.
>>>> It's something that's apparently so basic that I can't even find
>>>> information on it. I was told that the repositories had to be "base paths".
>>>>
>>>> The error I'm getting now is
>>>>
>>>>
>>>> DEBUG:root:Error data: {u'stat': u'fail', u'file': u'/*RepositoryName*
>>>> /branches/20131209-repo-P14/dev/src/modelLibraries/Adapter/Makefile',
>>>> u'err': {u'msg': u'The file was not found in the repository', u'code':
>>>> 207}, u'revision': u'15168'}
>>>>
>>>> I think it's because the checkout is actually a directory of branches.
>>>> But it's somehow trying to act like this is the base path.
>>>>
>>>>
>>>>
>>>>
>>>> On Wednesday, January 15, 2014 3:55:20 PM UTC-5, David Trowbridge wrote:
>>>>
>>>>> I mean in the repository configuration in the reviewboard admin.
>>>>>
>>>>> -David
>>>>>
>>>>> On Jan 15, 2014, at 12:49 PM, Zachary Gallagher <
>>>>> zachary....@remcom.com> wrote:
>>>>>
>>>>> I can log in with
>>>>>
>>>>> gallagher
>>>>>
>>>>> password
>>>>>
>>>>>
>>>>> But I can't run *rbt post* with it.
>>>>>
>>>>> --
>>>>> Get the Review Board Power Pack at http://www.reviewboard.org/pow
>>>>> erpack/
>>>>> ---
>>>>> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
>>>>> ---
>>>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>>>> ---
>>>>> You received this message because you are subscribed to the Google
>>>>> Groups "reviewboard" group.
>>>>> To unsubscribe from this group and stop receiving emails from it, send
>>>>> an email to reviewboard...@googlegroups.com.
>>>>>
>>>>> For more options, visit https://groups.google.com/groups/opt_out.
>>>>>
>>>>>  --
>>>> Get the Review Board Power Pack at http://www.reviewboard.org/
>>>> powerpack/
>>>> ---
>>>> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
>>>> ---
>>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>>> ---
>>>> You received this message because you are subscribed to the Google
>>>> Groups "reviewboard" group.
>>>> To unsubscribe from this group and stop receiving emails from it, send
>>>> an email to reviewboard...@googlegroups.com.
>>>> For more options, visit https://groups.google.com/groups/opt_out.
>>>>
>>>
>>>  --
> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> ---
> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> ---
> Happy user? Let us know at http://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to