Hello David Ribeiro Alves, Adar Dembo, Kudu Jenkins,

I'd like you to reexamine a change.  Please visit

    http://gerrit.cloudera.org:8080/5193

to look at the new patch set (#4).

Change subject: bshuf_block: some code cleanup
......................................................................

bshuf_block: some code cleanup

* Some typo/grammar fixes/reformatting in comments.
* Rename kMaxHeaderSize to kHeaderSize since the header is fixed-length.
* Adds a private cell_ptr() function instead of error prone indexing
  with multiplication into the data_ buffer.
* Remove an unnecessarily UINT32 specialization
* Fix some C-style casts and unnecessary type punning in favor of
  memcpy()

This partially fixes a bug with GetLastKey: previously we were
mistakenly indexing into data_[count - 1] instead of
data_[(count - 1) * size_of_type] which caused incorrect results.

There is still another bug here in GetLastKey() which will be fixed in
the next commit.

Change-Id: I6857f8096319072eb09be097adea99c45735e0a6
---
M src/kudu/cfile/bshuf_block.cc
M src/kudu/cfile/bshuf_block.h
2 files changed, 82 insertions(+), 62 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/93/5193/4
-- 
To view, visit http://gerrit.cloudera.org:8080/5193
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I6857f8096319072eb09be097adea99c45735e0a6
Gerrit-PatchSet: 4
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Todd Lipcon <t...@apache.org>
Gerrit-Reviewer: Adar Dembo <a...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <dral...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot

Reply via email to