-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/42476/#review115127
-----------------------------------------------------------

Ship it!



include/mesos/quota/quota.proto (line 53)
<https://reviews.apache.org/r/42476/#comment175991>

    Does it make sense to use this protobuf as well in 
master_quota_tests.cpp::createRequestBody?



include/mesos/quota/quota.proto (line 54)
<https://reviews.apache.org/r/42476/#comment175985>

    Given the naming scheme QuotaStatus wouldn't a more consistent name be 
QuotaSet?



include/mesos/quota/quota.proto (line 56)
<https://reviews.apache.org/r/42476/#comment175989>

    I feel that optimizing here (with = 16) is more confusing than helpful, 
especially as this protobuf is mostly used as the schema for the json request.



src/master/quota_handler.cpp (line 246)
<https://reviews.apache.org/r/42476/#comment175990>

    Not an issue, but question/remark: the protoRequest.error() is most likely 
to be less concise compared to the previous error messages?


- Joerg Schad


On Jan. 18, 2016, 11:37 p.m., Alexander Rukletsov wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/42476/
> -----------------------------------------------------------
> 
> (Updated Jan. 18, 2016, 11:37 p.m.)
> 
> 
> Review request for mesos, Ben Mahler, Joerg Schad, and Joris Van Remoortere.
> 
> 
> Bugs: MESOS-4410
>     https://issues.apache.org/jira/browse/MESOS-4410
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> See summary.
> 
> 
> Diffs
> -----
> 
>   docs/quota.md 1a6d2f07fb74d168a7eb30764ab9ff80cea5e3b6 
>   include/mesos/quota/quota.proto 338412ee967e14aa1957a47f4a50f2e19e4eca79 
>   src/master/quota_handler.cpp f44736cd5849d4fb22a75c1238d433a1c0c9708d 
>   src/tests/master_quota_tests.cpp e8cb074c2913cafdc6b1792896f29e53f1210c9d 
>   src/tests/role_tests.cpp 979391306e2427aaa63a5df32704913f79e20e36 
> 
> Diff: https://reviews.apache.org/r/42476/diff/
> 
> 
> Testing
> -------
> 
> make check on Mac OS 10.10.4
> 
> 
> Thanks,
> 
> Alexander Rukletsov
> 
>

Reply via email to