-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45604/#review128539
-----------------------------------------------------------




src/examples/balloon_executor.cpp (line 45)
<https://reviews.apache.org/r/45604/#comment191972>

    What is the "balloonLimit"?
    
    s/balloonLimit/upper limit/ ?



src/examples/balloon_executor.cpp (line 133)
<https://reviews.apache.org/r/45604/#comment191973>

    s/run/run multiple/



src/examples/balloon_executor.cpp 
<https://reviews.apache.org/r/45604/#comment192002>

    Why the change here?



src/examples/balloon_framework.cpp (lines 60 - 81)
<https://reviews.apache.org/r/45604/#comment192001>

    The interaction between these flags is a bit unclear.
    
    If some doesn't set `task_memory` but sets `balloon_limit`, the container 
might or might not OOM. It depends on how much is offerred to the scheduler. I 
would rather make this a required field. Infact, I would also add a required 
flag for executor memory (--executor_memory).
    
    Also s/balloon_limit/executor_memory_usage/ for clarity.



src/examples/balloon_framework.cpp (lines 98 - 102)
<https://reviews.apache.org/r/45604/#comment191985>

    Whether a framework wants checkpointing vs whether it should launch  more 
than one task seems like orthogonal issues. Why club them inside one flag?



src/examples/balloon_framework.cpp (lines 235 - 253)
<https://reviews.apache.org/r/45604/#comment191986>

    why the explicit listing of terminal states rather than what we had before? 
that is future proof if we add new terminal states.



src/examples/balloon_framework.cpp (line 243)
<https://reviews.apache.org/r/45604/#comment191989>

    `taskLaunched` sounds like something that is not reset for every task 
launch.
    
    How about calling it `taskActive`?



src/examples/balloon_framework.cpp (line 246)
<https://reviews.apache.org/r/45604/#comment191994>

    NOTE: We expect TASK_FAILED when this scheduler is launched by 
balloon_framework_test.sh shell script. The abort here ensures the script 
considers the test resutl as 'PASS'.



src/examples/balloon_framework.cpp (line 301)
<https://reviews.apache.org/r/45604/#comment191982>

    This comment doesn't make sense?


- Vinod Kone


On April 11, 2016, 6:24 p.m., Joseph Wu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45604/
> -----------------------------------------------------------
> 
> (Updated April 11, 2016, 6:24 p.m.)
> 
> 
> Review request for mesos, Greg Mann, Artem Harutyunyan, Kevin Klues, and 
> Vinod Kone.
> 
> 
> Bugs: MESOS-5174
>     https://issues.apache.org/jira/browse/MESOS-5174
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This gives the example `balloon-framework` enough options to run
> outside of the build environment.
> 
> This also updates:
> 
> * The style of the framework code.
> * Adds an option for restricting the number of resources per task
>   (otherwise, it will eat up an entire node).
> * Adds an option for persisting the framework and launching one task
>   after another.
> * Adds filters for declined offers.
> * Refines the shutdown logic for the executor.  In particular, ironed 
>   out bugs when the balloon executor does not exceed the memory limit.
> 
> 
> Diffs
> -----
> 
>   src/examples/balloon_executor.cpp 399218478a596387814d123290eeeb33102fad7a 
>   src/examples/balloon_framework.cpp 15c45612b777edaf97aea9b953439d4ad56920f3 
>   src/tests/balloon_framework_test.sh 
> ae32753e8942f77f94752543c384d218d6e4d48d 
> 
> Diff: https://reviews.apache.org/r/45604/diff/
> 
> 
> Testing
> -------
> 
> ```
> make check 
> 
> sudo bin/mesos-tests.sh --gtest_filter="*ROOT_CGROUPS_BalloonFramework"
> ```
> 
> 
> Thanks,
> 
> Joseph Wu
> 
>

Reply via email to