-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/61493/#review182775
-----------------------------------------------------------




src/tests/default_executor_tests.cpp
Lines 1436 (patched)
<https://reviews.apache.org/r/61493/#comment258770>

    Please use:
    
    `EXPECT_FALSE(offers1->offers().empty());`



src/tests/default_executor_tests.cpp
Lines 1451-1452 (patched)
<https://reviews.apache.org/r/61493/#comment258772>

    What do you think about the following alternative?
    
    `v1::TaskGroupInfo taskGroup = v1::createTaskGroupInfo({taskInfo})`



src/tests/default_executor_tests.cpp
Lines 1465-1481 (patched)
<https://reviews.apache.org/r/61493/#comment258773>

    I think that the following is shorter and more readable:
    
    ```
    v1::Offer::Operation launchGroup = v1::LAUNCH_GROUP(
        executorInfo,
        v1::createTaskGroupInfo({taskInfo}));
        
    mesos.send(v1::createCallAccept(
        frameworkId,
        offer1,
        {launchGroup}));
    ```



src/tests/default_executor_tests.cpp
Lines 1491 (patched)
<https://reviews.apache.org/r/61493/#comment258771>

    Add
    
    `EXPECT_FALSE(offers2->offers().empty());`



src/tests/default_executor_tests.cpp
Lines 1503-1504 (patched)
<https://reviews.apache.org/r/61493/#comment258774>

    Ditto.



src/tests/default_executor_tests.cpp
Lines 1511-1529 (patched)
<https://reviews.apache.org/r/61493/#comment258775>

    Ditto.



src/tests/default_executor_tests.cpp
Lines 1547 (patched)
<https://reviews.apache.org/r/61493/#comment258776>

    Remove this extra line.


- Gastón Kleiman


On Aug. 8, 2017, 9:44 a.m., Qian Zhang wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/61493/
> -----------------------------------------------------------
> 
> (Updated Aug. 8, 2017, 9:44 a.m.)
> 
> 
> Review request for mesos, Gastón Kleiman, Gilbert Song, Jie Yu, Kevin Klues, 
> and Vinod Kone.
> 
> 
> Bugs: MESOS-7853
>     https://issues.apache.org/jira/browse/MESOS-7853
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added a test `DefaultExecutorTest.MultiTaskgroupSharePidNamespace`.
> 
> 
> Diffs
> -----
> 
>   src/tests/default_executor_tests.cpp 
> b9776314a8781963b92ba9ac297654f61a443bc8 
> 
> 
> Diff: https://reviews.apache.org/r/61493/diff/1/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Qian Zhang
> 
>

Reply via email to