Github user HyukjinKwon commented on a diff in the pull request:
    --- Diff: 
    @@ -39,9 +39,12 @@ private[text] class TextOptions(@transient private val 
parameters: CaseInsensiti
       val wholeText = parameters.getOrElse(WHOLETEXT, "false").toBoolean
    +  val lineSeparator: String = parameters.getOrElse(LINE_SEPARATOR, "\n")
    +  require(lineSeparator.nonEmpty, s"'$LINE_SEPARATOR' cannot be an empty 
     private[text] object TextOptions {
       val COMPRESSION = "compression"
       val WHOLETEXT = "wholetext"
    +  val LINE_SEPARATOR = "lineSep"
    --- End diff --
    Actually, I am not sure why we so care about this naming. I think all 
recordSeparator, recordSep, lineSeperator and lineSep are all fine actually. 
lineSep was choosen to be consistent at my best. 


To unsubscribe, e-mail:
For additional commands, e-mail:

Reply via email to