Hi Ralph

Ralph Corderoy <ra...@inputplus.co.uk> wrote:

> Hi David,
> 
> >
https://wiki.archlinux.org/index.php/Step-by-step_debugging_guide#Segmentation_faults
> >
> > and read about rdb and then ran the command.  Here is the result of my
> > attempt to do something correctly!
> 
> Yep, you did it right.

Thank goodness for that!
 
[snip]
> > Thread 1 "rpcemu" received signal SIGSEGV, Segmentation fault.
> > 0x00005555570becba in rcodeblock () (gdb) bt full #0
> > 0x00005555570becba in rcodeblock () No symbol table info available. #1
> > 0x00007fffffffdf70 in ?? () No symbol table info available. #2
> > 0x0000000000000000 in ?? () No symbol table info available. (gdb)
> 
> I think this is saying the fault occurs in the generated-on-the-fly
> machine code to emulate some ARM instructions, so I wouldn't expect that
> next section on "more detail" to help.
> 
> https://marutan.net/rpcemu/linuxcompile.html has a note at the start
> about Ubuntu 16.10 needing CFLAGS=-no-pie.  I suspect this may now be
> true of Debian also.  So try that, going back to the configure stage.

Went to the website suggested and did as suggested (CFLAGS=-no-pie
./configure --enable-dynarec --enable-debug)and got a response

too many arguments

but unfortunately did not save the output.

I then tried without the configuration options (i.e. just the
CFLAGS=-no-pie) and was returned to

zed@zed-pc:~/rpcemu-0.8.15$ CFLAGS=-no-pie

I then started again and got the following output

zed@zed-pc:~$ cd /home/zed/rpcemu-0.8.15
zed@zed-pc:~/rpcemu-0.8.15$ CFLAGS=-no-pie ./configure --enable-dynarec
--enable-debug
bash: ./configure: No such file or directory
zed@zed-pc:~/rpcemu-0.8.15$ ./configure --enable-dynarec --enable-debug
bash: ./configure: No such file or directory
zed@zed-pc:~/rpcemu-0.8.15$ 

Would the fact that I did 

zed@zed-pc:~/rpcemu-0.8.15$ CFLAGS=-no-pie

have led to the output of No such file or directory?

I have checked and found that doing a cd <directory path> works on every
other Directory I've tried, other than /rpcemu-0.8.15 one.

As an aside, I have Linux Mint v18.2 Mate installed in another partition.
I booted into this and had no difficulty in installing rpcemu-0.8.15,
other than that the window which opened was very small and I could not
adjust it and there was only one screen resolution available.  I was able
to run !Draw and Paint! without problem, but could not open a floppy disc
containing !Drawfiles.  Just got an error asking whether the disc was
formatted!  That could be because when I upgraded this desktop a few years
ago, I've never checked whether the floppy disc drive was connected.

Again, thank you for staying with this.  All suggestions welcome.

Regards

David


-- 
zed
A friendly" program doesn't have a 600 page manual! 


_______________________________________________
Rpcemu mailing list
Rpcemu@riscos.info
http://www.riscos.info/cgi-bin/mailman/listinfo/rpcemu

Reply via email to