Ralph Corderoy <ra...@inputplus.co.uk> wrote:

[snip]
> > Went to the website suggested and did as suggested (CFLAGS=-no-pie
> > ./configure --enable-dynarec --enable-debug) and got a response too
> > many arguments but unfortunately did not save the output.
> 
> That response doesn't make a lot of sense, unless you're using some
> weird shell.  Does `echo $BASH_VERSION' display a useful
> version-number-ish value?

zed@zed-pc:~$ echo $BASH_VERSION
4.4.12(1)-release
zed@zed-pc:~$ 

and then

zed@zed-pc:~$ cd /home/zed/rpcemu-0.8.15/src CFLAGS=-no-pie ./configure
--enable-dynarec
bash: cd: too many arguments
zed@zed-pc:~$ 

So, again, I'mlost!

> > I then tried without the configuration options (i.e. just the
> > CFLAGS=-no-pie)
> 
> That would just set a variable in your shell.  Not an error, but no
> desired effect.

Glad that it didn't result in something which would bite me later.

> > zed@zed-pc:~$ cd /home/zed/rpcemu-0.8.15 zed@zed-pc:~/rpcemu-0.8.15$
> > CFLAGS=-no-pie ./configure --enable-dynarec --enable-debug bash:
> > ./configure: No such file or directory
> 
> Yes, start again.  You said at
> http://www.riscos.info/pipermail/rpcemu/2017-August/002526.html that you
> configured it just fine.  You need to repeat that, but with
> `CFLAGS=-no-pie' as a word before the ./configure.

I did that and got the 

bash: cd: too many arguments yet again

I then deleted the copy of rpcemu-0.8.15 and made another from my
Downloads Directory  to /home/zed

Decided to try David's option

zed@zed-pc:~$ cd /home/zed/Desktop/rpcemu-0.8.15/src
zed@zed-pc:~/Desktop/rpcemu-0.8.15/src$ ./configure CFLAGS=-no-pie
--enable-dynarec

zed@zed-pc:~/Desktop/rpcemu-0.8.15/src$ cd ..
zed@zed-pc:~/Desktop/rpcemu-0.8.15$ ./rpcemu
zed@zed-pc:~/Desktop/rpcemu-0.8.15$ 

and I have a working rpcemu.

Thank you Roy, for putting up with my "fumblings" and David for suggesting
I enter the source directory and enter ./configure before the CFLAGS
option which worked.  Obviously the originasl suggestion on the Maratun
website must work for others but just did not on Sparky Linux on my
computer, for some reason. Whatever, I am grateful to both of you for
leading me to a successful conclusion.

The most pressing question, at present, is: Is there any way to run rpcemu
other than through the terminal?

There will be many other questions from me in my attempt to re-learn RISC
OS (like how to enlarge the window which opens. How to change the screen
resolution, etc. etc but for the present, I'm like a "dog with two tails -
both wagging furiously"!

David

-- 
zed
Bigamy: Too many wives. Monogamy: Same thing.


_______________________________________________
Rpcemu mailing list
Rpcemu@riscos.info
http://www.riscos.info/cgi-bin/mailman/listinfo/rpcemu

Reply via email to