Thank you very much for your answer.
Pulse is indeed installed under Alsa - I thought it would make things easier ! 
I'll see this weekend if the problem is solved by using Alsa alone and making 
Hifiberry its default device.
Regarding Rygel+VLC, I did not understand that the MPRIS specifications indeed 
included a list of supported mime-types, sorry : I thought this option was only 
set in each media player configuration. At least I understand the problem, 
"G_MESSAGES_DEBUG=all rygel -g 5", only lists loaded profiles 
(AC3,EAC3,LPCM,AAC_ADTS_320, MP3,...but no FLAC, obviously). It's very 
long...and I think it ended before BubbleUpnp started sending anything (there 
is always a 1 second lag after I launch a track, before anything is actually 
Should I send it to you anyhow in a .txt file ?
And would BubbleUpnp's own log be of any use ? It's very long too. Among other 
things, it states :

[main (0)                    ] INFO     - 0:00:28.128    - AndroidUpnpService   
       : playItem: main thread
[main (0)                    ] INFO     - 0:00:28.129    - AndroidUpnpService   
       : force disable mime-type check due to FFmpeg transcoding possibly 
[main (0)                    ] INFO     - 0:00:28.130    - AbstractRenderer     
       : discarding unsupported mime-type: audio/flac
[main (0)                    ] INFO     - 0:00:28.131    - AbstractRenderer     
       : no playable resource was found for track '01 The Space Program.flac' 
to play on Lecteur multimédia VLC
[main (0)                    ] WARNING  - 0:00:28.132    - AbstractRenderer     
       : mime-type check disabled: returning first resource
[main (0)                    ] INFO     - 0:00:28.134    - AndroidUpnpService   
       : substituted play url
[main (0)                    ] INFO     - 0:00:28.135    - AndroidUpnpService   
       : selected item changed: 01 The Space Program.flac
[stop (29)                   ] INFO     - 0:00:28.242    - a                    
       : waitForTransportState: got transport state: Stopped
[stop (29)                   ] INFO     - 0:00:28.243    - AndroidUpnpService   
       : stop: worker thread took 137ms
[main (0)                    ] INFO     - 0:00:28.373    - NowPlayingFragment   
       : selected item changed: 01 The Space Program.flac
[stop (29)                   ] INFO     - 0:00:28.377    - AndroidUpnpService   
       : playItem: worker thread enter
[main (0)                    ] INFO     - 0:00:28.381    - AndroidUpnpService   
       : SetPlayNextItem: main thread"

Many thanks,

Le 08/02/2018 à 09:55, Jens Georg a écrit :

Depending on whether I use Playbin or VLC as the media player to which
Rygel transmits audio files, the issue is not exactly the same :
1) With Rygel+Playbin, no file may be heard, whether MP3 or FLAC. The
files seem to play (I can see the time line move as time goes by) but
there is no sound. I guess this means that Playbin should be so
configured as to recognize my HifiBerry soundcard. Are there any
options to do that ? All I see are options regarding Gstlaunch in
rygel.conf but I understand this configures a server, not a renderer
(and I tried anyway to add my soundcard and flac mime-types, according
to various tutorials, but no luck)

Sorry, I have a patch lying around to make the audio sink more configurable,
but I need to wrangle some documents before I can apply that upstream.

Basically what you could to is make the HifiBerry the "default" device
in ALSA if you are not using pulse underneath.

2) If I use VLC instead of playbin (by enabling MPRIS and disabling
Playbin in /home/pi/.config/rygel.conf, and then launching VLC before
Rygel), VLC reads perfectly the MP3 files but not the FLAC ones (701
code error : illegal mime-type).
I asked the developers of the BubbleUpnp app what should be done. They
answered that "The fix for FLAC for this Rygel/VLC renderer  is just
for developers to add the FLAC mime-type to the list. It's a 10s
I can play FLAC files from another computer to Rygel+VLC using
Foobar2000 : as Foobar2000 changes my FLACs into WAV (or PCM?) before
sending them to the Rpi. But BubbleUpnp does not this conversion.

Rygel uses org.mpris.MediaPlayer2.SupportedMimeTypes to query the remote
player. VLC does not expose a specific MIME type for flac, only the
generic "application/ogg":

readonly as SupportedMimeTypes = ['audio/mpeg', 'audio/x-mpeg', 'video/mpeg', 
'video/x-mpeg', 'video/mpeg-system', 'video/x-mpeg-system', 'video/mp4', 
'audio/mp4', 'video/x-msvideo', 'video/quicktime', 'application/ogg', 
'application/x-ogg', 'video/x-ms-asf', 'video/x-ms-asf-plugin', 
'application/x-mplayer2', 'video/x-ms-wmv', 'video/x-google-vlc-plugin', 
'audio/wav', 'audio/x-wav', 'audio/3gpp', 'video/3gpp', 'audio/3gpp2', 
'video/3gpp2', 'video/divx', 'video/flv', 'video/x-flv', 'video/x-matroska', 
'audio/x-matroska', 'application/xspf+xml'];

The issue is that VLC does not offer a specific FLAC mime type via MPRIS
so that will not match up with what BubbleUPnP sends as mime type for the

I cannot test here currently with BubbleUPnP due to network restrictions,
can you enable Debugging in Rygel (G_MESSAGES_DEBUG=all rygel -g 5) and
check what content-type BubbleUPnP is sending towards rygel? Maybe we need
to implement some generic matching towards application/ogg

rygel-list mailing list

Reply via email to