Hello Travis,

2014-12-03 0:24 UTC+01:00, Travis Scrimshaw <tsc...@ucdavis.edu>:
>    I strongly object to removing the function to_partition as it is useful
> to people (beyond FindStat), but I'm not opposed to renaming it to
> something like connected_components_partition.

I find your proposition too ambiguous. For me, I would expect that
such function returns the (set) partition induced on the set of
vertices... (which is just what connected_components does).

> Similar for to_graph.
> Although if you want to argue about removing "one-line" functions, we
> should also remove add_edges, add_vertices, delete_edges, delete_vertices,
> subdivide_edges, average_degree, average_distance, etc.

No. I am sorry if that was misinterpreted. One line methods like

map(len, self.connected_components())

or equivalently

[len(cc) for cc in self.connected_components()]

which are just standard Python are very different from

self._backend.add_edge(u, v, label, self._directed)

which strongly depends on the implementation of graphs in Sage. By
"one line function" I meant "one line function that anybody can
reproduce after one hour of Python".

> Also I cannot
> emphasize sufficiently that not all Sage users who use the graph code are
> graph theorists.

True. But I am not sure it helps to decide here (or I misunderstood
something hidden in your sentence)

Vincent

-- 
You received this message because you are subscribed to the Google Groups 
"sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to sage-devel+unsubscr...@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at http://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

Reply via email to