adding a PYTHON=python3 line in spkg-install seems to fix the version check 
issue

Le dimanche 6 août 2017 09:13:51 UTC+2, François Bissey a écrit :
>
> I have seen this strange thing before on this list I am sure. 
> For some reason the wrong thing ends up being passed to configure 
> and be tested. 
>
> A more brutal and effective way to force the issue is to edit 
> spkg-install for pynac. It will have to be done anyway. 
>
> > On 6/08/2017, at 19:09, Frédéric Chapoton <fchap...@gmail.com 
> <javascript:>> wrote: 
> > 
> > configure:3249: checking whether 
> /home/chapoton/sage3/local/var/lib/sage/installed/python3-3.6.1 version is 
> >= 2.7 
> > configure:3260: 
> /home/chapoton/sage3/local/var/lib/sage/installed/python3-3.6.1 -c import 
> sys # split strings by '.' and convert to numeric. Append some zeros # 
> because we need at least 4 digits for the hex conversion. # map returns an 
> iterator in Python 3.0 and a list in 2.x minver = list(map(int, 
> '2.7'.split('.'))) + [0, 0, 0] minverhex = 0 # xrange is not present in 
> Python 3.0 and range returns an iterator for i in list(range(0, 4)): 
> minverhex = (minverhex << 8) + minver[i] sys.exit(sys.hexversion < 
> minverhex) 
> > ./configure: line 3261: 
> /home/chapoton/sage3/local/var/lib/sage/installed/python3-3.6.1: Permission 
> denied 
> > configure:3263: $? = 126 
> > configure:3268: result: no 
> > configure:3270: error: Python interpreter is too old 
> > 
>
>

-- 
You received this message because you are subscribed to the Google Groups 
"sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to sage-devel+unsubscr...@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

Reply via email to