Re: [OMPI devel] (no subject)

2018-10-22 Thread Gilles Gouaillardet
Santiago, the config.log reports there is no /usr/include/sys/statfs.h on your system. on my system, this file exists and is provided by the msys2-runtime-devel file, so the first steps are to check this package is installed and if not, install it. note I ran pacman -Syu a few times to

Re: [OMPI devel] (no subject)

2018-10-22 Thread Santiago Serebrinsky
Thanks Dmitry. I was aware of the two links posted... [1]: It dates from 2016, and the issue with statfs/stavfs persists. I wouldn't know how to "submit a pull request with a PKGBUILD for the package", and from the post I did not understand if that is like a "feature request", or if that

Re: [OMPI devel] (no subject)

2018-10-22 Thread Santiago Serebrinsky
Dear Gilles, I did what you suggested $ pacman -Syu (a few times, until no further updates) $ pacman -S msys2-runtime-devel but I still get the same error. I am attaching the corresponding log file. I note that Dmitry mentioned that statf/statvfs are not provided in Msys2, so I wonder how

Re: [OMPI devel] Openmpi configure: Could not determine the fortran compiler flag

2018-10-22 Thread Jeff Squyres (jsquyres) via devel
For what it's worth, it looks like Open MPI's configure found your mingw fortran compiler, but was unable to determine what flag to use to find fortran modules -- that's what caused configure to abort. From your later messages, it looks like you just ended up disabling Fortran support, so this

Re: [OMPI devel] Openmpi configure: Could not determine the fortran compiler flag

2018-10-22 Thread Santiago Serebrinsky
Precisely, that was the problem. I disabled Fortran support to move ahead and see if I could manage that way (and I found I couldn't!), at least in some of my uses. But I (and perhaps others as well) would still need to have Fortran support, so the issue is not moot at all. Thanks On Mon, Oct

Re: [OMPI devel] Openmpi configure: Could not determine the fortran compiler flag

2018-10-22 Thread Jeff Squyres (jsquyres) via devel
> On Oct 22, 2018, at 12:58 PM, Santiago Serebrinsky > wrote: > > Precisely, that was the problem. > > I disabled Fortran support to move ahead and see if I could manage that way > (and I found I couldn't!), at least in some of my uses. But I (and perhaps > others as well) would still need

Re: [OMPI devel] Open MPI vs msys2

2018-10-22 Thread Gilles Gouaillardet
Santiago, I downloaded and installed msys2 from https://www.msys2.org, and here is what I have on my system gilles@gilles-PC MINGW32 ~ $ uname -a MINGW32_NT-6.1-WOW gilles-PC 2.11.1(0.329/5/3) 2018-09-10 13:25 i686 Msys gilles@gilles-PC MINGW32 ~ $ pacman -Qi msys2-runtime-devel Name