Re: [FFmpeg-devel] [PATCH v3] avcodec/rdft: remove sintable

2017-07-10 Thread Muhammad Faiz
On Fri, Jul 7, 2017 at 2:50 PM, Muhammad Faiz wrote: > It is redundant with costable. The first half of sintable is > identical with the second half of costable. The second half > of sintable is negative value of the first half of sintable. > > The computation is changed to handle sign of sin valu

[FFmpeg-devel] [PATCH] Add prefetch for mips

2017-07-10 Thread kaustubh.raste
From: Kaustubh Raste Signed-off-by: Kaustubh Raste --- libavcodec/mips/Makefile|1 + libavcodec/mips/videodsp_mips.c | 42 +++ libavcodec/videodsp.c |2 ++ libavcodec/videodsp.h |1 + 4 files changed, 46 insertions(+)

Re: [FFmpeg-devel] [PATCH v2] avfilter/pthread: rewrite implementation

2017-07-10 Thread Clément Bœsch
On Tue, Jul 11, 2017 at 11:18:42AM +0700, Muhammad Faiz wrote: [...] > My plan is to merge implementation of slice threading in avutil. > As a public API? With the .c include "trick"? avpriv_? I don't know what's the current consensus, but people never seem to agree about the path to take in that

Re: [FFmpeg-devel] [PATCH V2] examples/vaapi_dec: Add aVA-APIhwaccel decoding example

2017-07-10 Thread Steven Liu
2017-07-11 13:54 GMT+08:00 liyoubdu : > yes, you. pls share your test file I have no test file, i just review the code logic and code style, now, do you have any questions? > > > ---Original--- > From: "刘歧" > Date: 2017/7/11 13:52:06 > To: "and patches development discussions FFmpeg"; > Cc: "刘歧";

Re: [FFmpeg-devel] [PATCH V2] examples/vaapi_dec: Add a VA-API hwaccel decoding example

2017-07-10 Thread Jun Zhao
On 2017/7/11 12:38, 刘歧 wrote: > From 0e4d230ae4c98949a962c6bbdad31d216b54bb6a Mon Sep 17 00:00:00 2001 > From: Jun Zhao > Date: Tue, 21 Mar 2017 11:04:41 +0800 > Subject: [V2] examples/vaapi_dec: Add a VA-API hwaccel decoding example. > > Add a VA-API hwaccel decoding example. > > Signed-off-b

Re: [FFmpeg-devel] [PATCH V2] examples/vaapi_dec: Add aVA-APIhwaccel decoding example

2017-07-10 Thread liyoubdu
yes, you. pls share your test file ---Original--- From: "刘歧" Date: 2017/7/11 13:52:06 To: "and patches development discussions FFmpeg"; Cc: "刘歧"; Subject: Re: [FFmpeg-devel] [PATCH V2] examples/vaapi_dec: Add aVA-APIhwaccel decoding example > On Jul 11, 2017, at 12:49 PM, liyoubdu wrote:

Re: [FFmpeg-devel] [PATCH V2] examples/vaapi_dec: Add a VA-APIhwaccel decoding example

2017-07-10 Thread 刘歧
> On Jul 11, 2017, at 12:49 PM, liyoubdu wrote: > > where is your media file for testinfg me? > > > > ---Original--- > From: "刘歧" > Date: 2017/7/11 12:39:31 > To: "and patches development discussions FFmpeg"; > Cc: "wm4";"Mark > Thompson";"刘歧";"Liu, > Kaixuan"; > Subject: Re: [FFmpeg-devel]

Re: [FFmpeg-devel] [PATCH V2] examples/vaapi_dec: Add a VA-APIhwaccel decoding example

2017-07-10 Thread liyoubdu
where is your media file for testinfg ---Original--- From: "刘歧" Date: 2017/7/11 12:39:31 To: "and patches development discussions FFmpeg"; Cc: "wm4";"Mark Thompson";"刘歧";"Liu, Kaixuan"; Subject: Re: [FFmpeg-devel] [PATCH V2] examples/vaapi_dec: Add a VA-APIhwaccel decoding example From 0e4

Re: [FFmpeg-devel] [PATCH V2] examples/vaapi_dec: Add a VA-API hwaccel decoding example

2017-07-10 Thread 刘歧
From 0e4d230ae4c98949a962c6bbdad31d216b54bb6a Mon Sep 17 00:00:00 2001 From: Jun Zhao Date: Tue, 21 Mar 2017 11:04:41 +0800 Subject: [V2] examples/vaapi_dec: Add a VA-API hwaccel decoding example. Add a VA-API hwaccel decoding example. Signed-off-by: Liu, Kaixuan Signed-off-by: Jun Zhao --- d

Re: [FFmpeg-devel] [PATCH v2] avfilter/pthread: rewrite implementation

2017-07-10 Thread Muhammad Faiz
On Tue, Jul 11, 2017 at 4:40 AM, Michael Niedermayer wrote: > On Mon, Jul 10, 2017 at 10:53:42AM +0200, wm4 wrote: >> On Sat, 8 Jul 2017 01:45:06 +0200 >> Michael Niedermayer wrote: >> >> > On Fri, Jul 07, 2017 at 09:04:37PM +0700, Muhammad Faiz wrote: >> > > Avoid pthread_cond_broadcast that wak

[FFmpeg-devel] [PATCH V2] examples/vaapi_dec: Add a VA-API hwaccel decoding example

2017-07-10 Thread Jun Zhao
V2: re-work with new hw decoding API. From 0e4d230ae4c98949a962c6bbdad31d216b54bb6a Mon Sep 17 00:00:00 2001 From: Jun Zhao Date: Tue, 21 Mar 2017 11:04:41 +0800 Subject: [V2] examples/vaapi_dec: Add a VA-API hwaccel decoding example. Add a VA-API hwaccel decoding example. Signed-off-by: Liu, Ka

[FFmpeg-devel] [PATCH] movenc:adds keywords metadata

2017-07-10 Thread Kieran O Leary
Hi, A user mentioned in ffmpeg-user ( http://ffmpeg.org/pipermail/ffmpeg-user/2017-July/036571.html) that they couldn't write the 'keywords' metadata tag. I tested this patch and it appears to add the metadata value when using MOV and MP4 as output. I'm sure I've messed something up so please let

Re: [FFmpeg-devel] [PATCH] pthread_frame: save the FF_DEBUG_THREADS option in PerThreadContext.

2017-07-10 Thread Ronald S. Bultje
Hi, On Mon, Jul 10, 2017 at 1:24 PM, Wan-Teh Chang wrote: > Add the debug_threads boolean field to PerThreadContext. For > PerThreadContext *p, p->debug_threads records whether the > FF_DEBUG_THREADS bit is set in p->avctx->debug, and p->debug_threads and > p->avctx->debug are kept in sync. The

Re: [FFmpeg-devel] [PATCH v2] avfilter/pthread: rewrite implementation

2017-07-10 Thread James Almer
On 7/10/2017 5:53 AM, wm4 wrote: > On Sat, 8 Jul 2017 01:45:06 +0200 > Michael Niedermayer wrote: > >> On Fri, Jul 07, 2017 at 09:04:37PM +0700, Muhammad Faiz wrote: >>> Avoid pthread_cond_broadcast that wakes up all workers. Make each of them >>> uses distict mutex/cond. Also let main thread hel

Re: [FFmpeg-devel] [PATCH v2] avfilter/pthread: rewrite implementation

2017-07-10 Thread Michael Niedermayer
On Mon, Jul 10, 2017 at 10:53:42AM +0200, wm4 wrote: > On Sat, 8 Jul 2017 01:45:06 +0200 > Michael Niedermayer wrote: > > > On Fri, Jul 07, 2017 at 09:04:37PM +0700, Muhammad Faiz wrote: > > > Avoid pthread_cond_broadcast that wakes up all workers. Make each of them > > > uses distict mutex/cond.

Re: [FFmpeg-devel] [PATCH 3/3] avcodec/aacpsdsp_template: Fixes integer overflow in ps_add_squares_c()

2017-07-10 Thread Michael Niedermayer
On Mon, Jul 10, 2017 at 10:37:46AM +0200, wm4 wrote: > On Sun, 9 Jul 2017 22:03:21 +0200 > Reimar Döffinger wrote: > > > On 09.07.2017, at 16:08, "Ronald S. Bultje" wrote: > > > Hi, > > > > > > On Sun, Jul 9, 2017 at 4:39 AM, Reimar Döffinger > > > > > > wrote: > > > > > >> On 09.07.2017,

Re: [FFmpeg-devel] [PATCH] checkasm: add a g722dsp test

2017-07-10 Thread James Almer
On 7/5/2017 4:44 PM, James Almer wrote: > Signed-off-by: James Almer > --- > tests/checkasm/Makefile | 1 + > tests/checkasm/checkasm.c | 3 +++ > tests/checkasm/checkasm.h | 1 + > tests/checkasm/g722dsp.c | 66 > +++ > tests/fate/checkasm.mak

Re: [FFmpeg-devel] [PATCH] pthread_frame: save the FF_DEBUG_THREADS option in FrameThreadContext.

2017-07-10 Thread Wan-Teh Chang
On Sat, Jul 8, 2017 at 3:49 PM, Michael Niedermayer wrote: > On Sat, Jul 08, 2017 at 03:38:11PM -0700, Wan-Teh Chang wrote: >> Hi Ronald, >> >> On Sat, Jul 8, 2017 at 2:33 PM, Ronald S. Bultje wrote: >> > >> > I can see the design from the patch. >> > >> > What's missing is a justification for th

[FFmpeg-devel] [PATCH] pthread_frame: save the FF_DEBUG_THREADS option in PerThreadContext.

2017-07-10 Thread Wan-Teh Chang
Add the debug_threads boolean field to PerThreadContext. For PerThreadContext *p, p->debug_threads records whether the FF_DEBUG_THREADS bit is set in p->avctx->debug, and p->debug_threads and p->avctx->debug are kept in sync. The debug_threads field is defined as an atomic_int to allow atomic read

Re: [FFmpeg-devel] [PATCH 10/12] rtspdec: Fix return error

2017-07-10 Thread Derek Buitenhuis
On 7/6/2017 7:28 PM, Derek Buitenhuis wrote: > Signed-off-by: Derek Buitenhuis > --- > libavformat/rtspdec.c | 1 - > 1 file changed, 1 deletion(-) Pushing this today if nobody objects. - Derek ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org htt

[FFmpeg-devel] [PATCH 10/10] avcodec/dca: avoid using bitstream reader in a non-standard way

2017-07-10 Thread foo86
Use proper get_bits.h functions instead of directly accessing index. --- libavcodec/dca_core.c | 12 +++- libavcodec/dca_core.h | 1 + libavcodec/dca_xll.c | 2 +- libavcodec/dcadec.h | 4 ++-- 4 files changed, 11 insertions(+), 8 deletions(-) diff --git a/libavcodec/dca_core.c b/li

[FFmpeg-devel] [PATCH 08/10] avcodec/dca_parser: avoid use of magic values

2017-07-10 Thread foo86
Duration computation can be simplified because number of PCM blocks is only allowed to be a multiple of 8. --- libavcodec/dca_parser.c | 7 --- 1 file changed, 4 insertions(+), 3 deletions(-) diff --git a/libavcodec/dca_parser.c b/libavcodec/dca_parser.c index 390f7975f9..7e99b16bf0 100644 --

[FFmpeg-devel] [PATCH 03/10] avcodec: add avpriv_dca_parse_core_frame_header()

2017-07-10 Thread foo86
There are 3 different places where DCA core frame header is parsed: decoder, parser and demuxer. Each one uses ad-hoc code. Add common core frame header parsing function that will be used in all places. --- libavcodec/dca.c | 60 libavcodec/

[FFmpeg-devel] [PATCH 06/10] avformat/dtsdec: switch to common frame header parsing function

2017-07-10 Thread foo86
This makes probing for regular DTS more strict because more header fields are checked and values not supported by decoder are now rejected. Also fixes an issue original code had with 14-bit streams: 96 bits of header were expected, however only 84 bits were converted, which was not enough to parse

[FFmpeg-devel] [PATCH 07/10] avcodec/dca_parser: export profile information

2017-07-10 Thread foo86
Permits applications to access DTS profile information without having to decode a frame. --- libavcodec/dca_parser.c | 44 +++- 1 file changed, 39 insertions(+), 5 deletions(-) diff --git a/libavcodec/dca_parser.c b/libavcodec/dca_parser.c index 6107358773.

[FFmpeg-devel] [PATCH 01/10] avcodec/dca: move some enumeration typedefs into headers

2017-07-10 Thread foo86
These values will be used by the parser. Prefix them with DCA_ appropriately. --- libavcodec/dca_core.c | 68 +++ libavcodec/dca_core.h | 28 + libavcodec/dca_lbr.c | 9 ++- libavcodec/dca_lbr.h | 5 4 files changed,

[FFmpeg-devel] [PATCH 02/10] avcodec/dca: move bits per sample array to dca.c

2017-07-10 Thread foo86
It will be used by the parser. This change avoids unwanted parser dependency on dcadata. --- libavcodec/dca.c | 4 libavcodec/dca.h | 2 ++ libavcodec/dcadata.c | 4 libavcodec/dcadata.h | 2 -- 4 files changed, 6 insertions(+), 6 deletions(-) diff --git a/libavcodec/dca.c b/lib

[FFmpeg-devel] [PATCH 09/10] avcodec/dca_core: probe extension headers directly

2017-07-10 Thread foo86
Avoid using bitstream reader in a non-standard way by directly accessing index. Use bit shifting/masking operations instead. --- libavcodec/dca_core.c | 31 --- 1 file changed, 16 insertions(+), 15 deletions(-) diff --git a/libavcodec/dca_core.c b/libavcodec/dca_core.c

[FFmpeg-devel] [PATCH 04/10] avcodec/dca_core: switch to common frame header parsing function

2017-07-10 Thread foo86
--- libavcodec/dca_core.c | 167 ++ 1 file changed, 60 insertions(+), 107 deletions(-) diff --git a/libavcodec/dca_core.c b/libavcodec/dca_core.c index 16210b89f8..090191dfa9 100644 --- a/libavcodec/dca_core.c +++ b/libavcodec/dca_core.c @@ -81,114

[FFmpeg-devel] [PATCH 05/10] avcodec/dca_parser: switch to common frame header parsing function

2017-07-10 Thread foo86
--- libavcodec/dca_parser.c | 26 +++--- 1 file changed, 11 insertions(+), 15 deletions(-) diff --git a/libavcodec/dca_parser.c b/libavcodec/dca_parser.c index e5bea3347c..6107358773 100644 --- a/libavcodec/dca_parser.c +++ b/libavcodec/dca_parser.c @@ -192,10 +192,11 @@ stati

Re: [FFmpeg-devel] [PATCH 3/3] avcodec/aacpsdsp_template: Fixes integer overflow in ps_add_squares_c()

2017-07-10 Thread wm4
On Mon, 10 Jul 2017 09:29:31 -0300 James Almer wrote: > On 7/10/2017 5:37 AM, wm4 wrote: > > On Sun, 9 Jul 2017 22:03:21 +0200 > > Reimar Döffinger wrote: > > > >> On 09.07.2017, at 16:08, "Ronald S. Bultje" wrote: > >>> Hi, > >>> > >>> On Sun, Jul 9, 2017 at 4:39 AM, Reimar Döffinger > >

Re: [FFmpeg-devel] [PATCH 3/3] avcodec/aacpsdsp_template: Fixes integer overflow in ps_add_squares_c()

2017-07-10 Thread James Almer
On 7/10/2017 5:37 AM, wm4 wrote: > On Sun, 9 Jul 2017 22:03:21 +0200 > Reimar Döffinger wrote: > >> On 09.07.2017, at 16:08, "Ronald S. Bultje" wrote: >>> Hi, >>> >>> On Sun, Jul 9, 2017 at 4:39 AM, Reimar Döffinger >>> wrote: >>> On 09.07.2017, at 02:52, "Ronald S. Bultje" wrote: >>

Re: [FFmpeg-devel] [PATCH] avcodec/mpegvideo: Fix all but one tsan warning in fate-vsynth1-mpeg4

2017-07-10 Thread Ronald S. Bultje
Hi, On Mon, Jul 10, 2017 at 5:32 AM, wm4 wrote: > On Sun, 9 Jul 2017 22:37:46 -0400 > "Ronald S. Bultje" wrote: > > > Hi, > > > > On Sun, Jul 9, 2017 at 9:19 PM, Michael Niedermayer > > > wrote: > > > > > Signed-off-by: Michael Niedermayer > > > --- > > > libavcodec/mpegvideo.c | 15

Re: [FFmpeg-devel] [PATCH] avcodec/mpegvideo: Fix all but one tsan warning in fate-vsynth1-mpeg4

2017-07-10 Thread Michael Niedermayer
On Sun, Jul 09, 2017 at 10:37:46PM -0400, Ronald S. Bultje wrote: > Hi, > > On Sun, Jul 9, 2017 at 9:19 PM, Michael Niedermayer > wrote: > > > Signed-off-by: Michael Niedermayer > > --- > > libavcodec/mpegvideo.c | 15 ++- > > 1 file changed, 14 insertions(+), 1 deletion(-) > > > >

Re: [FFmpeg-devel] [PATCH] h264: Support multi-field closed captions by using AVBufferRef and not resetting per field

2017-07-10 Thread wm4
On Mon, 10 Jul 2017 09:43:09 + Kieran Kunhya wrote: > On Mon, 10 Jul 2017 at 10:39 wm4 wrote: > > > > > > h->frame_recovered = h1->frame_recovered; > > > +if (h1->sei.a53_caption.buf_ref) { > > > +h->sei.a53_caption.buf_ref = > > av_buffer_ref(h1->sei.a53_caption.

Re: [FFmpeg-devel] [PATCH v2] avcodec/pthread_slice: rewrite implementation

2017-07-10 Thread Muhammad Faiz
On Mon, Jul 10, 2017 at 4:25 PM, wm4 wrote: > On Sun, 9 Jul 2017 23:26:54 +0700 > Muhammad Faiz wrote: > >> Avoid pthread_cond_broadcast that wakes up all workers. Make each of them >> uses distict mutex/cond. Also let main thread help running jobs, but still >> allocate thread_count workers. Th

Re: [FFmpeg-devel] [PATCH] h264: Support multi-field closed captions by using AVBufferRef and not resetting per field

2017-07-10 Thread Kieran Kunhya
On Mon, 10 Jul 2017 at 10:39 wm4 wrote: > > > h->frame_recovered = h1->frame_recovered; > > +if (h1->sei.a53_caption.buf_ref) { > > +h->sei.a53_caption.buf_ref = > av_buffer_ref(h1->sei.a53_caption.buf_ref); > > +av_buffer_unref(&h1->sei.a53_caption.buf_ref); > > +

Re: [FFmpeg-devel] [PATCH] h264: Support multi-field closed captions by using AVBufferRef and not resetting per field

2017-07-10 Thread wm4
On Sun, 09 Jul 2017 22:59:41 + Kieran Kunhya wrote: > From e8768677511ae5ae9c62c7182a73993e5132f5b8 Mon Sep 17 00:00:00 2001 > From: Kieran Kunhya > Date: Sun, 9 Jul 2017 23:56:14 +0100 > Subject: [PATCH] h264: Support multi-field closed captions by using > AVBufferRef and not resetting per

Re: [FFmpeg-devel] [PATCH] avcodec/mpegvideo: Fix all but one tsan warning in fate-vsynth1-mpeg4

2017-07-10 Thread wm4
On Sun, 9 Jul 2017 22:37:46 -0400 "Ronald S. Bultje" wrote: > Hi, > > On Sun, Jul 9, 2017 at 9:19 PM, Michael Niedermayer > wrote: > > > Signed-off-by: Michael Niedermayer > > --- > > libavcodec/mpegvideo.c | 15 ++- > > 1 file changed, 14 insertions(+), 1 deletion(-) > > > > dif

Re: [FFmpeg-devel] [PATCH] avcodec/mpegvideo: Fix all but one tsan warning in fate-vsynth1-mpeg4

2017-07-10 Thread wm4
On Mon, 10 Jul 2017 03:19:51 +0200 Michael Niedermayer wrote: > Signed-off-by: Michael Niedermayer > --- > libavcodec/mpegvideo.c | 15 ++- > 1 file changed, 14 insertions(+), 1 deletion(-) > > diff --git a/libavcodec/mpegvideo.c b/libavcodec/mpegvideo.c > index e29558b3a2..574b385

Re: [FFmpeg-devel] [PATCH v2] avcodec/pthread_slice: rewrite implementation

2017-07-10 Thread wm4
On Sun, 9 Jul 2017 23:26:54 +0700 Muhammad Faiz wrote: > Avoid pthread_cond_broadcast that wakes up all workers. Make each of them > uses distict mutex/cond. Also let main thread help running jobs, but still > allocate thread_count workers. The last worker is currently unused, emulated > by main

Re: [FFmpeg-devel] Ticket 6375, Too many packets buffered for output stream

2017-07-10 Thread wm4
On Sun, 9 Jul 2017 13:38:10 +0200 Reimar Döffinger wrote: > On 09.07.2017, at 13:09, Michael Niedermayer wrote: > > > Hi all > > > > It does appear this regression affects alot of people, judging from > > the multiple different people in the ticket. > > Also people ask me about this, for examp

Re: [FFmpeg-devel] Ticket 6375, Too many packets buffered for output stream

2017-07-10 Thread wm4
On Sun, 9 Jul 2017 13:09:28 +0200 Michael Niedermayer wrote: > Hi all > > It does appear this regression affects alot of people, judging from > the multiple different people in the ticket. > Also people ask me about this, for example baptiste yesterday hit it > too. > > I belive multiple people

Re: [FFmpeg-devel] [PATCH] avfilter: add ANSNR filter

2017-07-10 Thread Tobias Rapp
On 09.07.2017 19:42, Ashish Singh wrote: Hi, added metadata scores and changed multipe string comparisons to few integer comparisons. --- Changelog| 1 + doc/filters.texi | 20 +++ libavfilter/Makefile | 1 + libavfilter/allfilters.c | 1 + libavfilter/ansnr.h

Re: [FFmpeg-devel] [PATCH v2] avfilter/pthread: rewrite implementation

2017-07-10 Thread wm4
On Sat, 8 Jul 2017 01:45:06 +0200 Michael Niedermayer wrote: > On Fri, Jul 07, 2017 at 09:04:37PM +0700, Muhammad Faiz wrote: > > Avoid pthread_cond_broadcast that wakes up all workers. Make each of them > > uses distict mutex/cond. Also let main thread help running jobs. > > > > Benchmark using

Re: [FFmpeg-devel] [PATCH 1/1] This change adds an encoder for Camera metadata motion. This is a type of sensor data associated with video, such as GPS, acceleration, gyro, and camera orientation. It

2017-07-10 Thread wm4
On Fri, 7 Jul 2017 15:24:02 -0700 "Louis O'Bryan" wrote: > > +static av_cold int encode_init(AVCodecContext *avctx) { > > > +// Use dummy values for the height and width. > > > +avctx->width = DUMMY_ENCODER_SIZE; > > > +avctx->height = DUMMY_ENCODER_SIZE; > > > +avctx->max_pixel

Re: [FFmpeg-devel] [PATCH 3/3] avcodec/aacpsdsp_template: Fixes integer overflow in ps_add_squares_c()

2017-07-10 Thread wm4
On Sun, 9 Jul 2017 22:03:21 +0200 Reimar Döffinger wrote: > On 09.07.2017, at 16:08, "Ronald S. Bultje" wrote: > > Hi, > > > > On Sun, Jul 9, 2017 at 4:39 AM, Reimar Döffinger > > wrote: > > > >> On 09.07.2017, at 02:52, "Ronald S. Bultje" wrote: > >>> On Sat, Jul 8, 2017 at 5:17 PM, Mic