Re: ACPI + Compaq Armada m700

2002-12-04 Thread Michal Mertl
Hello, Last night I cvsupped from 4.6-STABLE to 5.0-CURRENT. I do know the risks of using -CURRENT. Unfortunately I am having a problem with ACPI on boot. I have to issue the following to get the machine to boot boot unset acpi_load boot set boot_verbose=YES boot boot -v then the usual

Re: Any ideas at all about network problem?

2002-12-04 Thread ianf
Joshua Goodall wrote: On Wed, Dec 04, 2002 at 01:32:58AM +0100, Brad Knowles wrote: At 12:31 PM +0200 2002/12/03, [EMAIL PROTECTED] wrote: The two machines involved are connected by a crossover cable: I've heard of lots of problems with machines using cross-over cables. Can

ia64 tinderbox failure

2002-12-04 Thread Peter Wemm
-- Rebuilding the temporary build tree -- stage 1: bootstrap tools -- stage 2: cleaning up the object tree

Re: Any ideas at all about network problem?

2002-12-04 Thread ianf
Brad Knowles wrote: At 12:31 PM +0200 2002/12/03, [EMAIL PROTECTED] wrote: The two machines involved are connected by a crossover cable: I've heard of lots of problems with machines using cross-over cables. Can you connect the machines through a switch, and ensure that they are

Re: panic: ata_dmasetup: transfer active on this device!

2002-12-04 Thread Soeren Schmidt
It seems Ian Dowse wrote: Hi Søren, I get the above panic every few days when resuming, especially if the disk was active while the laptop was suspending - it's easy to reproduce by starting some disk-intensive activity and then hitting the suspend button. I see that IWASAKI-san posted

Re: [acpi-jp 2013] RE: ACPI errors w/ latest ACPI code on GA BX2000 based system

2002-12-04 Thread Mitsuru IWASAKI
Thanks, Bob. I think this code is the problem: Scope(\_TZ_) { ThermalZone(THRM) { Name(_AL0, Package(0x1) { FAN_, }) The name FAN_ is not defined elsewhere in the namespace. I guess that BIOS writer forgot to delete _AL0 definition :) Instead, you can

How can I use my kernel on DP2?

2002-12-04 Thread kai ouyang
Hi, everybody, I found a very strange thing about kernel on DP2. I do not know why I compiled my kernel, but I can not boot with it? Current# uname -a FreeBSD Current.wtwh.com.cn 5.0-DP2 FreeBSD 5.0-DP2 #1: Sat Nov 16 13:38:33 GMT 2002 [EMAIL PROTECTED]:/usr/obj/usr/src/sys/GENERIC i386

unable to use boot0cfg

2002-12-04 Thread Vallo Kallaste
Hi I'm using both -current and -stable on the same machine, very common. Boot0cfg has -s [12345] flag to set the slice to boot on and it has been working so far. Beginning from Dec 1, I'm unable to set the slice: root:vallo# boot0cfg -v ad0 # flag start chs type end chs

ahc and fd

2002-12-04 Thread Takahashi Yoshihiro
After recent your changes of the ahc driver, the fd driver can't work on my pc98 box. It never return from the open(2) syscall. I don't know that this problem is only pc98 or not. --- TAKAHASHI Yoshihiro [EMAIL PROTECTED] To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe

Re: ahc and fd

2002-12-04 Thread Poul-Henning Kamp
In message [EMAIL PROTECTED], Takahashi Yoshihiro writes: After recent your changes of the ahc driver, the fd driver can't work on my pc98 box. It never return from the open(2) syscall. I don't know that this problem is only pc98 or not. Please try to comment out the aic driver. The AIC has a

Re: unable to use boot0cfg

2002-12-04 Thread David Wolfskill
Date: Wed, 4 Dec 2002 15:17:39 +0200 From: Vallo Kallaste [EMAIL PROTECTED] I'm using both -current and -stable on the same machine, very common. Boot0cfg has -s [12345] flag to set the slice to boot on and it has been working so far. Beginning from Dec 1, I'm unable to set the slice:

Re: FYI - 4.3-stable to 5.0 upgrade success

2002-12-04 Thread Ruslan Ermilov
On Sat, Nov 30, 2002 at 05:48:21PM -0500, Daniel Eischen wrote: I recently upgraded a Dell Lattitude C600 from some version of -stable after 4.3 to 5.0-current. I first upgraded it to 4.7-stable, then to 5.0-current. I followed the instructions at the end of src/UPDATING pretty much to the

RE: How can I use my kernel on DP2?

2002-12-04 Thread Patrick Stinson
assuming you read the handbook on updating the kernel http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/kernelconfig.html , UPDATING in /usr/src ftp://ftp.freebsd.org/pub/FreeBSD/branches/-current/src/UPDATING , and completed a make and make install in your kernel compile directory, you

Re: console problem

2002-12-04 Thread Holm Tiffe
Chuck Robey wrote: I've been on vacation for the last week, so I haven't been watching -current like a good boy should, but I've suddenly been seeing a serious problem, and it *might* not have been reported, and seeing as code freeze is almost here, it's worth risking a bit of embarrassment,

ia64 tinderbox failure

2002-12-04 Thread Peter Wemm
-- Rebuilding the temporary build tree -- stage 1: bootstrap tools -- stage 2: cleaning up the object tree

Re: ahc and fd

2002-12-04 Thread Takahashi Yoshihiro
In article [EMAIL PROTECTED] Poul-Henning Kamp [EMAIL PROTECTED] writes: In message [EMAIL PROTECTED], Takahashi Yoshihiro writes: After recent your changes of the ahc driver, the fd driver can't work on my pc98 box. It never return from the open(2) syscall. I don't know that this problem

Re: ahc and fd

2002-12-04 Thread Scott Long
On Wed, Dec 04, 2002 at 11:53:55PM +0900, Takahashi Yoshihiro wrote: In article [EMAIL PROTECTED] Poul-Henning Kamp [EMAIL PROTECTED] writes: In message [EMAIL PROTECTED], Takahashi Yoshihiro writes: After recent your changes of the ahc driver, the fd driver can't work on my pc98 box.

Re: [acpi-jp 2015] Re: ACPI Poweroff problem

2002-12-04 Thread Mitsuru IWASAKI
Hi, * Nate Lawson ([EMAIL PROTECTED]): Power System off using ACPI ACPI -1287 *** Error: Method execution failed AE_AML_UNINITIALIZED_LOCAL ACPI -1287 *** Error: Method execution failed AE_AML_UNINITIALIZED_LOCAL ACPIEnterSleepStatePrep failed AE_AML_UNINITIALIZED_LOCAL

Re: ahc and fd

2002-12-04 Thread Takahashi Yoshihiro
In article [EMAIL PROTECTED] Scott Long [EMAIL PROTECTED] writes: Do you have an ahc card in your system? If you don't, then I have no idea what could be going wrong since it shouldn't do anything more than just check PCI Id's and then fail. If you do have an ahc device, try placing the

ata device removal panic fix

2002-12-04 Thread Andrew Gallatin
Hi, I've been hacking on DMA windows on alpha. While I've been getting things wrong, I've been provoking a panic in the ata driver because it cannot do DMA when attaching a disk. The panic is triggered at the end of ad_attach() by the raid probe causing a transfer to fail and the disk to be

make buildworld failure

2002-12-04 Thread JY
/usr/src/contrib/gcc/cp/except.c:790:18: cfns.h: No such file or directory mkdep: compile failed *** Error code 1 Stop in /usr/src/gnu/usr.bin/cc/cc1plus. JY To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe freebsd-current in the body of the message

Re: cvs commit: src/sbin/dump dump.8 main.c

2002-12-04 Thread Benjamin Lewis
On Tue, 2002-12-03 at 13:21, Kirk McKusick wrote: mckusick2002/12/03 10:21:09 PST Modified files: sbin/dumpdump.8 main.c Log: Add the `L' option [...] Aha! I've been waiting for that ever since it was hinted at in the original snapshots readme. I do wonder,

Re: make buildworld failure

2002-12-04 Thread David O'Brien
On Thu, Dec 05, 2002 at 02:08:42AM +0800, JY wrote: /usr/src/contrib/gcc/cp/except.c:790:18: cfns.h: No such file or directory mkdep: compile failed *** Error code 1 Stop in /usr/src/gnu/usr.bin/cc/cc1plus. Please cvsup again, and reply back if you still have any build problems. To

i386 tinderbox failure

2002-12-04 Thread Dag-Erling Smorgrav
-- Rebuilding the temporary build tree -- stage 1: bootstrap tools -- stage 2: cleaning up the object tree

GEOM + GRUB = ??

2002-12-04 Thread Wesley Morgan
Trying to install a new version of GRUB not having much success. I'm wondering if GEOM is interacting with it in some strange way. I am fairly certain grub reads the partitions itself, but this would be through the geom layer would it not? The port might need to be marked broken for 5.0, or

Re: GEOM + GRUB = ??

2002-12-04 Thread Terry Lambert
Wesley Morgan wrote: Trying to install a new version of GRUB not having much success. I'm wondering if GEOM is interacting with it in some strange way. I am fairly certain grub reads the partitions itself, but this would be through the geom layer would it not? The port might need to be marked

Re: ACPI + Compaq Armada m700

2002-12-04 Thread Craig Boston
Apparently the listserver ate my message for breakfast, resending. Maybe too big? I'm only attaching the patch this time; the other files are available on request. -Forwarded Message- From: Craig Boston [EMAIL PROTECTED] To: [EMAIL PROTECTED] Subject: Re: ACPI + Compaq Armada m700

Re: VM related panic during suspend/resume

2002-12-04 Thread Alan L. Cox
I've just committed a fix for this assertion failure. Regards, Alan To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe freebsd-current in the body of the message

Re: GEOM + GRUB = ??

2002-12-04 Thread Wesley Morgan
On Wed, 4 Dec 2002, Terry Lambert wrote: The GRUB stuff does not use GEOM, because GEOM is an abstraction that lives in FreeBSD only. GRUB reads the data directly, itself. To do this, it has to have some knowledge of how to at least get at the code in the boot1/boot2 case (try booting one of

Re: VM related panic during suspend/resume

2002-12-04 Thread Christian Brueffer
On Wed, Dec 04, 2002 at 01:52:33PM -0600, Alan L. Cox wrote: I've just committed a fix for this assertion failure. Regards, Alan Thanks! - Christian -- http://www.unixpages.org[EMAIL PROTECTED] GPG Pub-Key: www.unixpages.org/cbrueffer.asc GPG Fingerprint:

Re: GEOM + GRUB = ??

2002-12-04 Thread Christian Brueffer
On Wed, Dec 04, 2002 at 02:56:10PM -0500, Wesley Morgan wrote: On Wed, 4 Dec 2002, Terry Lambert wrote: The GRUB stuff does not use GEOM, because GEOM is an abstraction that lives in FreeBSD only. GRUB reads the data directly, itself. To do this, it has to have some knowledge of how to

ia64 tinderbox failure

2002-12-04 Thread Peter Wemm
-- Rebuilding the temporary build tree -- stage 1: bootstrap tools -- stage 2: cleaning up the object tree

DP-2 and Nvidia Geforce 4

2002-12-04 Thread Rob
Is there any solution to the above combo other than just waiting? thanks, Rob. -- - The Numeric Python EM Project www.pythonemproject.com To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe freebsd-current in the body of the message

Re: ACPI + Compaq Armada m700

2002-12-04 Thread Nate Lawson
On 4 Dec 2002, Craig Boston wrote: I've been conversing with Paul off-list about this and it is working on his m700 now with a fixed AML file. I'm posing my modified AML since there appear to be a few more people using current on the m700 now than the last time I checked (when it was 0 :).

Re: DP-2 and Nvidia Geforce 4

2002-12-04 Thread Joe Marcus Clarke
On Wed, 2002-12-04 at 17:04, Rob wrote: Is there any solution to the above combo other than just waiting? I think you've seen my how-to at http://www.marcuscom.com/g2g-xfree86/article.html. Did it not work for your card, or are you referring to GeForce 4 with accelerated 3D support? Joe

Re: USB mass device not quite there

2002-12-04 Thread Fred Clift
On Sun, 1 Dec 2002, Pete Carah wrote: da0 at umass-sim0 bus 0 target 0 lun 0 da0: eUSB Compact Flash 5.07 Removable Direct Access SCSI-2 device da0: Serial Number 21M82CFC1Y09C11125Z3 da0: 650KB/s transfers da0: 122MB (250368 512 byte sectors: 64H 32S/T 122C) ... The other slot is

Creating bootsector file for W2k boot menu

2002-12-04 Thread Tomi Vainio - Sun Finland -
I've used Windows NT boot menu for years to boot FreeBSD from the second disk on my machines. I've used bootpart DOS program to do this but now I can't find correct way to do FreeBSD boot block for it. Earlier there was a diskid definition in some Makefile to change. How should I do this now?

RE: console problem

2002-12-04 Thread Long, Scott
This problem and the general 'console freeze' problem, and possibly even the 'floppy doesn't work anymore' problem should be fixed. The problem was with the ahc and ahd drivers corrupting the callout list used to trigger timeouts in the kernel. Scott -Original Message- From: Holm

USB issues with Apollo KT133A mobo

2002-12-04 Thread Cliff L. Biffle
Hi all. I'm running 5.0-DP2 on a motherboard with the Apollo KT133A chipset. (I believe it's an ASUS, but it doesn't seem to be labelled.) The USB controller (described by dmesg as a VIA 83C572) periodically blows its brains out. More specifically, all USB devices lose power. The device

Re: Lock order reversals in sys_pipe.c and kern_sig.c

2002-12-04 Thread Lars Eggert
Alfred Perlstein wrote: * Kris Kennaway [021118 11:06] wrote: I've just turned witness back on on the bento cluster, and got the following lock order reversals a number of times overnight: Nov 18 07:45:40 gohan11 kernel: 1st 0xc6887200 pipe mutex (pipe mutex) @

Re: ACPI Poweroff problem

2002-12-04 Thread Thomas Seck
* Nate Lawson ([EMAIL PROTECTED]): 20021122 has not been imported yet. 20021118 is version in -current. Sorry. Thanks for correcting me on that one. Sorry for the confusion. --Thomas To Unsubscribe: send mail to [EMAIL PROTECTED] with unsubscribe freebsd-current in the body of the

Re: sound problems

2002-12-04 Thread Lars Eggert
Lars Eggert wrote: Peter Gade Jensen wrote: I have the same problem. It sounds like the soundbuffer runs empty somehow and needs to fill up before continueing. This results in something that sounds like a really small sample(1ms) looping for 1second or so. If this makes sense? :o) Same

Re: Lock order reversals in sys_pipe.c and kern_sig.c

2002-12-04 Thread Alfred Perlstein
* Lars Eggert [EMAIL PROTECTED] [021204 15:04] wrote: FYI, just got a similar one yesterday on an up-to-date -current: lock order reversal 1st 0xc784d700 pipe mutex (pipe mutex) @ /usr/src/sys/kern/sys_pipe.c:465 2nd 0xc0513840 sigio lock (sigio lock) @ /usr/src/sys/kern/kern_sig.c:2225

Re: Lock order reversals in sys_pipe.c and kern_sig.c

2002-12-04 Thread Lars Eggert
Alfred Perlstein wrote: * Lars Eggert [021204 15:04] wrote: FYI, just got a similar one yesterday on an up-to-date -current: lock order reversal 1st 0xc784d700 pipe mutex (pipe mutex) @ /usr/src/sys/kern/sys_pipe.c:465 2nd 0xc0513840 sigio lock (sigio lock) @

Re: USB issues with Apollo KT133A mobo

2002-12-04 Thread Darryl Okahata
Cliff L. Biffle [EMAIL PROTECTED] wrote: More specifically, all USB devices lose power. The device nodes stay in /dev and there are no notices to dmesg about the loss until I unplug and replug them, at which time it says 'port error: restarting port N' where N is generally 0, depending on

[PATCH] net/tac_plus4

2002-12-04 Thread Jeff Ito
Since 5.0 is approaching, and this didnt get any attention on -ports, I figured I'd forward it here. - Forwarded message from Jeff Ito [EMAIL PROTECTED] - Can someone who uses tac_plus/skey please test this to verify it works. It compiles cleanly. But I am not certain that the apis are

Re: USB issues with Apollo KT133A mobo

2002-12-04 Thread Josef Karthauser
On Wed, Dec 04, 2002 at 04:00:15PM -0700, Cliff L. Biffle wrote: Hi all. I'm running 5.0-DP2 on a motherboard with the Apollo KT133A chipset. (I believe it's an ASUS, but it doesn't seem to be labelled.) The USB controller (described by dmesg as a VIA 83C572) periodically blows its brains

Re: Lock order reversals in sys_pipe.c and kern_sig.c

2002-12-04 Thread Lars Eggert
Alfred Perlstein wrote: * Lars Eggert [021204 15:04] wrote: FYI, just got a similar one yesterday on an up-to-date -current: lock order reversal 1st 0xc784d700 pipe mutex (pipe mutex) @ /usr/src/sys/kern/sys_pipe.c:465 2nd 0xc0513840 sigio lock (sigio lock) @

Re: USB support for new HP printers?

2002-12-04 Thread Dag-Erling Smorgrav
John Nielsen [EMAIL PROTECTED] writes: Hi, John. The LaserJet 1200 advertises several alternate settings for the printer-class interface: 7/1/3 (for IEEE 1284.4 packets, the new and different USB interface you mentioned), 7/1/2 (bidirectional raw print data), and 7/1/1 (unidirectional raw

Re: GEOM + GRUB = ??

2002-12-04 Thread Terry Lambert
Wesley Morgan wrote: It's not the booting that is a problem. That was working fine until I had to wipe out the MBR when my disklabel was chomped last week.. It's the grub command-line shell/installer that won't work now (admittedly I have not updated my grub boot blocks in a while either, so

Poweroff problem with IBM ThinkPad T21 (ACPI?)

2002-12-04 Thread Greg Rumple
I just put 5.0-DP2 on my IBM ThinkPad T21 (which I can finaly use, 4.x was pretty bad since only one of the two pcmcia slots worked, and numerous other problems, forcing me to use windows) and have been very very happy with it. ACPI works nicely on the laptop, and everything seems to be pretty

stuck in DDB

2002-12-04 Thread Ray Kohler
Just tonight I pushed Ctl+Alt+Esc and dropped into DDB, only to find I couldn't do anything there. Either the machine hard locked or my keyboard didn't work, I can't think of any way to tell the difference there. I really have pitifully little to go on; I didn't even have DDB compiled in until

ia64 tinderbox failure

2002-12-04 Thread Peter Wemm
-- Rebuilding the temporary build tree -- stage 1: bootstrap tools -- stage 2: cleaning up the object tree

Re: make buildworld failure

2002-12-04 Thread JY
On Wed, Dec 04, 2002 at 10:55:24AM -0800, David O'Brien wrote: On Thu, Dec 05, 2002 at 02:08:42AM +0800, JY wrote: /usr/src/contrib/gcc/cp/except.c:790:18: cfns.h: No such file or directory mkdep: compile failed *** Error code 1 Stop in /usr/src/gnu/usr.bin/cc/cc1plus. Please cvsup

Re: make buildworld failure

2002-12-04 Thread Ray Kohler
On Thu, Dec 05, 2002 at 10:55:48AM +0800, JY wrote: On Wed, Dec 04, 2002 at 10:55:24AM -0800, David O'Brien wrote: On Thu, Dec 05, 2002 at 02:08:42AM +0800, JY wrote: /usr/src/contrib/gcc/cp/except.c:790:18: cfns.h: No such file or directory mkdep: compile failed *** Error code 1

RE: console problem

2002-12-04 Thread Chuck Robey
On Wed, 4 Dec 2002, Long, Scott wrote: This problem and the general 'console freeze' problem, and possibly even the 'floppy doesn't work anymore' problem should be fixed. The problem was with the ahc and ahd drivers corrupting the callout list used to trigger timeouts in the kernel. Pardon

Re: make buildworld failure

2002-12-04 Thread JY
On Wed, Dec 04, 2002 at 10:09:16PM -0500, Ray Kohler wrote: Cannot delete /usr/src/contrib/gcc/INSTALL: Directory not empty rm -rf /usr/src rm -rf /usr/sup and re-cvsupping does not help. I removed just the problematic directory and re-cvsupped. It downloaded the directory again but

Re: Any ideas at all about network problem?

2002-12-04 Thread Craig Reyenga
Unfortunately, I have no extra hardware available to me, so I can't experiment with switches and whatnot. Also, wouldn't some sort of software experimentation be more appropriate, considering that my existing setup works _perfetcly_ in 4.7? I'm not sure what to do; should I be trying various

Re: DP-2 and Nvidia Geforce 4

2002-12-04 Thread Rob
Joe Marcus Clarke wrote: On Wed, 2002-12-04 at 17:04, Rob wrote: Is there any solution to the above combo other than just waiting? I think you've seen my how-to at http://www.marcuscom.com/g2g-xfree86/article.html. Did it not work for your card, or are you referring to GeForce 4 with

Re: DP-2 and Nvidia Geforce 4

2002-12-04 Thread Rob
Rob wrote: Joe Marcus Clarke wrote: On Wed, 2002-12-04 at 17:04, Rob wrote: Is there any solution to the above combo other than just waiting? I think you've seen my how-to at http://www.marcuscom.com/g2g-xfree86/article.html. Did it not work for your card, or are you referring

Re: Poweroff problem with IBM ThinkPad T21 (ACPI?)

2002-12-04 Thread C Engineering
This problem was around prior to 5.0-DP2. I have a thinkpad A21 and experienced this at least as far back as early october. I've never had the time to investigate further. You should take this as confirming that this isn't a configuration issue. From Greg Rumple [EMAIL PROTECTED], Wed, Dec

Re: Poweroff problem with IBM ThinkPad T21 (ACPI?)

2002-12-04 Thread Nate Williams
I just put 5.0-DP2 on my IBM ThinkPad T21 (which I can finaly use, 4.x was pretty bad since only one of the two pcmcia slots worked, and numerous other problems, forcing me to use windows) and have been very very happy with it. Really? I ran 4.X on my T21 for over a year with no problems

Re: USB issues with Apollo KT133A mobo

2002-12-04 Thread Cliff L. Biffle
On Wednesday 04 December 2002 05:11 pm, Darryl Okahata wrote: 1. IIRC, USB ports on KT133A motherboards were buggy (???). Could be. The ATA controller was also flaking out under 4.7, but is solid as a rock under 5.0-DP2, which is why I'm sticking with it despite other potential bugs. I can

Re: DP-2 and Nvidia Geforce 4

2002-12-04 Thread Joe Marcus Clarke
On Wed, 2002-12-04 at 22:46, Rob wrote: Rob wrote: Joe Marcus Clarke wrote: On Wed, 2002-12-04 at 17:04, Rob wrote: Is there any solution to the above combo other than just waiting? I think you've seen my how-to at http://www.marcuscom.com/g2g-xfree86/article.html. Did it

Re: USB issues with Apollo KT133A mobo

2002-12-04 Thread Cliff L. Biffle
On Wednesday 04 December 2002 05:40 pm, Josef Karthauser wrote: Is it ohci? If so can you try this patch? Joe Hey Joe -- fancy meeting you here. :-) Nope, the KT133 has two UHCI controllers. What I'm going to do next (which I should have done before) is try the following variables: 1. Does

Re: DP-2 and Nvidia Geforce 4

2002-12-04 Thread Rob
Joe Marcus Clarke wrote: On Wed, 2002-12-04 at 22:46, Rob wrote: Rob wrote: Joe Marcus Clarke wrote: On Wed, 2002-12-04 at 17:04, Rob wrote: Is there any solution to the above combo other than just waiting? I think you've seen my how-to at

Re: setfacl requirements?

2002-12-04 Thread kai ouyang
Hi, everybody, From Robert N M Watson (1) UFS_ACL isn't enabled Yes, I am sure that in my kernel config: options UFS_ACL options UFS_EXTATTR options UFS_EXTATTR_AUTOSTART (2) Extended attributes aren't available on the file system (shouldn't happen for UFS2, but might happen for UFS1 if you