Re: TESTING

2000-04-06 Thread Thimble Smith
I get a lot of messages. Something's wrong with your subscription. Tim On Fri, Apr 07, 2000 at 04:08:18AM +0200, Juergen A. Erhard wrote: >-BEGIN PGP SIGNED MESSAGE- >Hash: SHA1 > >Just trying whether this list is alive... > >(But even if, it is probably effectively dead... I subscribed

TESTING

2000-04-06 Thread Juergen A. Erhard
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Just trying whether this list is alive... (But even if, it is probably effectively dead... I subscribed Mar 9th, and have yet to see a single message). - -- Jürgen A. Erhard eMail: [EMAIL PROTECTED] phone: (GERMANY) 0721 27326 -BEGIN

Re: string to Integer

2000-04-06 Thread Yuichi Tsuchimoto
> > And if I call the label on the stones "integer_from_string" > > and "integer_from_intlist", unflipped (.) does as well. > > But then the question is which function name is more natural. > Arjen's choice of names reflects Haskell's syntax for function > types: > > intlist_to_intege

Re: string to Integer

2000-04-06 Thread Ronny Wichers Schreur
I wrote: > (.) :: ((a -> b) -> (c -> a)) -> (c -> b) > flip (.) :: ((a -> b) -> (b -> c)) -> (a -> c) Hm, let me try that again: (.) :: (a -> b) -> (c -> a) -> (c -> b) flip (.) :: (a -> b) -> (b -> c) -> (a -> c) Cheers, Ronny Wichers Schreur

Re: string to Integer

2000-04-06 Thread Ronny Wichers Schreur
Ralf Muschall wrote: > And if I call the label on the stones "integer_from_string" > and "integer_from_intlist", unflipped (.) does as well. But then the question is which function name is more natural. Arjen's choice of names reflects Haskell's syntax for function types: intlist_to_

Re: string to Integer

2000-04-06 Thread Ralf Muschall
Ronny Wichers Schreur schrieb: > If you think of the (types of) functions as domino stones, > |. makes them fit. And if I call the label on the stones "integer_from_string" and "integer_from_intlist", unflipped (.) does as well. The same applies to the other answers: On could write f <.< g (whic

Re: Untrusted code

2000-04-06 Thread Fergus Henderson
On 06-Apr-2000, Chris Angus <[EMAIL PROTECTED]> wrote: > I was wondering if there was any way to run code which possibly > threw an error in any version of Haskell. > > e.g. > > efficient3rdPartyAlgorithm :: Int -> Int > myOwnSlowAlgorithm :: Int -> Int > > i.e. the idea is you run the efficent

RE: Untrusted code

2000-04-06 Thread Simon Peyton-Jones
Not in standard Haskell. But you might find these interesting "A semantics for imprecise exceptions" "Asynchronous exceptions in Haskell" both on my home page http://research.microsoft.com/~simonpj (but very much joint work; and both implemented in GHC and STG Hugs) Simon | -

Re: string to Integer

2000-04-06 Thread George Russell
Ralf Muschall wrote: > Where does the habit to use "flip (.)" in many FP people come > from? I think it may come partly from category theorists

Untrusted code

2000-04-06 Thread Chris Angus
Hi, I was wondering if there was any way to run code which possibly threw an error in any version of Haskell. e.g. efficient3rdPartyAlgorithm :: Int -> Int myOwnSlowAlgorithm :: Int -> Int i.e. the idea is you run the efficent version and if falls over you run your own version. Cheers Chris