Re: [Matplotlib-users] problem building matplotlib

2010-09-15 Thread Eric Firing
On 09/14/2010 01:36 PM, Dan Kortschak wrote: Hello, I just tried to have just tried to build matplotlib, but it fails - and is unable to find wxPython (looking under 2.8 rather than 2.6 where is lives - installed from source) or libgtk-2 headers (installed from apt repo). Can anyone

Re: [Matplotlib-users] problem building matplotlib

2010-09-15 Thread Dan Kortschak
Thanks Eric, The gui dependencies are secondary, but I will look into that. Since they are optional, the absence of them should not be the cause of the failure, but it looks like it might be. Is that the case? cheers Dan On Tue, 2010-09-14 at 21:42 -1000, Eric Firing wrote: On 09/14/2010 01:36

Re: [Matplotlib-users] problem building matplotlib

2010-09-15 Thread Dan Kortschak
I've just has a look at that and unfortunately it does not fix the problem Is there any other suggestion that might be worth a try? I should point out that I already have numpy 1.4.1 installed and scipy 0.8.0 as dependencies for other packages. thanks Dan On Tue, 2010-09-14 at 21:42 -1000,

Re: [Matplotlib-users] problem building matplotlib

2010-09-15 Thread Eric Firing
On 09/15/2010 03:50 AM, Benjamin Root wrote: On Wed, Sep 15, 2010 at 5:34 AM, Dan Kortschak dan.kortsc...@adelaide.edu.au mailto:dan.kortsc...@adelaide.edu.au wrote: I've just has a look at that and unfortunately it does not fix the problem Is there any other suggestion that

Re: [Matplotlib-users] problem building matplotlib

2010-09-15 Thread Dan Kortschak
That fixes the problem. thanks On Wed, 2010-09-15 at 07:30 -1000, Eric Firing wrote: Looking again at the original build output, and at setup.py and setupext.py, it appears that there is a bug in the latter. If the wrong version of wx is found, it should be disabling the attempt to build

Re: [Matplotlib-users] problem building matplotlib

2010-09-15 Thread Eric Firing
On 09/15/2010 01:17 PM, Dan Kortschak wrote: That fixes the problem. thanks On Wed, 2010-09-15 at 07:30 -1000, Eric Firing wrote: Looking again at the original build output, and at setup.py and setupext.py, it appears that there is a bug in the latter. If the wrong version of wx is

Re: [Matplotlib-users] Problem building matplotlib

2006-10-28 Thread José Matos
On 28/10/06, Eric Firing [EMAIL PROTECTED] wrote: The error is not in matplotlib, it is in a pygtk header file, which is presumably coming from a Redhat package. I don't know why it is True. happening or what the best solution is, though. It looks like the pygobject.h that I have has

Re: [Matplotlib-users] Problem building matplotlib

2006-10-27 Thread Eric Firing
Victor Danilchenko wrote: Hi all, I am trying to build Matplotlib 0.87.7 on an RHEL 4.4-derived system, with Python 2.3.4. I am running into a weird problem. When I do python setup.py build, I get the following error: gcc: src/_gtkagg.cpp In file included from