Re: raspberry pi 3b+ how to boot with hdmi

2022-01-08 Thread Shadrock Uhuru
From: Marcus MERIGHI To: openbsd Date: Sat, 1 Jan 2022 08:42:27 +0100 Subject: Re: raspberry pi 3b+ how to boot with hdmi Good morning 2022, niyal...@gmail.com (Shadrock Uhuru), 2021.01.01 (Sat) 05:54 (CET): > From: Stuart Henderson > To: misc@openbsd.org > Date: Tue, 28 Dec 2

Re: raspberry pi 3b+ how to boot with hdmi

2021-12-31 Thread Shadrock Uhuru
From: Stuart Henderson To: misc@openbsd.org Date: Tue, 28 Dec 2021 12:55:27 - (UTC) Subject: Re: raspberry pi 3b+ how to boot with hdmi > On 2021-12-28, Shadrock Uhuru wrote: > hi everyone > i have successfully installed the latest snapshot onto a rpi3b+ > using a

qq

2021-12-30 Thread Shadrock Uhuru
From: Stuart Henderson To: misc@openbsd.org Date: Tue, 28 Dec 2021 12:55:27 - (UTC) Subject: Re: raspberry pi 3b+ how to boot with hdmi On 2021-12-28, Shadrock Uhuru wrote: hi everyone i have successfully installed the latest snapshot onto a rpi3b+ using a serial cable, after rebooting

raspberry pi 3b+ how to boot with hdmi

2021-12-28 Thread Shadrock Uhuru
hi everyone i have successfully installed the latest snapshot onto a rpi3b+ using a serial cable, after rebooting still with the serial cable everything startup fine, when i try to reboot with a hdmi monitor connected i get a few line at startup then the screen goes blank, what configuration do

raspberry pi3 doesn,t boot after install

2021-11-28 Thread Shadrock Uhuru
hi everyone i've installed openbsd 7.0 onto a usb stick connected to my raspberry pi 3 with a serial cable, installation completes without a problem, after the congratulation promt i remove the power supply remove the usb stick and mount the i partition of the usb stick on my laptop, and add

Re: after sysupgrade, /etc/rc syntax error

2021-07-25 Thread shadrock uhuru
worked perfectly many thanks shadrock On Sat, 24 Jul 2021 at 21:42, shadrock uhuru wrote: > thanks for the quick reply Andreas > will try it later tonight when i'm back at the laptop. > shadrock > > On Sat, 24 Jul 2021 at 20:36, Andreas Kusalananda Kähäri < > andreas

Re: after sysupgrade, /etc/rc syntax error

2021-07-24 Thread shadrock uhuru
thanks for the quick reply Andreas will try it later tonight when i'm back at the laptop. shadrock On Sat, 24 Jul 2021 at 20:36, Andreas Kusalananda Kähäri < andreas.kah...@abc.se> wrote: > On Sat, Jul 24, 2021 at 07:11:30PM +0100, shadrock uhuru wrote: > > Hi all > >

after sysupgrade, /etc/rc syntax error

2021-07-24 Thread shadrock uhuru
Hi all i am running openbsd snapshot and have sysupgraded often without a single hitch, on this occasion i have encountered the following error after the sysupgrade and the laptop tried to reboot i entered sh and had a look at /etc/rc with ed, the if is matched with a fi. so i need suggestions

can't set export GPG_TTY=$(tty)

2021-06-18 Thread Shadrock Uhuru
hi everyone i have added export GPG_TTY=$(tty); eval $(gpg-agent --daemon) to my .profile file and also tried adding it to my .zshrc, my window manager is I3, when i open a terminal and and type env | grep GPG_TTY i get GPG_TTY=not a tty, if i run the export command in the terminal then i get

can texlive package be installed ?

2021-02-27 Thread Shadrock Uhuru
system information. OpenBSD 6.9 GENERIC.MP#343 amd64 flavor: current when i try to install texlive, all i get is :- doas pkg_add -v texlive_texmf-full Update candidates: quirks-3.588 -> quirks-3.588 quirks-3.588 signed on 2021-02-26T23:14:00Z Ustar

firefox crashed, no web access after attempted fix

2021-01-16 Thread Shadrock Uhuru
hi everyone i'm running 6.8 current, my problem started when firefox which had been working perfectly suddenly started crashing on startup, i don't know if it was because i shutdown the laptop with to many tab open in firefox, after many google searches i tried creating a new profile and copying

Re: what should i do with these package warnings

2020-07-12 Thread Shadrock Uhuru
From: Stuart Henderson To: misc@openbsd.org Subject: Re: what should i do with these package warnings Date: Tue, 7 Jul 2020 08:36:51 - (UTC) On 2020-07-07, Shadrock Uhuru wrote: hi everyone Q2 should i remove these missing dependencies ? also the issue of "lib should exist

what should i do with these package warnings

2020-07-06 Thread Shadrock Uhuru
hi everyone Q1 should i remove these Obsolete package ? doas pkg_add -u quirks-3.369 signed on 2020-06-27T20:23:25Z Obsolete package: grantlee-0.5.1p5 (no longer maintained upstream) Obsolete package: kfilemetadata-4.14.3p2 (no longer maintained upstream) Obsolete package: libkexiv2-4.14.3p1

Re: pass 'password manager' problem

2020-02-26 Thread Shadrock Uhuru
On 26.02.2020 10:57, Andreas Kusalananda Kähäri wrote: On Wed, Feb 26, 2020 at 09:37:53AM +, Shadrock Uhuru wrote: > > --- > > > > shadrock Hi yes i have gpg2 installed gpg-agent.conf has cat .gn

Re: pass 'password manager' problem

2020-02-26 Thread Shadrock Uhuru
~.profile : export GPG_TTY=$(tty) Shadrock Uhuru wrote: [-- text/plain, encoding 8bit, charset: utf-8, 61 lines --] Hi From: Rubén Llorente To: misc@openbsd.org Subject: Re: pass 'password manager' problem Date: Fri, 21 Feb 2020 16:22:37 - (UTC) Do you have a ~.gnupg/gpg.conf ? Pass works fine

Re: pass 'password manager' problem

2020-02-23 Thread Shadrock Uhuru
Hi From: Rubén Llorente To: misc@openbsd.org Subject: Re: pass 'password manager' problem Date: Fri, 21 Feb 2020 16:22:37 - (UTC) Do you have a ~.gnupg/gpg.conf ? Pass works fine for me. Shadrock Uhuru wrote: [-- text/plain, encoding 7bit, charset: utf-8, 6 lines --] running 'pass

pass 'password manager' problem

2020-02-21 Thread Shadrock Uhuru
running 'pass username' returns "gpg: Sorry, we are in batchmode - can't get input", am i missing a piece of software or setting ? shadrock smime.p7s Description: S/MIME cryptographic signature

Re: no flows with my iked vpn

2020-02-13 Thread Shadrock Uhuru
On 13.02.2020 08:43, Robert Paschedag wrote: sent from my mobile device Am 12. Februar 2020 15:07:46 schrieb Shadrock Uhuru : hi everyone i have setup iked on my firewall and laptop as a roadwarrior setup following https://www.openbsd.org/faq/faq17.html i.ve tested from within the local

no flows with my iked vpn

2020-02-12 Thread Shadrock Uhuru
hi everyone i have setup iked on my firewall and laptop as a roadwarrior setup following https://www.openbsd.org/faq/faq17.html i.ve tested from within the local network but no flows are started. could someone have a look at the following files to see where i have erred. # my iked config

Re: do i need to configure mkinitcpio.conf for my md array ?

2020-01-16 Thread Shadrock Uhuru
hardware passthrough to access the data. Am 16.01.20 um 13:10 schrieb Shadrock Uhuru: i have just configured my 4 disk raid 10 array with mdadm, the filesystem is ext4 unencrypted and arch is installed on a separate disk, do i need to reconfigure mkinitcpio.conf for my md array so that the array

do i need to configure mkinitcpio.conf for my md array ?

2020-01-16 Thread Shadrock Uhuru
i have just configured my 4 disk raid 10 array with mdadm, the filesystem is ext4 unencrypted and arch is installed on a separate disk, do i need to reconfigure mkinitcpio.conf for my md array so that the array is assembled and started at boot, all the examples i've seen have arch installed on

Re: [arch-general] how to upgrade 2017 server ?

2020-01-14 Thread Shadrock Uhuru
On 15.01.2020 02:05, Shadrock Uhuru wrote: On 11.01.2020 14:00, Chris Billington wrote: Pacman static will likely help, but you'll need to actually install it and use it, i.e.: sudo pacman -S pacman-static sudo pacman-static -Syu On Sat, Jan 11, 2020 at 1:57 PM Shadrock Uhuru via arch-general

Re: wrong pkg_add url after sysupgrade

2019-10-10 Thread shadrock uhuru
On 10/9/19 2:56 PM, Paul de Weerd wrote: On Wed, Oct 09, 2019 at 01:40:42PM +, shadrock uhuru wrote: | after trying sysupgrade for the first time on my laptop running snapshots | running the following command returns no such dir. | | doas pkg_add -u | https://ftp.OpenBSD.org/pub/OpenBSD/6.6

wrong pkg_add url after sysupgrade

2019-10-09 Thread shadrock uhuru
after trying sysupgrade for the first time on my laptop running snapshots running the following command returns no such dir. doas pkg_add -u https://ftp.OpenBSD.org/pub/OpenBSD/6.6/packages/amd64/: no such dir pkg_info p5-finance https://ftp.OpenBSD.org/pub/OpenBSD/6.6/packages/amd64/: no such

dhcpcd[82953]: pppoe0: DHCPv6 REPLY: NoAddrsAvail

2019-10-07 Thread shadrock uhuru
hi everyone does the following error in */var/log/*{messages,daemon} indicate a problem at my internet providers end of the line or one of my config files dhcpcd[82953]: pppoe0: DHCPv6 REPLY: NoAddrsAvail i have pd prefix addresses being assigned on my lan network but no nd prefix address

Re: authpf unable to exit ssh without control C

2019-09-17 Thread shadrock uhuru
> To: > misc@openbsd.org > > > On 9/15/19 7:31 AM, shadrock uhuru wrote: >> hi everyone >> i can login with authpf but unable to exit or control D out of the ssh >> session >> the only way out is to control C which also kills any other ordinary ssh >> u

authpf unable to exit ssh without control C

2019-09-15 Thread shadrock uhuru
hi everyone i can login with authpf but unable to exit or control D out of the ssh session the only way out is to control C which also kills any other ordinary ssh user connected to the server my authpf user has authpf as its login shell and login class, is this normal behaviour  ? shadrock

pppoe no carrier

2019-09-09 Thread shadrock uhuru
hi everyone i have setup pppoe and the interface comes up fine, the pppoedev is connected  to a fritzbox modem and zen internet is the provider speaking to one of their advisers i was told that all i had to do was connect to one of the lan ports on the fritzbox then i could do the pppoe from my

antispoof or urpf-failed ?

2019-09-02 Thread shadrock uhuru
hi everyone http://lists.dragonflybsd.org/pipermail/users/2017-August/313577.html states that the "urpf-failed" block rule causes the IPv6 traffic (ping) significant packet loss, while IPv4 remains fine is this correct ? https://lipidity.com/openbsd/router/ states The antispoof rules should be

Re: dhcrelay

2019-08-29 Thread shadrock uhuru
hiya thanks for the reply > hi eveyone > if i have a dhcp server in subnet A connected to interface em0 (lan) and > subnet B connected to interface iwn0 (wireless zone) on the router > with dhcrelay -i em0 running on the router should the wireless subnet be > able?? to get its dhcp address from

missing PD Prefix 's

2019-08-29 Thread shadrock uhuru
hi everyone how do i check if rad is working correctly i have a PD Prefix address on my routers wan interface but not on its lan interface or anywhere on the lan rad is configured with the following cat /etc/rad.conf interface em0 interface em1 interface tun0 i also have dhcpcd configured cat <<

Re :dhcrelay

2019-08-25 Thread shadrock uhuru
> To: > shadrock uhuru > CC: > misc@openbsd.org > > > shadrock uhuru(niyal...@gmail.com) on 2019.08.23 18:46:32 +0100: >> hi eveyone >> if i have a dhcp server in subnet A connected to interface em0 (lan) and >> subnet B connected to interface iwn0 (wirele

dhcrelay

2019-08-23 Thread shadrock uhuru
hi eveyone if i have a dhcp server in subnet A connected to interface em0 (lan) and subnet B connected to interface iwn0 (wireless zone) on the router with dhcrelay -i em0 running on the router should the wireless subnet be able  to get its dhcp address from the dhcp server on the lan ?

Re: pf.conf anchor directories

2019-08-20 Thread shadrock uhuru
> hiya > can you have lines like this in pf.conf > anchor "authpf/vpn/*" in on $VPN_IFACE > anchor "authpf/wireless/*" in on $WIRE_IFACE > and have anchors in /etc/authpf/vpn with your vpn rules > and anchors in /etc/authpf/wireless with your wireless rules

pf.conf anchor directories

2019-08-19 Thread shadrock uhuru
hiya can you have lines like this in pf.conf anchor "authpf/vpn/*" in on $VPN_IFACE anchor "authpf/wireless/*" in on $WIRE_IFACE and have anchors in /etc/authpf/vpn with your vpn rules and anchors in /etc/authpf/wireless with your wireless rules ? shadrock

Re: can't find libpcap

2019-08-18 Thread shadrock uhuru
> Hi, > > shadrock uhuru wrote on Sat, Aug 17, 2019 at 01:01:08PM +0100: > >> is there a package for pcap or libpcap >> or do i have to download the source and compile > to answer such questions, use pkg_locate(1). > ># pkg_add pkglocatedb >$ man pkg

Re: can't find libpcap

2019-08-17 Thread shadrock uhuru
On 8/17/19 1:07 PM, Noth wrote: > On 17/08/2019 14:01, shadrock uhuru wrote: >> hi everyone >> is there a package for pcap or libpcap >> or do i have to download the source and compile >> shadrock >> > libpcap is in base, see man pcap. It lives in /usr/lib. thanks

can't find libpcap

2019-08-17 Thread shadrock uhuru
hi everyone is there a package for pcap or libpcap or do i have to download the source and compile shadrock

packet filter questions

2019-08-16 Thread shadrock uhuru
hi  everyone # # internal interface INT_IFACE = "em0" # external wan interface EXT_IFACE = "bge0" # wireless interface WIRE_IFACE = "em1" # openvpn interface VPN_IFACE = "tun0" LO_IFACE = "lo" LO_ADDR_INET4 = "127.0.0.1" LO_ADDR_INET6 =

Re: adding ipv6 and pppoe to my firewall

2019-07-19 Thread shadrock uhuru
Hi Stuart thanks for the reply On 7/12/19 1:20 PM, owner-m...@openbsd.org wrote: >> hypothetical ipv4 Address and ipv6 prefix from zen: >> ND Prefix: :::::/64 >> PD Prefix: ::::/48 >> IPv4 Address:     12.34.56.78 (Subnet mask 255.255.255.255)

Re: adding ipv6 and pppoe to my firewall

2019-07-19 Thread shadrock uhuru
Hi Stuart thanks for the reply On 7/12/19 1:20 PM, misc@openbsd.org wrote: >> hypothetical ipv4 Address and ipv6 prefix from zen: >> ND Prefix: :::::/64 >> PD Prefix: ::::/48 >> IPv4 Address: ?? 12.34.56.78 (Subnet mask 255.255.255.255)

Re: adding ipv6 and pppoe to my firewall

2019-07-10 Thread shadrock uhuru
> hi  everyone > i have a dual redundant firewall setup the same as the example given at > https://www.openbsd.org/faq/pf/carp.html > i was originally with virgin media but have moved to a provider > offering ipv4, ipv6 and fixed ip addresses, > i am now trying  to add ipv6 and pppoe to the

adding ipv6 and pppoe to my firewall

2019-07-09 Thread shadrock uhuru
hi  everyone i have a dual redundant firewall setup the same as the example given at https://www.openbsd.org/faq/pf/carp.html i was originally with virgin media but have moved to a provider offering ipv4, ipv6 and fixed ip addresses, i am now trying  to add ipv6 and pppoe to the firewall. i

Fwd: howto verify keydisk backup

2019-06-19 Thread shadrock uhuru
Forwarded Message Subject:Re: howto verify keydisk backup Date: Wed, 19 Jun 2019 09:23:53 +0100 From: shadrock uhuru To: noah pugsley On 6/19/19 5:25 AM, noah pugsley wrote: > On Tue, Jun 18, 2019 at 5:37 PM shadrock uhuru wrote: >> hi every

howto verify keydisk backup

2019-06-18 Thread shadrock uhuru
hi everyone my keydisk is on a compactflash sandisk ultra 2 card, which was created during disk encryption doas disklabel sd1 # /dev/rsd1c: type: SCSI disk: SCSI disk label: USB CARD READER duid: ea53e532b5ae2a0f flags: bytes/sector: 512 sectors/track: 63 tracks/cylinder: 255 sectors/cylinder:

how to setup wireless for redundent firewalls ?

2019-05-23 Thread shadrock uhuru
hi everyone i have two firewalls setup with carp and pfsync with my wireless router fed straight into the switch connected to the lan , this is fine for me as a single user of my network. i would like to improve the setup to include other users while allowing them  access to the internet and

Re: i3bar not working after 6.5 upgrade

2019-05-14 Thread shadrock uhuru
On 5/13/19 12:51 PM, Edgar Pettijohn wrote: > On May 13, 2019 2:58 AM, shadrock uhuru wrote: >> >> >> On 5/13/19 1:35 AM, shadrock uhuru wrote: >>> hi everyone >>> since upgrading to 6.5 my i3bar no longer works. >>> i have not changed the conf

Re: i3bar not working after 6.5 upgrade

2019-05-13 Thread shadrock uhuru
On 5/13/19 1:35 AM, shadrock uhuru wrote: > hi everyone > since upgrading to 6.5 my i3bar no longer works. > i have not changed the configuration in any way > when i run the i3status command manually in a terminal the bar is not > displayed but the correct infomation that would

i3bar not working after 6.5 upgrade

2019-05-13 Thread shadrock uhuru
hi everyone since upgrading to 6.5 my i3bar no longer works. i have not changed the configuration in any way when i run the i3status command manually in a terminal the correct information that would be on the i3bar is echoed to the terminal. the message on the right hand of the i3bar is error:

Re: Upgrade procedure encrypted filesystem (6.4 -> 6.5)

2019-05-09 Thread shadrock uhuru
On 5/9/19 11:56 AM, cho...@jtan.com wrote: > shadrock uhuru writes: >> i've got a couple of follow up queries concerning post upgrade things todo. >> >> --- -dbus-1.12.10p0v0 --- >> Remember to update /etc/machine-id >> how do i update machin

Re: Upgrade procedure encrypted filesystem (6.4 -> 6.5)

2019-05-09 Thread shadrock uhuru
On 5/7/19 9:16 PM, Omar Polo wrote: > On Tue, May 07, 2019 at 02:04:03AM +0100, shadrock uhuru wrote: >> >> On 5/6/19 8:18 PM, Omar Polo wrote: >>> On Mon, May 06, 2019 at 07:46:53PM +0100, shadrock uhuru wrote: >>>> hi everyone >>>> when upgra

Upgrade procedure encrypted filesystem (6.4 -> 6.5)

2019-05-06 Thread shadrock uhuru
hi everyone when upgrading my laptop which is encrypted with a keydisk i assume that i boot the 6.5 kernel which will be on a usb stick with the keydisk inserted, will the hard drive still be decrypted and upgraded, also will the encryption step need to be redone or will the keydisk continue to

missing sdl header and lib files

2019-02-08 Thread shadrock uhuru
hi everyone i have added the following packages sdl sdl-mixer sdl_image sdl_net sdl_ttf sdl2 sdl2-mixer sdl2_image sdl2_net sdl2_ttf the lib and header files are missing are there additional packages to add for these. shadrock

pycharm updates ?

2019-01-30 Thread shadrock uhuru
hi everyone just a quick question about pycharm updates do i allow pycharm to update its's IDE and Plugins or only update it with pkg_add -u ? shadrock

howto set terminus font in .Xresources for xterm

2018-12-31 Thread shadrock uhuru
hi everyone what is the correct command to put in .Xresources for the terminus font, the following is my Xresources file, i've tried a few variation but all i get when i start xterm is cannot load font, font loading is new to me so i have only try examples off the web --- XTerm*utf8: 1 !

Re: ports/devel/pygame make install error

2018-12-28 Thread shadrock uhuru
On 12/27/18 3:35 PM, Edgar Pettijohn wrote: i have openbsd 6.4 release installed how do i fix this ? > Don't mix release with current ports. > > Either install a current snapshot or ... > >> doas cvs -d anon...@anoncvs1.ca.openbsd.org:/cvs -q up -Pd -A >> > rm -rf /usr/ports > And

Re: ports/devel/pygame make install error

2018-12-27 Thread shadrock uhuru
On 12/27/18 3:48 AM, Anthony J. Bentley wrote: > shadrock uhuru writes: >> hi everyone >> >> i have openbsd 6.4 release installed >> >> when i try to make install  ports/devel/pygame i get an error stating >> >> create /usr/ports/packages/am

ports/devel/pygame make install error

2018-12-26 Thread shadrock uhuru
hi everyone i have openbsd 6.4 release installed when i try to make install  ports/devel/pygame i get an error stating create /usr/ports/packages/amd64/all/py-game-1.9.3.tgz error: Libraries in packing-list in the port tree and libraries from installed packages don't match how do i fix this ?

keydisk not found when unhibernating

2018-11-27 Thread shadrock uhuru
hi everyone on powering up the laptop after closing the lid the keydisk is not found i shutdown the laptop and with the power button then restart it again this time the keydisk is found. is this behaviour normal for resuming from hibernation with an encrypted filesytem ? shadrock

apmd: howto resume with screen locked

2018-11-27 Thread shadrock uhuru
On 11/26/18 9:26 AM, Peter Hessler wrote: > On 2018 Nov 26 (Mon) at 01:18:59 + (+), shadrock uhuru wrote: > : > :also how do i resume from hibernate or suspend with the screen locked > : > :i use i3 and lock the screen with xautolock and i3lock in .i3/config > : >

apmd: howto resume with screen locked

2018-11-25 Thread shadrock uhuru
also how do i resume from hibernate or suspend with the screen locked i use i3 and lock the screen with xautolock and i3lock in .i3/config i put i3lock in /etc/apm/resume when i  resume from ZZZ no lock screen appears, i am brought straight to  my desktop shadrock

apmd: howto resume with screen locked

2018-11-25 Thread shadrock uhuru
Hi everyone i have in my /etc/rc.conf.local apmd "-A -Z8 -t120" my laptop doesn't hibernate when the power falls below 8% is there more that i need to configure ? shadrock