stumped on virtual aliases

2019-08-24 Thread Joseph A Borg
I’m trying to match an email: nos...@domain.tld to expand to webmas...@domain.tld and deliver to local mailbox. My setup is pretty simple and works well for virtual mailboxes linked to a couple of virtual domains. now I’m trying t add aliases to some accounts. From the error, it seems like

Service names in listen on directives

2019-08-24 Thread Darren S.
OpenBSD 6.5 amd64 OpenSMTPD 6.5.0 port [port] Listen on the given port instead of the default port 25. I wanted to confirm if service names are intended to be supported for `listen on` option in smtpd.conf. These result in syntax failure: listen on lo port smtp listen on lo port smtps

Re: Service names in listen on directives

2019-08-24 Thread Martijn van Duren
On 8/24/19 9:32 PM, Darren S. wrote: > OpenBSD 6.5 amd64 > OpenSMTPD 6.5.0 > > port [port] > Listen on the given port instead of the default port 25. > > I wanted to confirm if service names are intended to be supported for > `listen on` option in smtpd.conf. > > These result in syntax

Re: tags on the portable branch?

2019-08-24 Thread Harald Dunkel
Hi Gilles, On 8/24/19 9:14 PM, Gilles Chehade wrote: > > This is expected. > > Version 6.4.x only builds with LibreSSL or OpenSSL 1.0.x > do you think it would be possible to set a tag matching support for openssl 1.1.1c as well? The version I am using right now now is based on

Re: Service names in listen on directives

2019-08-24 Thread Gilles Chehade
On Sat, Aug 24, 2019 at 10:16:26PM +0200, Martijn van Duren wrote: > On 8/24/19 10:06 PM, Gilles Chehade wrote: > > On Sat, Aug 24, 2019 at 12:32:05PM -0700, Darren S. wrote: > >> OpenBSD 6.5 amd64 > >> OpenSMTPD 6.5.0 > >> > >> port [port] > >> Listen on the given port instead of the

Re: stumped on virtual aliases

2019-08-24 Thread Gilles Chehade
On Sat, Aug 24, 2019 at 04:14:21PM +0200, Joseph A Borg wrote: > I???m trying to match an email: nos...@domain.tld to expand to > webmas...@domain.tld and deliver to local mailbox. > > My setup is pretty simple and works well for virtual mailboxes linked to a > couple of virtual domains. now

Re: stumped on virtual aliases

2019-08-24 Thread Edgar Pettijohn
On Sat, Aug 24, 2019 at 04:14:21PM +0200, Joseph A Borg wrote: > I???m trying to match an email: nos...@domain.tld to expand to > webmas...@domain.tld and deliver to local mailbox. > > My setup is pretty simple and works well for virtual mailboxes linked to a > couple of virtual domains. now

Re: Service names in listen on directives

2019-08-24 Thread Gilles Chehade
On Sat, Aug 24, 2019 at 12:32:05PM -0700, Darren S. wrote: > OpenBSD 6.5 amd64 > OpenSMTPD 6.5.0 > > port [port] > Listen on the given port instead of the default port 25. > > I wanted to confirm if service names are intended to be supported for > `listen on` option in smtpd.conf. > >

Re: tags on the portable branch?

2019-08-24 Thread Harald Dunkel
On 8/23/19 9:55 PM, John Cox wrote: > Hi > > Whilst I know it doesn't help you I just git cloned that URL and the > tag checkout just worked for me. What happens if you make another new > (temporary) repo with clone and try again? > > Regards > > John Cox > Using a new clone, as suggested:

Re: stumped on virtual aliases

2019-08-24 Thread Joseph A Borg
AFAIK I can do that Edgar, I’m already filtering on domain, so the domain stump is not really necessary. this is not an urgent work situation, I’m just trying things out and spent way too much time understanding this not to bother the list. If there is a workaround or it’s a known issue it’s

Re: stumped on virtual aliases

2019-08-24 Thread Edgar Pettijohn
On Sat, Aug 24, 2019 at 06:02:55PM +0200, Joseph A Borg wrote: > AFAIK I can do that Edgar, I???m already filtering on domain, so the domain > stump is not really necessary. > > this is not an urgent work situation, I???m just trying things out and spent > way too much time understanding this

Re: tags on the portable branch?

2019-08-24 Thread Gilles Chehade
On Sat, Aug 24, 2019 at 04:19:11PM +0200, Harald Dunkel wrote: > On 8/23/19 9:55 PM, John Cox wrote: > > Hi > > > > Whilst I know it doesn't help you I just git cloned that URL and the > > tag checkout just worked for me. What happens if you make another new > > (temporary) repo with clone and

Re: table api question

2019-08-24 Thread Edgar Pettijohn
On Sat, Aug 24, 2019 at 08:19:00AM +, gil...@poolp.org wrote: > 24 ao??t 2019 02:59 "Edgar Pettijohn" a ??crit: > > > I am writing a table-lua, however the table_lua_update function doesn't > > appear to be called. > > Here are relevant pieces of the code. > > > > The lookup function

Re: table api question

2019-08-24 Thread gilles
24 août 2019 02:59 "Edgar Pettijohn" a écrit: > I am writing a table-lua, however the table_lua_update function doesn't > appear to be called. > Here are relevant pieces of the code. > > The lookup function works. However, it would be more ideal to have the > update() called early > to fill