[Bug 1922781] Re: Does not appear to work in Hirsuit Hippo

2021-04-06 Thread Unit 193
Howdy,

Yeah when you say the problem is everything looks fine it's just not
showing up, my first thought was "You're using wayland aren't you?"
Barrier doesn't work on wayland, there's an upstream bug reported[0] on
it which mentions another project[1] you may want to try if you use
GNOME on Wayland.

[0]: https://github.com/debauchee/barrier/issues/109
[1]: https://github.com/htrefil/rkvm

** Bug watch added: github.com/debauchee/barrier/issues #109
   https://github.com/debauchee/barrier/issues/109

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1922781

Title:
  Does not appear to work in Hirsuit Hippo

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/barrier/+bug/1922781/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1899841] Re: Leaks memory on client disconnect while using TLS

2020-11-23 Thread Unit 193
Howdy,

Sorry for the delay.  I tried the package as it appeared in focal and
reproduced the issue (no surprise, since I reported it) then tried the
package from -proposed which fixed the leak.

~Unit 193

** Tags removed: verification-needed verification-needed-focal
** Tags added: verification-done verification-done-focal

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1899841

Title:
  Leaks memory on client disconnect while using TLS

To manage notifications about this bug go to:
https://bugs.launchpad.net/icecast/+bug/1899841/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1899841] Re: Leaks memory on client disconnect while using TLS

2020-10-14 Thread Unit 193
** Description changed:

  Howdy,
  
  When one has TLS enabled, icecast2 leaks memory on client disconnect.
  Given the nature of a streaming server this happens all the time.
  
  There are two ways to solve this, one would be to switch to using
  OpenSSL rather than WolfSSL, while the other would be to apply a tiny
  patch that was written by one of the WolfSSL contributors and is
  attached.
  
  I tested both solutions and they most certainly do solve the problem.
  One can easily test by setting up icecast2, connecting a source client,
  then creating a loop with wget to generate a lot of connect/disconnect
  noise.
  
  
+ [Impact]
+ 
+ Anyone that uses TLS will be affected.
+ 
+ 
+ [Test Case]
+ 
+ Set up icecast2 with TLS and hook up a source client such as ices2,
+ darkice, boodler, etc.
+ 
+ Quickly connect and disconnect some clients:
+ 
+ for i in `seq 1 300`;do timeout 3 wget -O /dev/null https://DOMAIN.TLD
+ :TLS-PORT/STREAM-MOUNT;done
+ 
+ And watch the memory increase.
+ 
+ 
+ [Regression Potential]
+ 
+ Well it's a minimal patch, so topping OOM'ing due to too many clients is
+ going to be hard to beat.
+ 
+ If switching to OpenSSL, this is perhaps a bigger change due to
+ switching out TLS backends, but perhaps has been tested more.
+ 
+ 
  ~Unit 193

** Patch added: "icecast2.debdiff"
   
https://bugs.launchpad.net/debian/+source/icecast2/+bug/1899841/+attachment/5422340/+files/icecast2.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1899841

Title:
  Leaks memory on client disconnect while using TLS

To manage notifications about this bug go to:
https://bugs.launchpad.net/icecast/+bug/1899841/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1899841] [NEW] Leaks memory on client disconnect while using TLS

2020-10-14 Thread Unit 193
Public bug reported:

Howdy,

When one has TLS enabled, icecast2 leaks memory on client disconnect.
Given the nature of a streaming server this happens all the time.

There are two ways to solve this, one would be to switch to using
OpenSSL rather than WolfSSL, while the other would be to apply a tiny
patch that was written by one of the WolfSSL contributors and is
attached.

I tested both solutions and they most certainly do solve the problem.
One can easily test by setting up icecast2, connecting a source client,
then creating a loop with wget to generate a lot of connect/disconnect
noise.


~Unit 193

** Affects: icecast
 Importance: Unknown
 Status: Unknown

** Affects: icecast2 (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: icecast2 (Debian)
 Importance: Unknown
 Status: Unknown

** Attachment added: "1001-ssl_error_handling.patch"
   
https://bugs.launchpad.net/bugs/1899841/+attachment/5422292/+files/1001-ssl_error_handling.patch

** Bug watch added: gitlab.xiph.org/xiph/icecast-server/-/issues #2391
   https://gitlab.xiph.org/xiph/icecast-server/-/issues/2391

** Also affects: icecast via
   https://gitlab.xiph.org/xiph/icecast-server/-/issues/2391
   Importance: Unknown
   Status: Unknown

** Bug watch added: Debian Bug tracker #969018
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=969018

** Also affects: icecast2 (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=969018
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1899841

Title:
  Leaks memory on client disconnect while using TLS

To manage notifications about this bug go to:
https://bugs.launchpad.net/icecast/+bug/1899841/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1835968] Re: Regression in backported patch for openssl 1.1

2020-06-18 Thread Unit 193
Howdy,

After Ruby 2.7 entered Debian I re-ran the test, as far as I was aware
ruby-openssl didn't make a release in time for Ruby 2.7, and that seems
to have held true.  I have much more recently tried pulling buffering.rb
(the specific file with the bug) from upstream's git, and it would
*appear*, unless my testing was off, that the bug has also been properly
fixed upstream as well, I suspect in this[0] commit.


[0]: 
https://github.com/ruby/openssl/commit/0aaf274211d4b4877b266bc1ad406db4fd8160ab

~Unit 193

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1835968

Title:
  Regression in backported patch for openssl 1.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ruby2.5/+bug/1835968/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1881321] Re: ssl compilation option

2020-05-29 Thread Unit 193
Howdy,

As of icecast2 2.4.4-2 TLS is supported, this version is in Focal which
is the current LTS.

~Unit 193

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1881321

Title:
  ssl compilation option

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/icecast2/+bug/1881321/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1872309] Re: Sync purple-discord 0.9.2020.04.05.git.db7dc79-1 (universe) from Debian unstable (main)

2020-04-17 Thread Unit 193
This bug was fixed in the package purple-discord -
0.9.2020.04.05.git.db7dc79-1

---
purple-discord (0.9.2020.04.05.git.db7dc79-1) unstable; urgency=high

  * New upstream snapshot
- Adds workaround for crashes in ssl_nss_read (Closes: #955635)

 -- Paul Wise   Sun, 05 Apr 2020 08:09:21 +0800

purple-discord (0.9.2020.03.10.git.4e71974-1) unstable; urgency=high

  * New upstream snapshot
- Fixes issues with channel user lists and null names

 -- Paul Wise   Thu, 12 Mar 2020 11:19:53 +0800

purple-discord (0.9.2020.02.14.git.d47f0bc-1) unstable; urgency=medium

  [ Paul Wise ]
  * New upstream snapshot
  * Bump Standards-Version, no changes needed

  [ lintian-brush ]
  * Remove obsolete field Name from debian/upstream/metadata (already
present in machine-readable debian/copyright).

 -- Paul Wise   Sat, 29 Feb 2020 14:05:33 +0800

** Changed in: purple-discord (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1872309

Title:
  Sync purple-discord 0.9.2020.04.05.git.db7dc79-1 (universe) from
  Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/purple-discord/+bug/1872309/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1861672] Re: Alpine Java cacerts gets corrupted on upgrading apk-tools

2020-02-03 Thread Unit 193
Howdy,

It would appear you're filing a bug report regarding Alpine Linux, but
you have instead filed a bug report against the Alpine email client for
the Ubuntu distribution.  Perhaps you'd find more luck if you filed your
issue on https://gitlab.alpinelinux.org/alpine/aports/issues ?


Regards,
Unit 193

Unit193 @ freenode
Unit193 @ OFTC

** Changed in: alpine (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1861672

Title:
  Alpine Java cacerts gets corrupted on upgrading apk-tools

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alpine/+bug/1861672/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1839129] Re: fix it or remove it

2019-09-23 Thread Unit 193
Howdy,

As noted in LP #1822672 this was broken in 1.66ubuntu1 with a somewhat
undocumented change to the submission URL was changed from http to
https, which the codebase doesn't handle (Just gpg encryption and using
Tor)

All that needs done is to reset SUBMITURLS="http://popcon.ubuntu.com
/popcon-submit.cgi" and everything will start working again.  I've
pinged Simon a few times about this, but so far Eoan is still affected.

** Changed in: popularity-contest (Ubuntu)
   Status: Incomplete => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1839129

Title:
  fix it or remove it

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/popularity-contest/+bug/1839129/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1044420] Re: microcom fails to remove lockfiles in some cases when exiting with an error

2019-09-12 Thread Unit 193
Howdy,

Sorry for the late update.  The Debian maintainer notes that this bug
was fixed in version 2012.06.0, specifically with the following commit,
https://git.pengutronix.de/cgit/tools/microcom/commit/?id=6c9154b327c1a2b1398df6812d175baa9777f970

2012.06.0-1 first appeared in Ubuntu Quantal so this problem should be
gone.

Thanks!

** Changed in: microcom (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1044420

Title:
  microcom fails to remove lockfiles in some cases when exiting with an
  error

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/microcom/+bug/1044420/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1835968] Re: Regression in backported patch for openssl 1.1

2019-08-05 Thread Unit 193
Howdy,

Well I tested this before, but the current version in -proposed seems to
work just as expected after a few days.

** Tags removed: verification-needed-bionic
** Tags added: verification-done-bionic

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1835968

Title:
  Regression in backported patch for openssl 1.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ruby2.5/+bug/1835968/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1835968] Re: Regression in backported patch for openssl 1.1

2019-07-29 Thread Unit 193
Howdy,

While I haven't done anything specific to put it to the test, I've let
cron do its thing and so far haven't hit any issues on either line
ending type.  So I'm going to say it looks good to me!

~Unit 193

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1835968

Title:
  Regression in backported patch for openssl 1.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ruby2.5/+bug/1835968/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1835968] Re: Regression in backported patch for openssl 1.1

2019-07-25 Thread Unit 193
Howdy,

You came up with the same conclusion I had above, including suspecting
patch 16 first as well.  I've added the repo, upgraded, and we'll see
how this goes for a little bit.

~Unit 193

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1835968

Title:
  Regression in backported patch for openssl 1.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ruby2.5/+bug/1835968/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1835968] Re: Regression in backported patch for openssl 1.1

2019-07-12 Thread Unit 193
Howdy,

"to confirm - reverting just [2] (and no other components of this) fixes
the issue for you?"  Yes, this is precisely what I am saying.  Reverting
just that makes everything work for me.

Eh, the "testcase" isn't really a proper testcase, but it was narrowed
down enough for me to reproduce the error and confirm when specifically
it was gone.  Otherwise it's pretty poor.

Thanks for looking into this issue!


~Unit 193

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1835968

Title:
  Regression in backported patch for openssl 1.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ruby2.5/+bug/1835968/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1835968] Re: Regression in backported patch for openssl 1.1

2019-07-10 Thread Unit 193
Howdy,

So I got a bit of a simpler testcase worked out (though due to reasons,
it's not something I'd like to make fully public, can PM it) and it
ended up being 251b5be20d5b58c27490f44cdeb6e655f9be6f19 that was giving
me the trouble.

I also made an Eoan chroot and tried the test script, it worked like a
charm so this is limited to Bionic.  That is to be expected though since
Eoan doesn't carry the commit.

~Unit 193

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1835968

Title:
  Regression in backported patch for openssl 1.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ruby2.5/+bug/1835968/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1835968] Re: Regression in backported patch for openssl 1.1

2019-07-10 Thread Unit 193
Howdy,

My apologies I never mentioned what version I was on.  And I went from
2.5.1-1ubuntu1.2 to 2.5.1-1ubuntu1.4 it would seem.

I don't exactly have a minimal testcase since the error happened when
interacting with a smtpd.

As part of the openssl 1.1 upgrade, a couple patches were added to
ruby2.5.  If you note the path I mentioned it's the embedded copy of
ruby/openssl that libruby2.5 ships.  If you look at ruby2.5 now, Ubuntu
eoan carries a couple patches over what Debian has.  Given the package
changelog, I would presume 3f6e30e53ce8050375955322e170612e1de099b1 is
the offending commit[0].

The diff I attached shows that Ubuntu also added
251b5be20d5b58c27490f44cdeb6e655f9be6f19 over what Debian has, I could
add that patch back to my system and see if I still am error free if
that'd help in any way.


[0]: 
https://github.com/ruby/openssl/commit/3f6e30e53ce8050375955322e170612e1de099b1

~Unit 193

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1835968

Title:
  Regression in backported patch for openssl 1.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ruby2.5/+bug/1835968/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1835968] [NEW] Regression in backported patch for openssl 1.1

2019-07-09 Thread Unit 193
Public bug reported:

Howdy,

After the update of ruby2.5 (2.5.1-1ubuntu1.4) I started getting this
error "incompatible character encodings: ASCII-8BIT and UTF-8"
intermittently, depending on contents.  I copied
/usr/lib/ruby/2.5.0/openssl/buffering.rb (as mentioned in the root of
the traceback) over from buster/testing and the issues went away.

When using 'file' to check the output documents for what failed in
Ubuntu vs the ones that didn't, I got the following results:

Works: "HTML document, UTF-8 Unicode text, with very long lines"
Fails: "HTML document, UTF-8 Unicode text, with very long lines, with CRLF, LF 
line terminators"

The diff of buffering.rb between Ubuntu and Debian is attached.

** Affects: ruby2.5 (Ubuntu)
 Importance: Undecided
 Status: New

** Attachment added: "buffering.patch"
   
https://bugs.launchpad.net/bugs/1835968/+attachment/5275940/+files/buffering.patch

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1835968

Title:
  Regression in backported patch for openssl 1.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ruby2.5/+bug/1835968/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1785821] Re: "pastebinit -i file" to paste.openstack.org fails: Object of type 'bytes' is not JSON serializable

2019-07-06 Thread Unit 193
Howdy,

This is fixable with a very simple patch, though I'm not sure what the
downside of it is:

--- a/usr/bin/pastebinit/pastebinit  2016-03-01 00:52:32.0 -0500
+++ b/usr/bin/pastebinit/pastebinit  2019-07-06 19:39:43.280603245 -0400
@@ -349,7 +348,7 @@
 content = sys.stdin.read()
 else:
 try:
-with open(filename, "rb") as fd:
+with open(filename, "r") as fd:
 content = fd.read()
 except KeyboardInterrupt:
 print(_("KeyboardInterrupt caught."), file=sys.stderr)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1785821

Title:
  "pastebinit -i file" to paste.openstack.org fails: Object of type
  'bytes' is not JSON serializable

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pastebinit/+bug/1785821/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1829530] Re: synergy's fork replaces it, should be pointed in dpkg package

2019-07-06 Thread Unit 193
Howdy,

It's a fork, they have the same end goal and at this point use
compatible protocols, but Barrier is not a renamed Synergy.  Synergy
still exists and as far as I'm aware they still have releases so it'd be
improper to add a transitional package to Barrier from Synergy.  Synergy
even still exists in the Debian (and Ubuntu) archives.

~Unit 193

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1829530

Title:
  synergy's fork replaces it, should be pointed in dpkg package

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/barrier/+bug/1829530/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1835320] Re: mu-editor python debugger broken.

2019-07-03 Thread Unit 193
** Also affects: mu-editor (Ubuntu Disco)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1835320

Title:
  mu-editor python debugger broken.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mu-editor/+bug/1835320/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 399956] Re: Opening new tabs causes window size to exceed screen size

2019-07-02 Thread Unit 193
As noted by upstream, fixed in the port to VTE3.

** Changed in: xfce4-terminal (Ubuntu)
   Status: Triaged => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/399956

Title:
  Opening new tabs causes window size to exceed screen size

To manage notifications about this bug go to:
https://bugs.launchpad.net/xfce4-terminal/+bug/399956/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1796212] Re: xfce4-terminal fails to update utmp; breaks write, wall, who commands

2019-07-02 Thread Unit 193
This was fixed with the following upload:

 xfce4-terminal (0.8.7.4-2) unstable; urgency=medium

   * add build-dep on libutempter (closes: #904789)
   * d/control: update standards version to 4.2.1
   * d/watch: use https protocol
   * d/lintian-overrides added, ignore warning about fortify
   * d/control: drop b-d on chrpath, we don't use it

** Changed in: xfce4-terminal (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1796212

Title:
  xfce4-terminal fails to update utmp; breaks write, wall, who commands

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xfce4-terminal/+bug/1796212/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1422626] Re: Terminal not maximized when tiling

2019-07-02 Thread Unit 193
As noted by the upstream maintainer, this was fixed in the migration to
vte3.

** Changed in: xfce4-terminal (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1422626

Title:
  Terminal not maximized when tiling

To manage notifications about this bug go to:
https://bugs.launchpad.net/xfce4-terminal/+bug/1422626/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1760691] Re: Please switch to Ayatana AppIndicator

2019-06-14 Thread Unit 193
** Changed in: update-notifier (Ubuntu)
   Status: Fix Released => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1760691

Title:
  Please switch to Ayatana AppIndicator

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1760691/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1812232] Re: Deprecation warnings

2019-05-14 Thread Unit 193
Howdy,

The problem I described is new as of this SRU, the issue you're hitting
is an older one.  You can't use -i but must pipe output to pastebinit:

unit193@Sigma:~$ cat popcon_perf2.patch | pastebinit
/usr/bin/pastebinit:42: DeprecationWarning: dist() and linux_distribution() 
functions are deprecated in Python 3.5
  release = platform.linux_distribution()[0].lower()
/usr/bin/pastebinit:414: DeprecationWarning: pasteURLopener style of invoking 
requests is deprecated. Use newer urlopen functions/methods
  url_opener = pasteURLopener()
http://paste.openstack.org/show/5PwveZ4A1TjJb5YrsyeD

This is with 1.5-2 on disco.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1812232

Title:
  Deprecation warnings

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pastebinit/+bug/1812232/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1812232] Re: Deprecation warnings

2019-05-13 Thread Unit 193
** Tags added: regression-proposed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1812232

Title:
  Deprecation warnings

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pastebinit/+bug/1812232/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1812232] Re: Deprecation warnings

2019-05-13 Thread Unit 193
Howdy,

While attempting to use this version of pastebinit with the openstack
pastebin, it fails and spits out the following error:

 Failed to contact the server: POST data should be bytes, an iterable of
bytes, or a file object. It cannot be of type str.

As this is a regression, I don't think this should be SRU'd as-is.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1812232

Title:
  Deprecation warnings

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pastebinit/+bug/1812232/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1827486] Re: Weather data failure

2019-05-06 Thread Unit 193
Howdy,

As noted by the upstream maintainer, this bug was fixed in version
3.0.31 with the following changelog entry:

 3. BIG: current inxi weather will probably fail if not updated to this or
 newer versions!! Not an inxi bug per se, but your users will see it as one.

This will, of course, affect all versions prior to that release.

** Changed in: inxi (Ubuntu)
   Status: Confirmed => Fix Released

** Also affects: inxi (Ubuntu Bionic)
   Importance: Undecided
   Status: New

** Also affects: inxi (Ubuntu Cosmic)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1827486

Title:
  Weather data failure

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/inxi/+bug/1827486/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1529647] Re: [SRU] Always backport newer versions

2019-04-24 Thread Unit 193
** Changed in: hundredpapercuts
   Status: Confirmed => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1529647

Title:
  [SRU] Always backport newer versions

To manage notifications about this bug go to:
https://bugs.launchpad.net/hundredpapercuts/+bug/1529647/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1392797] Re: Unable to extract Initial JS player signature function name

2019-04-24 Thread Unit 193
** Changed in: hundredpapercuts
   Status: Confirmed => Invalid

** Changed in: youtube-dl (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1392797

Title:
  Unable to extract Initial JS player signature function name

To manage notifications about this bug go to:
https://bugs.launchpad.net/hundredpapercuts/+bug/1392797/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1437149] Re: download of ZDF Mediathek Video hangs at 100%

2019-04-24 Thread Unit 193
Howdy,

I've looked through several issue reports for that host at around the
time this was filed, there's been several fixes and while test
downloading a video from that site I could no longer reproduce said
issue.  The problem is at least fixed in 2019.01.17-1, but presumably
much earlier as well.

** Changed in: youtube-dl (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1437149

Title:
  download of ZDF Mediathek Video hangs at 100%

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/youtube-dl/+bug/1437149/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1318363] Re: can't download this youtube video

2019-04-24 Thread Unit 193
Howdy,

This was upstream issue https://github.com/ytdl-org/youtube-
dl/issues/3754, which was also reported in LP: #1402981 and has been
(long since) fixed in Ubuntu.


** Bug watch added: github.com/ytdl-org/youtube-dl/issues #3754
   https://github.com/ytdl-org/youtube-dl/issues/3754

** Changed in: youtube-dl (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1318363

Title:
  can't download this youtube video

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/youtube-dl/+bug/1318363/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1402981] Re: Breaks with Automatic signature extraction failed and then 403

2019-04-24 Thread Unit 193
Howdy,

As noted, the upstream bug has been solved and the release has trickled
down to Ubuntu.  Sorry for the late comment.

** Changed in: youtube-dl (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1402981

Title:
  Breaks with Automatic signature extraction failed and then 403

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/youtube-dl/+bug/1402981/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1479493] Re: ERROR: unable to download video data: HTTP Error 403: Forbidden

2019-04-24 Thread Unit 193
Howdy,

This was upstream issue https://github.com/ytdl-org/youtube-
dl/issues/3754, which was also reported in LP: #1402981 and has been
(long since) fixed in Ubuntu.

** Bug watch added: github.com/ytdl-org/youtube-dl/issues #3754
   https://github.com/ytdl-org/youtube-dl/issues/3754

** Changed in: youtube-dl (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1479493

Title:
  ERROR: unable to download video data: HTTP Error 403: Forbidden

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/youtube-dl/+bug/1479493/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1637874] Re: youtube-dl --quiet is anything but

2019-04-24 Thread Unit 193
Howdy,

This bug was subsequently fixed in https://github.com/ytdl-org/youtube-
dl/commit/a609e61a90ad8f3b472e2e221f9f75c8408b65f2 which is in release
2017.05.23 and on.

** Changed in: youtube-dl (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1637874

Title:
  youtube-dl --quiet is anything but

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/youtube-dl/+bug/1637874/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1774728] Re: Installing youtube-dl on ubuntu minimal brings in far too many extraneous dependencies

2019-04-24 Thread Unit 193
Howdy,

You can try to use `apt install --no-install-recommends youtube-dl` to
solve the issue of too many packages being pulled in.  As noted in a bug
in Debian[0], mpv/mplayer are recommended as one of them is needed in
order to obtain rtsp streams.

[0]: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=881326

** Bug watch added: Debian Bug tracker #881326
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=881326

** Changed in: youtube-dl (Ubuntu)
   Status: Confirmed => Won't Fix

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1774728

Title:
  Installing youtube-dl on ubuntu minimal brings in far too many
  extraneous dependencies

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/youtube-dl/+bug/1774728/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1776692] Re: Crackle no longer works, URL of service changed

2019-04-24 Thread Unit 193
This issue was reported upstream as https://github.com/ytdl-org/youtube-
dl/issues/16698, fixed in https://github.com/ytdl-org/youtube-
dl/commit/dc53c7863481f927bb011ad28784facec428ce22#diff-
9cf327a5036f565dce2b95a322e05100 commit, which is in release 2018.06.14
onwards.

** Bug watch added: github.com/ytdl-org/youtube-dl/issues #16698
   https://github.com/ytdl-org/youtube-dl/issues/16698

** Changed in: youtube-dl (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1776692

Title:
  Crackle no longer works, URL of service changed

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/youtube-dl/+bug/1776692/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1377794] Re: please improve error handling

2019-04-24 Thread Unit 193
Marking as fixed in Ubuntu too now.

** Changed in: youtube-dl (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1377794

Title:
  please improve error handling

To manage notifications about this bug go to:
https://bugs.launchpad.net/youtube-dl/+bug/1377794/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1728423] Re: Backport debhelper 10.3+ to xenial

2018-10-08 Thread Unit 193
Never noticed there was a reply, nevertheless, artful is dead now so
while that's now a moot point, I can't seem to reproduce that error, at
least when I run that URL as an argument for dget.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1728423

Title:
  Backport debhelper 10.3+ to xenial

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/debhelper/+bug/1728423/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1787021] Re: Directory traversal vulnerability

2018-08-14 Thread Unit 193
** Patch added: "Ugly fix, missing bug reference."
   
https://bugs.launchpad.net/ubuntu/+source/cgit/+bug/1787021/+attachment/5175362/+files/cgit_ubuntu.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1787021

Title:
  Directory traversal vulnerability

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cgit/+bug/1787021/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1787021] [NEW] Directory traversal vulnerability

2018-08-14 Thread Unit 193
*** This bug is a security vulnerability ***

Public security bug reported:

Howdy,

The CVE says: "cgit_clone_objects in CGit before 1.2.1 has a directory
traversal vulnerability when `enable-http-clone=1` is not turned off, as
demonstrated by a cgit/cgit.cgi/git/objects/?path=../ request."

This has been fixed upstream with
https://git.zx2c4.com/cgit/commit/?id=53efaf30b50f095cad8c160488c74bba3e3b2680

This was fixed in Debian unstable:
https://tracker.debian.org/news/979737/accepted-cgit-11git2102-31
-source-into-unstable/

** Affects: cgit (Ubuntu)
 Importance: Undecided
 Status: New

** CVE added: https://cve.mitre.org/cgi-bin/cvename.cgi?name=2018-14912

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1787021

Title:
  Directory traversal vulnerability

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cgit/+bug/1787021/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1787021] Re: Directory traversal vulnerability

2018-08-14 Thread Unit 193
I've attached two versions of this patch, one is based off the Bionic
upload, the other backports the minimal NMU that cosmic has.  I
personally prefer the latter.

** Patch added: "cgit_debian.debdiff"
   
https://bugs.launchpad.net/ubuntu/+source/cgit/+bug/1787021/+attachment/5175363/+files/cgit_debian.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1787021

Title:
  Directory traversal vulnerability

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cgit/+bug/1787021/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1713343] Re: no release file and error 404

2018-07-01 Thread Unit 193
Howdy,

You were getting that error due to a PPA not being published for the
release you were on.  This isn't from Ubuntu or Xubuntu, xfce4-terminal,
or anything we control.  You may wish to contact the ~artfwo user in
regards to whatever PPA issues, if you still have said issues.

** Changed in: xfce4-terminal (Ubuntu)
   Status: New => Incomplete

** Changed in: xfce4-terminal (Ubuntu)
   Status: Incomplete => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1713343

Title:
  no release file and error 404

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xfce4-terminal/+bug/1713343/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 643623] Re: Should ubuntu-keyring include the debug archive key?

2018-06-19 Thread Unit 193
This bug was fixed with the following upload, and the package ubuntu-
dbgsym-keyring can now be installed.

ubuntu-keyring (2018.02.05) bionic; urgency=medium

  * Ship the current ubuntu-cloudimage-keyring in the ubuntu-keyring
package. LP: #1331057
  * Ship ubuntu-cloud-keyring for Cloud Archive signing keys, as a
separate keyring in /etc/apt/trusted.gpg.d/, and remove it from the
trusted.gpg keyring as no longer needed to be there.
  * Ship ubuntu-dgbsym key
  * Specify udeb Package-Type and bump priority to standard.
  * Bump standards version

 -- Dimitri John Ledkov   Wed, 17 Jan 2018 16:01:45
+

** Changed in: ubuntu-keyring (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/643623

Title:
  Should ubuntu-keyring include the debug archive key?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-keyring/+bug/643623/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1470483] Re: Please update the Package

2018-05-12 Thread Unit 193
Indicator support was added in 2016 with the following upload:

pasystray (0.5.2-1ubuntu1) yakkety; urgency=medium

  * d/control: Build-dep on libappindicator3-dev for indicator support.

 -- Unit 193 <unit...@ubuntu.com>  Thu, 02 Jun 2016 21:24:38 -0400

** Changed in: pasystray (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1470483

Title:
  Please update the Package

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pasystray/+bug/1470483/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1757574] [NEW] development libraries missing depends listed in *.pc files

2018-03-21 Thread Unit 193
Public bug reported:

As the title says, the development libraries are missing depends on
other libraries that are listed in the pkg-config files, this will cause
failures if something else doesn't pull them in.  I started hitting it
with after the upload of
https://launchpad.net/ubuntu/+source/libdbusmenu/16.04.1+18.04.20171206-0ubuntu1.

** Affects: libappindicator (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1757574

Title:
  development libraries missing depends listed in *.pc files

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libappindicator/+bug/1757574/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1754188] Re: Please update to the latest release so the LTS doesn't ship with a prerelease

2018-03-21 Thread Unit 193
xca (1.4.1-0ubuntu1) bionic; urgency=medium

  * New upstream release.
  * d/compat, d/control: Bump dh compat to 10.
  * d/control: Drop unnecessary depends.
- autoconf
- automake
- dh-autoreconf
- dpkg-dev (>= 1.16.1~)

 -- Unit 193 <unit...@ubuntu.com>  Wed, 07 Mar 2018 17:45:52 -0500

** Changed in: xca (Ubuntu)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1754188

Title:
  Please update to the latest release so the LTS doesn't ship with a
  prerelease

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xca/+bug/1754188/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1754781] [NEW] Please merge the latest bug release, 1.0.7-1, from Debian

2018-03-09 Thread Unit 193
Public bug reported:

While the version in Bionic contains the CVE fixes, it would be nice to
ship the latest bugfix release in the 1.0.x series.

dget
https://launchpad.net/~unit193/+archive/ubuntu/staging/+files/irssi_1.0.7-1ubuntu1.dsc

Source: irssi
Version: 1.0.7-1ubuntu1
Distribution: devel
Urgency: high
Maintainer: Unit 193 <unit...@ubuntu.com>
Timestamp: 1520636093
Date: Fri, 09 Mar 2018 17:54:53 -0500
Closes: 886475 890674 890675 890676 890677 890678
Changes:
 irssi (1.0.7-1ubuntu1) devel; urgency=medium
 .
   * Merge from Debian. Remaining changes:
 - Refresh and re-enabled 20fix_ssl_proxy_hostname_check.
   - When we have a proxy setting, we expect the CN to match
 the proxy hostname, not the server hostname.
 - d/p/90irc-ubuntu-com: 
   + Add the Ubuntu network with irc.ubuntu.com as the server,
 which is currently a CNAME for chat.freenode.net.
 - d/p/03firsttimer_text:
   + Adapt 03firsttimer_text so it tells you about
 connecting to Ubuntu and joining #ubuntu.
   * Changes no longer needed:
 - d/p/CVE-2018-.patch: Applied upstream.
 .
 irssi (1.0.7-1) unstable; urgency=high
 .
   * New upstream bugfix release (closes: #886475):
 From 1.0.6:
 - Fix invalid memory access when reading hilight configuration
   (#787, #788).
 - Fix null pointer dereference when the channel topic is set
   without specifying a sender [CVE-2018-5206]
 - Fix return of random memory when using incomplete escape
   codes [CVE-2018-5205]
 - Fix heap buffer overflow when completing certain strings
   [CVE-2018-5208]
 - Fix return of random memory when using an incomplete
   variable argument [CVE-2018-5207]
 .
 From 1.0.7:
 - Prevent use after free error during the execution of some
   commands. Found by Joseph Bisch [CVE-2018-7054] (closes: #890674)
 - Revert netsplit print optimisation due to crashes
 - Fix use after free when SASL messages are received in
   unexpected order [CVE-2018-7053] (closes: #890675)
 - Fix null pointer dereference in the tab completion when an
   empty nick is joined [CVE-2018-7050] (closes: #890678)
 - Fix use after free when entering oper password
 - Fix null pointer dereference when too many windows are
   opened [CVE-2018-7052] (closes: #890676)
 - Fix out of bounds access in theme strings when the last
   escape is incomplete. Credit to Oss-Fuzz [CVE-2018-7051]
   (closes: #890677)
 - Fix out of bounds write when using negative counts on window
   resize
 - Minor help correction. By William Jackson
 .
   * Fix watch URL.
   * Bump to debhelper compat 11, remove autotools-dev Build-Depends.
   * Bump Standards-Version to 4.1.3.
   * Add lintian overrides for the spelling of "hilight" in the changelog
 mentioning the lintian overrides for the spelling of "hilight" in irssi
 itself.

** Affects: irssi (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1754781

Title:
  Please merge the latest bug release, 1.0.7-1, from Debian

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/irssi/+bug/1754781/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1754188] [NEW] Please update to the latest release so the LTS doesn't ship with a prerelease

2018-03-07 Thread Unit 193
Public bug reported:

A pre-release was used in order to gain OpenSSL 1.1 support, since then
a stable release has been issued and now a point release.  It would be
far better to ship a stable release with the LTS.

Testbuild:
https://launchpad.net/~unit193/+archive/ubuntu/staging/+sourcepub/8840664
/+listing-archive-extra

Source: xca
Version: 1.4.1-0ubuntu1
Distribution: devel
Urgency: medium
Maintainer: Unit 193 <unit...@ubuntu.com>
Timestamp: 1520462752
Date: Wed, 07 Mar 2018 17:45:52 -0500
Changes:
 xca (1.4.1-0ubuntu1) devel; urgency=medium
 .
   * New upstream release.
   * d/compat, d/control: Bump dh compat to 10.
   * d/control: Drop unnecessary depends.
 - autoconf
 - automake
 - dh-autoreconf
 - dpkg-dev (>= 1.16.1~)

** Affects: xca (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1754188

Title:
  Please update to the latest release so the LTS doesn't ship with a
  prerelease

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xca/+bug/1754188/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1737750] Re: nvidia-graphics-drivers-304 304.137-0ubuntu2 ADT test failure with linux 4.15.0-1.2

2018-02-22 Thread Unit 193
I can confirm Seth's findings, as well as the fact it functions.

nvidia-304, 304.137, 4.15.0-10-generic, x86_64: installed

[40.440] (II) NVIDIA dlloader X Driver  304.137  Thu Sep 14 13:52:41 PDT 
2017
[40.440] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[40.440] (II) NOUVEAU driver Date:   Fri Apr 21 14:41:17 2017 -0400

00:0d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 6150SE 
nForce 430] (rev a2) (prog-if 00 [VGA controller])
Kernel driver in use: nvidia

Thanks for the patch!

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1737750

Title:
  nvidia-graphics-drivers-304 304.137-0ubuntu2 ADT test failure with
  linux 4.15.0-1.2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304/+bug/1737750/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1728423] Re: Backport debhelper 10.3+ to xenial

2018-01-05 Thread Unit 193
As per discussion with Laney, merges:

Artful: https://sigma.unit193.net/source/debhelper_11ubuntu0.1~ubuntu17.10.dsc
Xenial: https://sigma.unit193.net/source/debhelper_11ubuntu0.1~ubuntu16.04.dsc

This was a merge from stable-backports as that contains the reverted
changes for R³.  The version '11ubuntu0' such that it fulfills the
requirement of 'debhelper (>= 11)'

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1728423

Title:
  Backport debhelper 10.3+ to xenial

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/debhelper/+bug/1728423/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1735346] Re: bittornado: Python3 port needed, or demotion to universe

2017-12-11 Thread Unit 193
Best guess as to why it's in main would be that Ubuntu uses it as the
torrent tracker (http://torrent.ubuntu.com:6969/)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1735346

Title:
  bittornado: Python3 port needed, or demotion to universe

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bittornado/+bug/1735346/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1719322] Re: Remove patch to remove headerbar

2017-11-03 Thread Unit 193
By "Xfce doesn't include..." I'll presume you mean Xubuntu, which in
fact does include file-roller.  I'd be very disappointed if the
headerbars came back or were restricted to Unity.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1719322

Title:
  Remove patch to remove headerbar

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/eog/+bug/1719322/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1727428] Re: variety crashed with SIGSEGV in __strlen_avx2()

2017-10-26 Thread Unit 193
** Information type changed from Private to Public

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1727428

Title:
  variety crashed with SIGSEGV in __strlen_avx2()

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/variety/+bug/1727428/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1727089] Re: variety crashed with SIGABRT in g_assertion_message()

2017-10-26 Thread Unit 193
Excerpt from journal:

out 24 20:39:09 hostname variety.desktop[2034]: WARNING: 2017-10-24 
20:39:09,074: create_menu() 'Variety Slideshow is not installed. This is an 
optional extension adding pan-and-zoom slideshows to Variety: see 
https://github.com/peterlevi/variety-slideshow for details'
out 24 20:39:13 hostname variety.desktop[2034]: 
/usr/lib/python2.7/dist-packages/urllib3/connectionpool.py:854: 
InsecureRequestWarning: Unverified HTTPS request is being made. Adding 
certificate verification is strongly advised. See: 
https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
out 24 20:39:13 hostname variety.desktop[2034]:   InsecureRequestWarning)
out 24 20:39:20 hostname gnome-keyring-daemon[1497]: asked to register item 
/org/freedesktop/secrets/collection/login/3, but it's already registered
out 24 20:39:23 hostname gnome-keyring-daemon[1497]: asked to register item 
/org/freedesktop/secrets/collection/login/3, but it's already registered
out 24 20:39:27 hostname variety.desktop[2034]: 
/usr/lib/python2.7/dist-packages/urllib3/connectionpool.py:854: 
InsecureRequestWarning: Unverified HTTPS request is being made. Adding 
certificate verification is strongly advised. See: 
https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
out 24 20:39:27 hostname variety.desktop[2034]:   InsecureRequestWarning)
out 24 20:39:28 hostname variety.desktop[2034]: ERROR: 2017-10-24 20:39:27,977: 
reporting_thread_method() 'Stats: Could not report config'
out 24 20:39:28 hostname variety.desktop[2034]: Traceback (most recent call 
last):
out 24 20:39:28 hostname variety.desktop[2034]:   File 
"/usr/lib/python2.7/dist-packages/variety/VarietyWindow.py", line 999, in 
reporting_thread_method
out 24 20:39:28 hostname variety.desktop[2034]: 
self.smart.stats_report_config()
out 24 20:39:28 hostname variety.desktop[2034]:   File 
"/usr/lib/python2.7/dist-packages/variety/Smart.py", line 851, in 
stats_report_config
out 24 20:39:28 hostname variety.desktop[2034]: res = 
Util.fetch_json(Smart.API_URL + '/stats/%s/report-config' % statsid, data=data)
out 24 20:39:28 hostname variety.desktop[2034]:   File 
"/usr/lib/python2.7/dist-packages/variety/Util.py", line 534, in fetch_json
out 24 20:39:28 hostname variety.desktop[2034]: return Util.request(url, 
data).json()
out 24 20:39:28 hostname variety.desktop[2034]:   File 
"/usr/lib/python2.7/dist-packages/variety/Util.py", line 507, in request
out 24 20:39:28 hostname variety.desktop[2034]: r.raise_for_status()
out 24 20:39:28 hostname variety.desktop[2034]:   File 
"/usr/lib/python2.7/dist-packages/requests/models.py", line 937, in 
raise_for_status
out 24 20:39:28 hostname variety.desktop[2034]: raise 
HTTPError(http_error_msg, response=self)
out 24 20:39:28 hostname variety.desktop[2034]: HTTPError: 500 Server Error: 
Internal Server Error for url: 
https://vrty.org/api/stats/qh4dfyxgfh/report-config
out 24 20:39:29 hostname variety.desktop[2034]: 
/usr/lib/python2.7/dist-packages/urllib3/connectionpool.py:854: 
InsecureRequestWarning: Unverified HTTPS request is being made. Adding 
certificate verification is strongly advised. See: 
https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
out 24 20:39:29 hostname variety.desktop[2034]:   InsecureRequestWarning)
out 24 20:39:30 hostname variety.desktop[2034]: 
/usr/lib/python2.7/dist-packages/urllib3/connectionpool.py:854: 
InsecureRequestWarning: Unverified HTTPS request is being made. Adding 
certificate verification is strongly advised. See: 
https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
out 24 20:39:30 hostname variety.desktop[2034]:   InsecureRequestWarning)
out 24 20:39:59 hostname variety.desktop[2034]: 
/usr/lib/python2.7/dist-packages/urllib3/connectionpool.py:854: 
InsecureRequestWarning: Unverified HTTPS request is being made. Adding 
certificate verification is strongly advised. See: 
https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
out 24 20:39:59 hostname variety.desktop[2034]:   InsecureRequestWarning)
out 24 20:39:59 hostname variety.desktop[2034]: ERROR: 2017-10-24 20:39:59,276: 
reporting_thread_method() 'Stats: Could not report config'
out 24 20:39:59 hostname variety.desktop[2034]: Traceback (most recent call 
last):
out 24 20:39:59 hostname variety.desktop[2034]:   File 
"/usr/lib/python2.7/dist-packages/variety/VarietyWindow.py", line 999, in 
reporting_thread_method
out 24 20:39:59 hostname variety.desktop[2034]: 
self.smart.stats_report_config()
out 24 20:39:59 hostname variety.desktop[2034]:   File 
"/usr/lib/python2.7/dist-packages/variety/Smart.py", line 851, in 
stats_report_config
out 24 20:39:59 hostname variety.desktop[2034]: res = 
Util.fetch_json(Smart.API_URL + '/stats/%s/report-config' % statsid, data=data)
out 24 20:39:59 hostname variety.desktop[2034]:   File 
"/usr/lib/python2.7/dist-packages/variety/Util.py", line 534, in fetch_json
out 24 20:39:59 

[Bug 1715518] Re: Sync pianobar 2017.08.30-1 (universe) from Debian unstable (main)

2017-09-06 Thread Unit 193
** Summary changed:

- Sync pianobar 2017.08.30-1 (universe) from Debian unstable (main)  This 
package is very low risk, a splinter package, and the new upstream version 
fixes ffmpeg/libav/json-c deprecations.
+ Sync pianobar 2017.08.30-1 (universe) from Debian unstable (main)

** Description changed:

  Please sync pianobar 2017.08.30-1 (universe) from Debian unstable (main)
+ 
+ This package is very low risk, a splinter package, and the new upstream
+ version fixes ffmpeg/libav/json-c deprecations.
  
  Changelog entries since current artful version 2016.06.02-1:
  
  pianobar (2017.08.30-1) UNRELEASED; urgency=medium
  
-   * New upstream release.
-   * Update Standards-Version to 4.1.0.
-   * d/control, d/rules: Drop pianobar-dbg and migrate to auto dbgsym packages.
-   * d/control, d/copyright, d/watch: Use https where possible.
-   * d/copyright: Update years, add myself.
-   * d/rules:
- - Enable all hardening, sans pie.
- - Enable verbose build.
+   * New upstream release.
+   * Update Standards-Version to 4.1.0.
+   * d/control, d/rules: Drop pianobar-dbg and migrate to auto dbgsym packages.
+   * d/control, d/copyright, d/watch: Use https where possible.
+   * d/copyright: Update years, add myself.
+   * d/rules:
+ - Enable all hardening, sans pie.
+ - Enable verbose build.
  
-  -- Unit 193 <unit...@ubuntu.com>  Wed, 30 Aug 2017 11:54:29 -0400
+  -- Unit 193 <unit...@ubuntu.com>  Wed, 30 Aug 2017 11:54:29 -0400

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1715518

Title:
  Sync pianobar 2017.08.30-1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pianobar/+bug/1715518/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1715518] [NEW] Sync pianobar 2017.08.30-1 (universe) from Debian unstable (main) This package is very low risk, a splinter package, and the new upstream version fixes ffmpeg/libav/json-c deprecat

2017-09-06 Thread Unit 193
Public bug reported:

Please sync pianobar 2017.08.30-1 (universe) from Debian unstable (main)

Changelog entries since current artful version 2016.06.02-1:

pianobar (2017.08.30-1) UNRELEASED; urgency=medium

  * New upstream release.
  * Update Standards-Version to 4.1.0.
  * d/control, d/rules: Drop pianobar-dbg and migrate to auto dbgsym packages.
  * d/control, d/copyright, d/watch: Use https where possible.
  * d/copyright: Update years, add myself.
  * d/rules:
- Enable all hardening, sans pie.
- Enable verbose build.

 -- Unit 193 <unit...@ubuntu.com>  Wed, 30 Aug 2017 11:54:29 -0400

** Affects: pianobar (Ubuntu)
 Importance: Wishlist
 Status: New

** Changed in: pianobar (Ubuntu)
   Importance: Undecided => Wishlist

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1715518

Title:
  Sync pianobar 2017.08.30-1 (universe) from Debian unstable (main)
  This package is very low risk, a splinter package, and the new
  upstream version fixes ffmpeg/libav/json-c deprecations.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pianobar/+bug/1715518/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1711758] Re: artful: nvidia-304 unknown symbol init_mm

2017-08-29 Thread Unit 193
I ran into this issue as well, turned up this bug report and an
nvidia[0] report.  After patching and hitting up dkms, the driver was
working with 4.12 kernels.

[0]: https://devtalk.nvidia.com/default/topic/1022833/linux/304-135
-driver-fails-to-insert-on-fedora-26-4-12-5-kernel-with-quot-unknown-
symbol-init_mm-quot-/

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1711758

Title:
  artful: nvidia-304 unknown symbol init_mm

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304/+bug/1711758/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1711748] [NEW] Sync chef 12.14.60-3 (universe) from Debian unstable (main)

2017-08-18 Thread Unit 193
Public bug reported:

Please sync chef 12.14.60-3 (universe) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:

Stefano Rivera pushed his changes in Ubuntu to Debian, and of course I
fixed the net-ssh incompatibility.  There is no Delta.


Changelog entries since current artful version 12.14.60-2ubuntu5:

chef (12.14.60-3) unstable; urgency=medium

  * Team upload.

  [ Stefano Rivera ]
  * Build-Depend on ruby-fuzzyurl, rather than relying on it's indirect
presence via ohai -> ruby-chef-config.
  * Blacklist mount_spec and ifconfig_spec, as they require real root.
  * Be more verbose on failure, and tighten the pgrep to avoid catching
"systemd-cgroups-agent chef-client.service" after stopping.
(Patch from Ubuntu, Closes: #798618)
  * Unset http[s]_proxy in the subversion spec, so it doesn't alter generated
subversion commands.

  [ Unit 193 ]
  * Bump Standards-Version to 4.0.1.
  * d/p/0004-Use-newer-net-ssh.patch:
- Relax dependency on ruby-net-ssh (Closes: #869179)

 -- Unit 193 <unit...@ubuntu.com>  Mon, 07 Aug 2017 05:01:33 -0400

** Affects: chef (Ubuntu)
 Importance: Wishlist
 Status: New

** Changed in: chef (Ubuntu)
   Importance: Undecided => Wishlist

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1711748

Title:
  Sync chef 12.14.60-3 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/chef/+bug/1711748/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1598503] Re: [needs-packaging] xfdashboard

2017-08-12 Thread Unit 193
** Changed in: ubuntu
   Status: In Progress => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1598503

Title:
  [needs-packaging] xfdashboard

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+bug/1598503/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 521342] Re: ices2 in playlist-mode leaves empty stream on clients when song ends

2017-07-27 Thread Unit 193
Sorry to be necro posting here, but does this still occur on current
versions of ices2?  Specifically 2.0.2?

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/521342

Title:
  ices2 in playlist-mode leaves empty stream on clients when song ends

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ices2/+bug/521342/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 651610] Re: [CVE-2017-11421] Version number for .msi thumbnail is obtained from unreliable source

2017-07-27 Thread Unit 193
On Zesty, I tried to reproduce the CVE before the patch and was able to,
after patching the package, rebuilding, and restarting the thumbnailer
service I no longer could reproduce the issue.

** Changed in: gnome-exe-thumbnailer (Ubuntu Zesty)
 Assignee: James Lu (tacocat) => (unassigned)

** Changed in: gnome-exe-thumbnailer (Ubuntu Xenial)
 Assignee: James Lu (tacocat) => (unassigned)

** Changed in: gnome-exe-thumbnailer (Ubuntu Xenial)
   Status: In Progress => Confirmed

** Changed in: gnome-exe-thumbnailer (Ubuntu Zesty)
   Status: In Progress => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/651610

Title:
  [CVE-2017-11421] Version number for .msi thumbnail is obtained from
  unreliable source

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-exe-thumbnailer/+bug/651610/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1703519] [NEW] Sync ruby-simplecov 0.14.1-1 (universe) from Debian unstable (main)

2017-07-11 Thread Unit 193
Public bug reported:

Please sync ruby-simplecov 0.14.1-1 (universe) from Debian unstable
(main)


Ubuntu's delta is a backport from upstream, a new upstream version of course 
includes this.


Changelog entries since current artful version 0.11.1-1ubuntu1:

ruby-simplecov (0.14.1-1) unstable; urgency=medium

  * Team upload.

  [ Cédric Boutillier ]
  * Use https:// in Vcs-* fields
  * Use https:// in Vcs-* fields
  * Bump Standards-Version to 3.9.7 (no changes needed)

  [ Lucas Nussbaum ]
  * New upstream version 0.14.1.

  [ Unit 193 ]
  * Bump Standards-Version to 4.0.0.
  * Refresh patch.

  [ Lucas Nussbaum ]
  * Refresh packaging using dh-make-ruby.

 -- Lucas Nussbaum <lu...@debian.org>  Sun, 09 Jul 2017 07:44:18 +0200

** Affects: ruby-simplecov (Ubuntu)
 Importance: Wishlist
 Status: New

** Changed in: ruby-simplecov (Ubuntu)
   Importance: Undecided => Wishlist

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1703519

Title:
  Sync ruby-simplecov 0.14.1-1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ruby-simplecov/+bug/1703519/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 538589] Re: ezstream man page in incomplete and incorrect.

2017-07-10 Thread Unit 193
This was NMU'd in Debian.

 ezstream (0.5.6~dfsg-1.1) unstable; urgency=medium
 
   * Non-maintainer upload.
   * Bug fix: "ezstream manpage is incomplete and incorrect", thanks to
 Philip Muskovac (Closes: #573928).

This version is in Ubuntu, starting with Yakkety.

** Changed in: ezstream (Ubuntu)
   Status: Triaged => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/538589

Title:
  ezstream man page in incomplete and incorrect.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ezstream/+bug/538589/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1566999] Re: Causes Dropbox to crash when context menu item selected

2017-07-08 Thread Unit 193
Can either of you get some logs, terminal output, or anything from the
crashes?  I haven't seen any myself, so can't really tell what's going
on without some hints.

As a side note, newer versions of nautilus-dropbox should fix the
indicator, and if you're still having issues you can change a line in
/usr/bin/dropbox to include 'XFCE' in the array 'to_check'.  Granted,
this is a slight hack...  The trayicon gives me more info, so I force
that myself.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1566999

Title:
  Causes Dropbox to crash when context menu item selected

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/thunar-dropbox-plugin/+bug/1566999/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1359547] Re: Setting an initial title (-T or --title) breaks dynamic titles

2017-07-07 Thread Unit 193
** Changed in: xfce4-terminal (Ubuntu)
   Status: New => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1359547

Title:
  Setting an initial title (-T or --title) breaks dynamic titles

To manage notifications about this bug go to:
https://bugs.launchpad.net/xfce4-terminal/+bug/1359547/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1458674] Re: hide scroll bar and menu bar in xfce drop-down terminal

2017-07-07 Thread Unit 193
Since 0.8.x has this feature, and we're currently shipping that series.
This has now been fixed.

** Changed in: xfce4-terminal (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1458674

Title:
  hide scroll bar and menu bar in xfce drop-down terminal

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xfce4-terminal/+bug/1458674/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1380194] Re: Terminal emulator opens menu by F10 key and/or opens help by F1 key.

2017-07-07 Thread Unit 193
See also bug #1620223, this has been fixed in xfce4-terminal 0.8.x
series, which Xubuntu has.

** Changed in: xfce4-terminal (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1380194

Title:
  Terminal emulator opens menu by  F10 key and/or opens help by F1 key.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/1380194/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1620223] Re: blocks F1 key from mc and other apps

2017-07-07 Thread Unit 193
As per upstream (Igor Zakharov), this is now fixed.

Have a nice day!

** Changed in: xfce4-terminal (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1620223

Title:
  blocks F1 key from mc and other apps

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xfce4-terminal/+bug/1620223/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1471469] Re: Text does not wrap after window resize - xfce4-terminal

2017-07-07 Thread Unit 193
Thanks for noting, as such closing with 'Fix Released'

** Changed in: xfce4-terminal (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1471469

Title:
  Text does not wrap after window resize - xfce4-terminal

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xfce4-terminal/+bug/1471469/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1276432] Re: Cursor shape and cursor blink configuation

2017-07-07 Thread Unit 193
According to the upstream bug report, and upstream maintainer (commenter
above), this is now fixed.  Closing.

** Changed in: xfce4-terminal (Ubuntu)
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1276432

Title:
  Cursor shape and cursor blink configuation

To manage notifications about this bug go to:
https://bugs.launchpad.net/xfce4-terminal/+bug/1276432/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1626477] Re: Error on execute printing Brother DCPJ4120DW

2017-07-07 Thread Unit 193
** Changed in: xfce4-terminal (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1626477

Title:
   Error on execute printing Brother DCPJ4120DW

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xfce4-terminal/+bug/1626477/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1023826] Re: xfce4-terminal freezes on mouse input

2017-07-07 Thread Unit 193
According to https://bugzilla.xfce.org/show_bug.cgi?id=7587, this issue
has been fixed.  Closing.

** Changed in: xfce4-terminal (Ubuntu)
   Status: Incomplete => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1023826

Title:
  xfce4-terminal freezes on mouse input

To manage notifications about this bug go to:
https://bugs.launchpad.net/xfce4-terminal/+bug/1023826/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1677961] Re: xfce4-terminal crashes if input arrives too soon after resize

2017-07-07 Thread Unit 193
As this appears to be fixed for you now, closing as fixed released.

** Changed in: xfce4-terminal (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1677961

Title:
  xfce4-terminal crashes if input arrives too soon after resize

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xfce4-terminal/+bug/1677961/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1014291] Re: Export from bzr / Import to git results in a deleted file re-appearing

2017-06-19 Thread Unit 193
In attempt to at least get the fix in the distribution if not upstream,
debdiff attached.

** Also affects: bzr-fastimport (Ubuntu)
   Importance: Undecided
   Status: New

** Patch added: "bzr-fastimport.debdiff"
   
https://bugs.launchpad.net/ubuntu/+source/bzr-fastimport/+bug/1014291/+attachment/4898811/+files/bzr-fastimport.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1014291

Title:
  Export from bzr / Import to git results in a deleted file re-appearing

To manage notifications about this bug go to:
https://bugs.launchpad.net/bzr-fastimport/+bug/1014291/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1698566] [NEW] Sync gocryptfs 1.3-1 (universe) from Debian unstable (main)

2017-06-17 Thread Unit 193
Public bug reported:

Please sync gocryptfs 1.3-1 (universe) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
  * Dont run flaky tests on ppc64el for now.

This version is built against a newer version of golang-github-hanwen-
go-fuse-dev[0], thus the build is fixed[1][2] and tests will pass on
those arches.

[0]: 
https://packages.qa.debian.org/g/golang-github-hanwen-go-fuse/news/20170614T193342Z.html
[1]: 
https://buildd.debian.org/status/fetch.php?pkg=gocryptfs=ppc64el=1.3-1=1497657286=0
[2]: https://launchpad.net/~unit193/+archive/ubuntu/staging/+build/12760011

Changelog entries since current artful version 1.2.1-1ubuntu1:

gocryptfs (1.3-1) unstable; urgency=medium

  * New upstream version.
  * Compile against latest go-fuse for cross platform (Closes: 849662).

 -- David Steele   Fri, 16 Jun 2017 17:09:26 -0400

** Affects: gocryptfs (Ubuntu)
 Importance: Wishlist
 Status: New

** Changed in: gocryptfs (Ubuntu)
   Importance: Undecided => Wishlist

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1698566

Title:
  Sync gocryptfs 1.3-1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gocryptfs/+bug/1698566/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1696908] [NEW] Sync goaccess 1:1.2-1 (universe) from Debian experimental (main)

2017-06-08 Thread Unit 193
Public bug reported:

Please sync goaccess 1:1.2-1 (universe) from Debian experimental (main)

Changelog entries since current artful version 1:0.9.4-1build1:

goaccess (1:1.2-1) experimental; urgency=medium

  [ Martin Bagge / brother ]
  * Fix debian/watch (Closes: #848954)

  [ Antonio Terceiro ]
  * New upstream version 1.2 (Closes: #858292)
- pre-minified Javascript and CSS files removed; we use the existing
  source packages in Debian
  * wrap-and-sort
  * debian/rules:
- enable Tokyocabinet support (Closes: #857804)
- use dh-autoreconf
- really enable geoip support
  * debian/copyright: convert to machine-readable format
- note that upstream is now licensed under MIT/Expat license.
- use Files-Excluded to make uscan remove pre-minified JS/CSS from
  upstream tarball
  * debian/patches/0001-Makefile.am-don-t-install-resources.patch: don't
install extra files to /usr/share/doc/
  * debian/patches/0002-Fix-db-path-without-trailing-slash.patch: ditto
  * Add myself to Uploaders:
  * Add Vcs-* fields pointing to collab-maint/goaccess
  * Add missing build dependency on libncurses5-dev
  * Add missing build dependency on libbz2-dev

 -- Antonio Terceiro   Thu, 08 Jun 2017 20:46:39
-0300

** Affects: goaccess (Ubuntu)
 Importance: Wishlist
 Status: New

** Changed in: goaccess (Ubuntu)
   Importance: Undecided => Wishlist

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1696908

Title:
  Sync goaccess 1:1.2-1 (universe) from Debian experimental (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/goaccess/+bug/1696908/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1695555] [NEW] Sync gocryptfs 1.2.1-1 (universe) from Debian unstable (main)

2017-06-02 Thread Unit 193
Public bug reported:

Please sync gocryptfs 1.2.1-1 (universe) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
  * d/p/Fix-a-missing-import-in-a-test: Disable, causes FTBFS.

This is no longer needed as it has been upstreamed to Debian.


Changelog entries since current artful version 1.2-2ubuntu1:

gocryptfs (1.2.1-1) unstable; urgency=medium

  * New upstream version.
  * Fixed FTBFS error.
  * Enable all tests during build.
  * No longer installs source code.
  * Implement debci CI testing.

 -- David Steele   Fri, 02 Jun 2017 13:33:43 -0400

** Affects: gocryptfs (Ubuntu)
 Importance: Wishlist
 Status: New

** Changed in: gocryptfs (Ubuntu)
   Importance: Undecided => Wishlist

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/169

Title:
  Sync gocryptfs 1.2.1-1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gocryptfs/+bug/169/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1694864] [NEW] Sync variety 0.6.4-1 (universe) from Debian experimental (main)

2017-05-31 Thread Unit 193
Public bug reported:

Please sync variety 0.6.4-1 (universe) from Debian experimental (main)

Changelog entries since current artful version 0.6.3-5:

variety (0.6.4-1) experimental; urgency=low

  * New upstream release.
- Port from pyexif2 to GExiv2 (LP: #1280349)
  * debian/ folder changes:
- Refresh dependencies: add python-pil, gir1.2-gexiv2-0.10; remove
  python-imaging, python-pyexiv2
- Drop desktop-file-keywords.diff, menu-position-varargs.patch, and
  remove-timebombs.patch: they were either merged upstream or superseded.
- Add python-gi, python-requests, and dh-python to build dependencies to
  fix distutils and debhelper build warnings.
- Wrap-and-sort dependencies.

 -- James Lu   Thu, 18 May 2017 18:40:52 -0700

** Affects: variety (Ubuntu)
 Importance: Wishlist
 Status: New

** Changed in: variety (Ubuntu)
   Importance: Undecided => Wishlist

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1694864

Title:
  Sync variety 0.6.4-1 (universe) from Debian experimental (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/variety/+bug/1694864/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1688056] Re: Package outdated

2017-05-19 Thread Unit 193
** Changed in: xfce4-weather-plugin (Ubuntu Xenial)
   Status: New => Confirmed

** Changed in: xfce4-weather-plugin (Ubuntu)
   Status: Confirmed => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1688056

Title:
  Package outdated

To manage notifications about this bug go to:
https://bugs.launchpad.net/xfce4-weather-plugin/+bug/1688056/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1688056] Re: Package outdated

2017-05-19 Thread Unit 193
** Also affects: xfce4-weather-plugin (Ubuntu Xenial)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1688056

Title:
  Package outdated

To manage notifications about this bug go to:
https://bugs.launchpad.net/xfce4-weather-plugin/+bug/1688056/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1692074] [NEW] Sync parsedatetime 2.3-1 (main) from Debian experimental (main)

2017-05-19 Thread Unit 193
Public bug reported:

Please sync parsedatetime 2.3-1 (main) from Debian experimental (main)

Changelog entries since current artful version 2.1-3:

parsedatetime (2.3-1) experimental; urgency=medium

  * Team upload

  [ Harlan Lieberman-Berg ]
  * New upstream version 2.3 (Closes: #717991)

  [ Ghislain Antony Vaillant ]
  * Switch from git-dpm to gbp
  * Drop the patch queue, applied upstream
  * cme fix dpkg-control
- Drop versioned b-dep on python-all
- Bump Standards-Version to 3.9.8, no changes required
- Drop versioned i-dep on base-files
- Overall reordering of fields, wrap and sort
  * Replace b-dep on nose by pytest and pytest-runner
  * Ensure only test targets require pytest-runner
- New patch Conditional-requirement-on-pytest-runner.patch
  * Add the necessary test args for pybuild
  * Support the non-standard pytest config used upstream
- New patch Add-upstream-pytest-configuration.patch
  * Build binary packages for Python 3.
Thanks to Paul Tagliamonte for reporting (Closes: #782926)
  * Add autopkgtests running the upstream test suite

 -- Ghislain Antony Vaillant   Sat, 11 Mar 2017
11:18:06 +

** Affects: parsedatetime (Ubuntu)
 Importance: Wishlist
 Status: New

** Changed in: parsedatetime (Ubuntu)
   Importance: Undecided => Wishlist

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1692074

Title:
  Sync parsedatetime 2.3-1 (main) from Debian experimental (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/parsedatetime/+bug/1692074/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1685561] Re: Please merge irssi-1.0.2-1 (main) from Debian unstable (main)

2017-05-05 Thread Unit 193
irssi (1.0.2-1ubuntu2) artful; urgency=medium

  * debian/patches/90-irc-ubuntu-com: update to use the right use_tls
option, and add tls_verify. Thanks to Unit193 for noticing!

 -- Marc Deslauriers   Fri, 05 May 2017
07:32:23 -0400

irssi (1.0.2-1ubuntu1) artful; urgency=medium

  * Merge from Debian. Remaining changes:
- Re-enabled 20fix_ssl_proxy_hostname_check.
  - When we have a proxy setting, we expect the CN to match
the proxy hostname, not the server hostname.
- d/p/90irc-ubuntu-com:
  + Add the Ubuntu network with irc.ubuntu.com as the server,
which is currently a CNAME for chat.freenode.net.
- d/p/03firsttimer_text:
  + Adapt 03debian_firsttimer_text so it tells you about
connecting to Ubuntu and joining #ubuntu.

 -- Marc Deslauriers   Thu, 04 May 2017
07:59:52 -0400

** Changed in: irssi (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1685561

Title:
  Please merge irssi-1.0.2-1 (main) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/irssi/+bug/1685561/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1680943] Re: telegram-desktop's window never shows up (differently from Debian's sid)

2017-05-03 Thread Unit 193
Since Rogério hasn't responded, I tested that about a week ago on
Xubuntu (we ship /etc/X11/Xsession.d/56xubuntu-session which sets the
same value) and system installed telegram launched as expected.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1680943

Title:
  telegram-desktop's window never shows up (differently from Debian's
  sid)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/telegram-desktop/+bug/1680943/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1687816] Re: package inxi 2.3.8-0ubuntu1 failed to install/upgrade: problemas de dependência - deixando desconfigurado

2017-05-02 Thread Unit 193
Google translate tells me that:
dpkg: erro ao processar o pacote gawk (--configure):
 O pacote está num mau estado de inconsistência; deve
 reinstala-lo antes de tentar configura-lo.

Translates to:
dpkg: error processing package gawk (--configure):
  The package is in a bad state of inconsistency; Should
  Reinstall it before attempting to configure it.

Which means there is no bug in inxi, the issue lies within one of its
deps (gawk) which failed to configure, thus inxi failed.

** Changed in: inxi (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1687816

Title:
  package inxi 2.3.8-0ubuntu1 failed to install/upgrade: problemas de
  dependência - deixando desconfigurado

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/inxi/+bug/1687816/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1685561] Re: Please merge irssi-1.0.2-1 (main) from Debian unstable (main)

2017-04-28 Thread Unit 193
Perhaps I could entice you more with a free dsc:
https://sigma.unit193.net/source/irssi_1.0.2-1ubuntu1.dsc

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1685561

Title:
  Please merge irssi-1.0.2-1 (main) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/irssi/+bug/1685561/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1581902] Re: Network manager applet malfunctioning

2017-04-28 Thread Unit 193
** Package changed: xfdesktop4 (Ubuntu) => network-manager-applet
(Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1581902

Title:
  Network manager applet malfunctioning

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1581902/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1563484] Re: Unable to click 'connect' to connect to hidden network

2017-04-28 Thread Unit 193
** Package changed: xfdesktop4 (Ubuntu) => network-manager-applet
(Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1563484

Title:
  Unable to click 'connect' to connect to hidden network

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1563484/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1685560] Re: Please merge irssi-1.0.2-1 (main) from Debian unstable (main)

2017-04-22 Thread Unit 193
*** This bug is a duplicate of bug 1685561 ***
https://bugs.launchpad.net/bugs/1685561

** This bug has been marked a duplicate of bug 1685561
   Please merge irssi-1.0.2-1 (main) from Debian unstable (main)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1685560

Title:
  Please merge irssi-1.0.2-1 (main) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/irssi/+bug/1685560/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1685561] Re: Please merge irssi-1.0.2-1 (main) from Debian unstable (main)

2017-04-22 Thread Unit 193
** Patch added: "Diff from Debian"
   
https://bugs.launchpad.net/ubuntu/+source/irssi/+bug/1685561/+attachment/4866627/+files/irssi_debian.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1685561

Title:
  Please merge irssi-1.0.2-1 (main) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/irssi/+bug/1685561/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1685561] [NEW] Please merge irssi-1.0.2-1 (main) from Debian unstable (main)

2017-04-22 Thread Unit 193
Public bug reported:

Changes since last merge:

irssi (1.0.2-1) unstable; urgency=high

  * New upstream pure bugfix release:
- Prevent some null-pointer crashes.
- Fix compilation with OpenSSL 1.1.0.
- Correct dereferencing of already freed server objects during
  output of netjoins. Found by APic. (closes: #857502)
- Fix in command arg parser to detect missing arguments in tail place.
- Fix regression that broke incoming DCC file transfers.
- Fix issue with escaping \ in evaluated strings.

 -- Rhonda D'Vine   Sat, 11 Mar 2017 10:52:54 +0100

irssi (1.0.1-1) unstable; urgency=high

  * New upstream pure bugfix release:
- Fix Perl compilation in object dir.
- Disable EC cryptography on Solaris to fix build.
- Fix incorrect HELP SERVER example.
- Correct memory leak in /OP and /VOICE.
- Fix regression that broke second level completion.
- Correct missing NULL termination in perl_parse.
- Sync broken mail.pl script.

 -- Rhonda D'Vine   Mon, 06 Feb 2017 08:07:55 +0100

irssi (1.0.0-1) unstable; urgency=medium

  * New upstream release.
  * Add patch 25tls-ssl-compat-defines provided by upstream's dx for backward
compatibility to not require modules using these functions to change code.
  * Update patch 22fix-perl-hardening.

 -- Rhonda D'Vine   Sun, 08 Jan 2017 01:08:23 +0100

irssi (0.8.21-1) unstable; urgency=medium

  * New upstream security release (Closes: #850403):
- CVE-2017-5193: NULL pointer dereference in the nickcmp function
- CVE-2017-5194: Use-after-freee when receiving invalid nick message
- CVE-2017-5195: Out-of-bounds read in certain incomplete control codes
- CVE-2017-5196: Out-of-bounds read in certain incomplete character
  sequences
  * Remove patch 23fix-buf.pl which is included in upstream release.
  * Set PACKAGE_VERSION for configure as suggested by upstream.

 -- Rhonda D'Vine   Thu, 05 Jan 2017 10:26:08 +0100

** Affects: irssi (Ubuntu)
 Importance: Undecided
 Status: New

** Attachment added: "irssi_ubuntu.debdiff"
   
https://bugs.launchpad.net/bugs/1685561/+attachment/4866626/+files/irssi_ubuntu.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1685561

Title:
  Please merge irssi-1.0.2-1 (main) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/irssi/+bug/1685561/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1685560] [NEW] Please merge irssi-1.0.2-1 (main) from Debian unstable (main)

2017-04-22 Thread Unit 193
Public bug reported:

Changes since last merge:

irssi (1.0.2-1) unstable; urgency=high

  * New upstream pure bugfix release:
- Prevent some null-pointer crashes.
- Fix compilation with OpenSSL 1.1.0.
- Correct dereferencing of already freed server objects during
  output of netjoins. Found by APic. (closes: #857502)
- Fix in command arg parser to detect missing arguments in tail place.
- Fix regression that broke incoming DCC file transfers.
- Fix issue with escaping \ in evaluated strings.

 -- Rhonda D'Vine   Sat, 11 Mar 2017 10:52:54 +0100

irssi (1.0.1-1) unstable; urgency=high

  * New upstream pure bugfix release:
- Fix Perl compilation in object dir.
- Disable EC cryptography on Solaris to fix build.
- Fix incorrect HELP SERVER example.
- Correct memory leak in /OP and /VOICE.
- Fix regression that broke second level completion.
- Correct missing NULL termination in perl_parse.
- Sync broken mail.pl script.

 -- Rhonda D'Vine   Mon, 06 Feb 2017 08:07:55 +0100

irssi (1.0.0-1) unstable; urgency=medium

  * New upstream release.
  * Add patch 25tls-ssl-compat-defines provided by upstream's dx for backward
compatibility to not require modules using these functions to change code.
  * Update patch 22fix-perl-hardening.

 -- Rhonda D'Vine   Sun, 08 Jan 2017 01:08:23 +0100

irssi (0.8.21-1) unstable; urgency=medium

  * New upstream security release (Closes: #850403):
- CVE-2017-5193: NULL pointer dereference in the nickcmp function
- CVE-2017-5194: Use-after-freee when receiving invalid nick message
- CVE-2017-5195: Out-of-bounds read in certain incomplete control codes
- CVE-2017-5196: Out-of-bounds read in certain incomplete character
  sequences
  * Remove patch 23fix-buf.pl which is included in upstream release.
  * Set PACKAGE_VERSION for configure as suggested by upstream.

 -- Rhonda D'Vine   Thu, 05 Jan 2017 10:26:08 +0100

** Affects: irssi (Ubuntu)
 Importance: Undecided
 Status: New

** Attachment added: "Diff from Ubuntu version"
   
https://bugs.launchpad.net/bugs/1685560/+attachment/4866625/+files/irssi_ubuntu.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1685560

Title:
  Please merge irssi-1.0.2-1 (main) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/irssi/+bug/1685560/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1647101] Re: UnicodeDecodeError in fast-export when author name contains non-ascii characters

2017-04-22 Thread Unit 193
Been using this at least since Jan.

** Patch added: "pyfi.debdiff"
   
https://bugs.launchpad.net/python-fastimport/+bug/1647101/+attachment/4866587/+files/pyfi.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1647101

Title:
  UnicodeDecodeError in fast-export when author name contains non-ascii
  characters

To manage notifications about this bug go to:
https://bugs.launchpad.net/python-fastimport/+bug/1647101/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1673625] Re: 10-globally-managed-devices.conf contained in wrong package

2017-03-18 Thread Unit 193
** Also affects: network-manager (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1673625

Title:
  10-globally-managed-devices.conf contained in wrong package

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1673625/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1673625] Re: 10-globally-managed-devices.conf contained in wrong package

2017-03-17 Thread Unit 193
Right, I gathered that part.  But then again so are things like resolved
and snap which I consider optional (and the former has been breaking DNS
in my VMs, 10-dns-resolved.conf made it more fun.)

I considered, based on the logic of "this configuration 'comes' for
another package and breaks this package" should be enough, but yes I've
had to track down as to why I had no networking with NM installed.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1673625

Title:
  10-globally-managed-devices.conf contained in wrong package

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nplan/+bug/1673625/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1673625] [NEW] 10-globally-managed-devices.conf contained in wrong package

2017-03-16 Thread Unit 193
Public bug reported:

/usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf is
installed from network-manager but without nplan it has no benefit, and
breaks networking until you override it.  Since the config is there to
change how NetworkManager behaves in the presence of nplan, the
configuration file itself should actually be contained in the nplan
package.

** Affects: nplan (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1673625

Title:
  10-globally-managed-devices.conf contained in wrong package

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nplan/+bug/1673625/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1668093] Re: ssh-keygen -H corrupts already hashed entries

2017-03-08 Thread Unit 193
This was fixed upstream in this commit
https://anongit.mindrot.org/openssh.git/commit/?id=12d3767ba4c84c32150cbe6ff6494498780f12c9

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1668093

Title:
  ssh-keygen -H corrupts already hashed entries

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1668093/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1666988] Re: Incompatibilities with ruby-json =>2.0

2017-02-28 Thread Unit 193
Updated debdiff including the d/changelog fixes as requested.

** Patch added: "ruby-simplecov.debdiff"
   
https://bugs.launchpad.net/ubuntu/+source/ruby-simplecov/+bug/1666988/+attachment/4828654/+files/ruby-simplecov.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1666988

Title:
  Incompatibilities with ruby-json =>2.0

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ruby-simplecov/+bug/1666988/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


[Bug 1668781] [NEW] Sync atheme-services 7.2.9-1 (universe) from Debian unstable (main)

2017-02-28 Thread Unit 193
Public bug reported:

Please sync atheme-services 7.2.9-1 (universe) from Debian unstable
(main)

Please note, 7.2.8 and 7.2.9 fix security issues.

Changelog entries since current zesty version 7.2.7-1:

atheme-services (7.2.9-1) unstable; urgency=medium

  * new upstream release (7.2.8) fixing security issue "saslserv/main: free
sasl_sourceinfo_t after use" see:
https://github.com/atheme/atheme/pull/539
  * new upstream release (7.2.9) fixing security issue introduced in
7.2.8: "Fix use after free during impersonation" (Closes: #855588)
  * remove two OpenSSL 1.1 patches merged upstream

  [ Jos Ahrens ]
  * email templates: Fix leading whitespace

  [ Aaron Jones ]
  * atheme.conf.example: better highlight the pbkdf2v2 crypto module
  * pbkdf2v2: make digest and rounds configurable at runtime
  * memoserv: let user know (on identify and /away) when their inbox is full
  * memoserv: unregister hooks when unloading

 -- Antoine Beaupré   Tue, 07 Feb 2017 21:01:27
-0500

** Affects: atheme-services (Ubuntu)
 Importance: Wishlist
 Status: New

** Changed in: atheme-services (Ubuntu)
   Importance: Undecided => Wishlist

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1668781

Title:
  Sync atheme-services 7.2.9-1 (universe) from Debian unstable (main)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/atheme-services/+bug/1668781/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

[Bug 1666988] Re: Incompatibilities with ruby-json =>2.0

2017-02-23 Thread Unit 193
The next Debian upload would likely be a new upstream release, which
would fix this, or if we're lucky then they'll upload a patch. It
shouldn't be out of sync long.

The package is not entirely broken, no.  Just some incompatibilities
with another package.  I noticed when building another package locally
(ruby-trello).

There is currently no bug filed in Debian, yet, but I did ask the team
and Antonio Terceiro (last uploader) responded.

Yeah 'devel' is just a 'symlink' to the development release, I've been
told it's fine to use and have uploaded stuff to there before.  I
understand that some of the sponsor tools don't know about it, so I can
change that to 'zesty'.

It perhaps should, it just cleans up after the build process.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1666988

Title:
  Incompatibilities with ruby-json =>2.0

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ruby-simplecov/+bug/1666988/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs


  1   2   3   >