Re: (Probably) A Bug in AjaxLink and list

2013-11-06 Thread lambdad...@gmail.com
Hi Martin, Here is the java file: http://pastebin.com/rKpp50zr and the corresponding html file: http://pastebin.com/Cq1j7ZPT I have also tried with the WebMarkupContainer and had experienced the same behavior. Thanks in advance, L On Tue, Nov 5, 2013 at 2:07 PM, Martin Grigorov

Re: Document mode restart from IE9 Standards to Quirks - any ideas?

2013-11-06 Thread Sebastien
Hi Matt, Just FYI, even Google apps stops supporting IE9... http://googleappsupdates.blogspot.fr/2013/11/end-of-support-for-internet-explorer-9.html I know it is not a resolution of your problem but it might help you to justify IE9 is outdated... Best regards, Sebastien. On Wed, Nov 6, 2013

Re: (Probably) A Bug in AjaxLink and list

2013-11-06 Thread Martin Grigorov
Hi, span wicket:id=dummy id=raw/span remove id=raw and let Wicket generate the id for you On Wed, Nov 6, 2013 at 11:56 AM, lambdad...@gmail.com lambdad...@gmail.comwrote: Hi Martin, Here is the java file: http://pastebin.com/rKpp50zr and the corresponding html file:

Re: (Probably) A Bug in AjaxLink and list

2013-11-06 Thread lambdad...@gmail.com
That works! Thanks for your answer. cheers, L On Wed, Nov 6, 2013 at 12:37 PM, Martin Grigorov mgrigo...@apache.orgwrote: Hi, span wicket:id=dummy id=raw/span remove id=raw and let Wicket generate the id for you On Wed, Nov 6, 2013 at 11:56 AM, lambdad...@gmail.com

Re: Back button not calling onConfigure()

2013-11-06 Thread Artur Kronenberg
Hi, I would expect it to hit the container. Debuggin and testing on a test environment works and hits it. Unfortunatelly there is no way to definitely proove that the error in question hits it to. I do know that the onConfigure is not hit. I don't have access to the access logs. Is there a

Re: getPage(pageReference) == null since Wicket 6.10.0

2013-11-06 Thread Ondrej Zizka
Try the JBoss EAP 6.1: http://www.jboss.org/jbossas/downloads/ I didn't have much trouble using that with Wicket 6.x. Ondra On 5.11.2013 18:19, Dieter Tremel wrote: Am 12.10.2013 12:19, schrieb Dieter Tremel: Sometimes I have the impression that a Glassfish and wicket are not a couple in

Re: Signing in works on localhost but not on VPS server

2013-11-06 Thread meduolis
Does your VPS and your computer uses same databases? If not, check if user that you want to log in exists in VPS DB -- View this message in context: http://apache-wicket.1842946.n4.nabble.com/Signing-in-works-on-localhost-but-not-on-VPS-server-tp4662167p4662169.html Sent from the Users forum

Re: Cannot get to desired error page on handling RuntimeException in AbstractRequestCycleListener#onException()

2013-11-06 Thread dgn
Thanks Martin. Good to know about the other option. I'll go with Session.get().bind(); since I get the redirect to the error page. Otherwise, if I add the RedirectPolicy.NEVER_REDIRECT to the RenderPageRequestHandler there will still be the original value in the URL bar of the browser. -- View

Re: Back button not calling onConfigure()

2013-11-06 Thread Martin Funk
Hi, have you thought about wireshark? Easy to set up and not all that hard to handle. Filters are powerful and most interestingly for Web-Development ist the Follow TCP stream function. http://www.wireshark.org/docs/wsug_html_chunked/ChAdvFollowTCPSection.html mf Am 06.11.2013 um 15:27

Re: Back button not calling onConfigure()

2013-11-06 Thread Artur Kronenberg
Hi Martin, I had a quick read through it and this is not an option. I can't reproduce the error and it is not given when it will reoccur. If I understood it correctly I'd have to caputre all network traffic for my application until the point the error occurs to be able to use wireshark and

Re: getPage(pageReference) == null since Wicket 6.10.0

2013-11-06 Thread David Beer
JBoss AS 7 and Wildfly 8 work nicely with Wicket. On 6 November 2013 15:25, Ondrej Zizka ozi...@redhat.com wrote: Try the JBoss EAP 6.1: http://www.jboss.org/jbossas/downloads/ I didn't have much trouble using that with Wicket 6.x. Ondra On 5.11.2013 18:19, Dieter Tremel wrote: Am

Re: getPage(pageReference) == null since Wicket 6.10.0

2013-11-06 Thread Dieter Tremel
Thank You, will try that. Dieter Am 06.11.2013 17:14, schrieb David Beer: JBoss AS 7 and Wildfly 8 work nicely with Wicket. On 6 November 2013 15:25, Ondrej Zizka ozi...@redhat.com wrote: Try the JBoss EAP 6.1: http://www.jboss.org/jbossas/downloads/ I didn't have much trouble using

How to use BootStrap3 ProgressBar and UpdateableProgress Bar

2013-11-06 Thread David Beer
Hi Guys I have added an UploadProgressBar from the Wicket extensions to my upload form and process, it would be nice if I could keep the Bootstrap3 components. I am having a bit of difficulty fguring out how I can attach either a ProgressBar or UpdatableProgresBar to my upload form. Any

Re: Back button not calling onConfigure()

2013-11-06 Thread Martin Funk
Hi Arthur, no worries. This was just a hint. Wireshark might look quite discouraging at first sight. When it is started it will show all the network traffic on the machine, but that output can be filtered quite effectively. If it is really important, then wireshark can analyse gigabyte big

Re: Wicket job opportunities

2013-11-06 Thread Ondrej Zizka
I guess you have checked http://careers.stackoverflow.com/jobs/tag/wicket and also http://www.linkedin.com/vsearch/j?keywords=wicketopenAdvancedForm=truelocationType=YsortBy=R Ondra On 29.10.2013 19:13, Leonid Bogdanov wrote: Hello! Sorry for bringing this topic, but I'm wondering are

Signing in works on localhost but not on VPS server

2013-11-06 Thread MartinoSuperman
Hello, I made authentication and authorization in my website. Signing in works perfectly on my own computer on localhost, but it does not work on my VPS server. I installed everything according to plan. But now I want to sign in and that does not work. Does someone know what the cause of

Issue w/ Ajax and setting form containers visible in Deployment mode.

2013-11-06 Thread Ben S
Hello, I've been trying to work on this issue for hours and have had no luck. Basically, my code works just fine in development mode as intended, however when in Deployment mode I can't seem to get WebMarkupContainers toggle between visibility. If they're visible, they won't go invisible,

Bizarre undentified error resulting in blank page

2013-11-06 Thread Rafael Barrera Oro
Hello! I've stumbled across a tricky one, i am getting a blank screen withouth any error in the logs, the only thing i can observe is the following javascript error on the js console: *Uncaught TypeError: Cannot call method 'appendChild' of null wicket-ajax-debug.js:207* *GET

Re: Issue w/ Ajax and setting form containers visible in Deployment mode.

2013-11-06 Thread Martin Grigorov
Hi, Show us your code. It is possible to do what you need but we cannot say what is wrong from the provided information. On Thu, Nov 7, 2013 at 3:21 AM, Ben S br...@yahoo.com wrote: Hello, I've been trying to work on this issue for hours and have had no luck. Basically, my code works

Re: Bizarre undentified error resulting in blank page

2013-11-06 Thread Martin Grigorov
Hi, On Thu, Nov 7, 2013 at 5:33 AM, Rafael Barrera Oro boraf...@gmail.comwrote: Hello! I've stumbled across a tricky one, i am getting a blank screen withouth any error in the logs, the only thing i can observe is the following javascript error on the js console: *Uncaught TypeError: