[ovirt-users] gfapi, 3.5.1

2014-12-09 Thread Alex Crow
Hi, Will the vdsm patches to properly enable libgfapi storage for VMs (and matching refactored code in the hosted-engine setup scripts) for VMs make it into 3.5.1? It's not in the snapshots yet it seems. I notice it's in master/3.6 snapshot but something stops the HA stuff in self-hosted

Re: [ovirt-users] gfapi, 3.5.1

2014-12-16 Thread Alex Crow
Hi, Anyone know if this is due to work correctly in the next iteration of 3.5? Thanks Alex On 09/12/14 10:33, Alex Crow wrote: Hi, Will the vdsm patches to properly enable libgfapi storage for VMs (and matching refactored code in the hosted-engine setup scripts) for VMs make it into 3.5.1

Re: [ovirt-users] Change gluster primary

2015-01-20 Thread Alex Crow
Hi John, There isn't really a primary in gluster. If you're using a glusterfs storage domain, you could turn off nix and the VMs would continue to run (although you'd have to disable quorum if you currently have it enabled on the volume, and you'd have to repoint the domain at some later

Re: [ovirt-users] Migration from Xenserver 6.2 to KVM.

2015-01-20 Thread Alex Crow
Is there a way to export the VM disk images from Xenserver? If so you should be able to spin them up on a KVM host and then use v2v to import these into oVirt. Cheers Alex On 20/01/15 11:57, mots wrote: -Ursprüngliche Nachricht- Von:Yaniv Dary yd...@redhat.com Gesendet: Die 20

Re: [ovirt-users] Put the engine inside hosts after installation

2015-01-17 Thread Alex Crow
On 16/01/15 19:26, Mario Giammarco wrote: 2015-01-16 12:37 GMT+01:00 Simone Tiraboschi stira...@redhat.com mailto:stira...@redhat.com: HA capability is provided for other VMs by oVirt engine. But who provide it if the engine itself is on a VM on the host that it's managing?

Re: [ovirt-users] Change gluster primary

2015-01-24 Thread Alex Crow
there are some bugs there. When we have had storage issues on RHEV we see all our VMS pausing, not crashing. BTW we do use the ded. hypervisor (like oVirt node). Cheers Alex regards, John On 21/01/15 00:20, Alex Crow wrote: Hi John, There isn't really a primary in gluster. If you're using

Re: [ovirt-users] bonding 802.3ad mode

2015-03-18 Thread Alex Crow
The balancing on 802.3ad only occurs for different network flows based on a hash of source and destination MAC (or can be made to add IP addresses into the calculation). A single flow will only use a single NIC in ad mode. Alex On 18/03/15 16:17, Nathanaël Blanchet wrote: Hi all, I'm

Re: [ovirt-users] used engine-iso-uploader to upload ISO , but cant find the images

2015-05-06 Thread Alex Crow
On 06/05/15 06:36, John Joseph wrote: Hi All I finished installing oVirto 3.5.2-1 on CentOS 6.6 64 bit OS and it is working and now I am slowly epxloring other feaures. I have uploaded a ISO image, and the message says that It is been uploaded as follows # engine-iso-uploader -i

Re: [ovirt-users] Maximum VM memory

2015-05-10 Thread Alex Crow
On 10/05/15 13:17, Christophe TREFOIS wrote: Dear ovirt users, We have a special machine which has 1 TB RAM. The idea is to have 3-4 VMs on there which should be split like 85/5/5/5 % of total RAM. I have three questions: 1. Is there any reason not to put up a VM with so much RAM One

Re: [ovirt-users] Kernel panic - not syncing: An NMI occurred on HP Dl360g6

2015-05-27 Thread Alex Crow
Hi, If you've had a crash caused by an NMI it can often be a hardware issue. Maybe worth running some H/W diagnostics. Cheers Alex On 27/05/15 15:40, Daniel Helgenberger wrote: Hello, can somebody help me getting to the bottom of this panic? vdsm.log was empty (stopped 10min prior panic)

Re: [ovirt-users] GlusterFS Hyperconvergence

2015-07-06 Thread Alex Crow
On 06/07/15 16:01, Tiemen Ruiten wrote: Also, while I can imagine why fencing might be a problem, what would be the issue with HA? /users Hi, Fencing is required for HA. If a box hosting HA vms seem to have gone away, it *has* to be guaranteed those VMs are not running before they are

Re: [ovirt-users] Ovirt and Gluster

2015-07-28 Thread Alex Crow
Hi, That does not provide any answers to the OP's questions. And it also still fails to *explicitly* mention that gfapi acceleration is not available unless you use oVirt 3.6.0 (which AFAIK is still in beta). I raised a documentation bug about that many months ago and I still feel it has not

Re: [ovirt-users] Wishlist - Mix gluster and local storage in same data center

2015-11-08 Thread Alex Crow
Messed up the quote. removed it for clarity: One thing that would render this whole issue moot is being able to use local fast storage on the hypervisor hosts, ie SSD or 3D-Xpoint drives in LVM-Cache to accelerate IOPS on shared storage. The underlying stuff is already there, and it works.

Re: [ovirt-users] Wishlist - Mix gluster and local storage in same data center

2015-11-08 Thread Alex Crow
There are many things that tie a VM to a host, like USB device passthrough, but that's not reason to remove all such support from oVirt, is it? In my case, I'd like to mix iSCSI and local storage, because I have a couple of systems that need higher disk I/O that I'd like to put on my shared

Re: [ovirt-users] oVirt 3.5 -> 3.6 engine upgrade failure

2015-11-05 Thread Alex Crow
Encountered " "numberOsCpus "" at line 7, column 33. Was expecting one of: "ram" ... "disksize" ... "numberOfCpus" Typo bug maybe? See "...Os..." vs "...Of..." -- This message is intended only for the addressee and may contain confidential information. Unless you are that person, you may not

[ovirt-users] 3.6.0 nighty hosted-engine deploy quits silently on second host

2015-09-12 Thread Alex Crow
Hi. I've manged to get a 3.6.0-pre self-hosted engine running on one Centos 7.1 host (glusterfs-backed) but on the second host it the deploy process just quits with no error before I even get to configure the storage: [root@olympia ~]# hosted-engine --deploy [ INFO ] Stage: Initializing [

Re: [ovirt-users] P2V shrink disk

2015-09-17 Thread Alex Crow
On 17/09/15 13:32, wodel youchi wrote: Hi, I am not sure if it's the right place to post this question. I tried to do a P2V operation of a Win2k3 server to ovirt 3.5 the physical server is RAID5 of 3x146Go configured, about 290 Go usable space, but the server uses about 20Go only. I am

Re: [ovirt-users] P2V shrink disk

2015-09-17 Thread Alex Crow
On 17/09/15 13:40, Alex Crow wrote: On 17/09/15 13:32, wodel youchi wrote: Hi, I am not sure if it's the right place to post this question. I tried to do a P2V operation of a Win2k3 server to ovirt 3.5 the physical server is RAID5 of 3x146Go configured, about 290 Go usable space

Re: [ovirt-users] Automatically migrate VM between hosts in the same cluster

2015-09-17 Thread Alex Crow
On 17/09/15 14:25, Luca Bertoncello wrote: Hi list! I'm new by oVirt. Right now I configured a Cluster with two hosts and a VM. I can migrate the VM between the two hosts without any problem, but what I need is, that the VM automatically migrate if an host is down. The migration occurs just

Re: [ovirt-users] Automatically migrate VM between hosts in the same cluster

2015-09-17 Thread Alex Crow
I don't really think this is practical: - If the PSU failed, your UPS could alert you. If you have one... If you have only one PSU in a host, a UPS is not going to stop you losing all the VMs on that host. OK, if you had N+1 PSUs, you may be able to monitor for this (IPMI/LOM/DRAC etc)and

Re: [ovirt-users] Automatically migrate VM between hosts in the same cluster

2015-09-18 Thread Alex Crow
rer: Rüdiger Henke, André Pinkert USt-IdNr.: DE234220077 *From:*users-boun...@ovirt.org [mailto:users-boun...@ovirt.org] *On Behalf Of *matthew lagoe *Sent:* Thursday, September 17, 2015 9:56 PM *To:* 'Alex Crow'; 'Yaniv Kaul' *Cc:* users@ovirt.org *Subject:* Re: [ovirt-users] Automatically migrat

Re: [ovirt-users] Automatically migrate VM between hosts in the same cluster

2015-09-18 Thread Alex Crow
On 18/09/15 07:59, Luca Bertoncello wrote: Hi Alex 2) My question was: "what can I do, so that in case of Kernel Panic or similar, the VM will be migrated (live or not) to another host?" You would make the VMs HA and acquire a fencing solution. What do you mean now? Have two VM and build

Re: [ovirt-users] Automatically migrate VM between hosts in the same cluster

2015-09-18 Thread Alex Crow
Well, right now my problem is to understand how can I "simulate" this Power management. Maybe in the future, if we decide that oVirt is the right solution for us, we will buy some Power management system (APC or similar). But now, for the experiments, I can't ask my boss to pay >500€ for a

Re: [ovirt-users] Problem migration VM

2015-09-23 Thread Alex Crow
On 23/09/15 13:54, Luca Bertoncello wrote: Hi Alex Did the host you are running the script on shut down before the migration completed? Apparently yes... Thought so. The migration then cannot continue, obviously. If you put the host in maintenance from the GUI, does it successfully

Re: [ovirt-users] Problem migration VM

2015-09-23 Thread Alex Crow
On 23/09/15 10:30, Luca Bertoncello wrote: Hi list! Sorry fort the previous E-Mail... problem on my Outlook... :( Here again... After a "war-week" I finally got a systemd-script to put the host in "maintenance" when a shutdown will started. Now the problem is, that the automatically

Re: [ovirt-users] Problem migration VM

2015-09-23 Thread Alex Crow
On 23/09/15 14:11, Luca Bertoncello wrote: Hi Alex Thought so. The migration then cannot continue, obviously. Obviously... :( Can someone suggest me a way to call my script as FIRST script on shutdown/reboot and to block the shutdown/reboot until my script complete? This will solve the

Re: [ovirt-users] Network tagging

2015-12-18 Thread Alex Crow
Just curious, why would you want to bond two different VLAN interfaces? It does not make much sense. You can add a network with a VLAN and then use it on a bonded connection or an a single interface, if that's what you mean. I just wish there was a way to make the VLAN ID optional, so you

Re: [ovirt-users] VM has been paused due to no Storage space error.

2016-04-13 Thread Alex Crow
Hi, If you have set up VM disks as Thin Provisioned, the VM has to pause when the disk image needs to expand. You won't see this on VMs with preallocated storage. It's not the SAN that's running out of space, it's the VM image needing to be expanded incrementally each time. Cheers Alex

Re: [ovirt-users] Educational use case question

2016-04-13 Thread Alex Crow
This certainly works. Console can be reached via a browser plugin or Virt-Viewer (available for Windows). Self-hosted engine is the way to go, and is production-ready, especially if you want to add more nodes later. On 14/04/16 03:33, Michael Hall wrote: > Yes but what about the student sitting

Re: [ovirt-users] Network problem with bonding and Windows guests

2016-05-25 Thread Alex Crow
On 25/05/16 10:28, Maxence Sartiaux wrote: Hello, I've a problem, all my ovirt hosts are linked with a bonding mode 4 (802.3ad LACP) 2x10Gbps Eveything is okay with unix guest but with Windows guest, i can ping but internet browsing is impossible (sometime i have a part of the page, very

Re: [ovirt-users] Slowness in the deploying a vm from template

2016-07-14 Thread Alex Crow
Hi, FYI the "thin" option is in the "resource allocation" tab when "advanced" is selected in the New VM dialog. Cheers Alex On 14/07/16 19:46, Karli Sjöberg wrote: > > > Den 14 jul 2016 20:31 skrev Budur Nagaraju : > > > > HI > > > > When a deploy a vm from template its

Re: [ovirt-users] Fwd: Multipath iSCSI with several IPs

2016-08-04 Thread Alex Crow
On 04/08/16 15:37, James Michels wrote: Hi Dan, The way you describe it I should have 2 storage backends with 2 IPs for the same SAN backend, right? The problem I see is that when you create a disk for a VM, you assign it to only one storage domain... so if the first fails, how will oVirt

Re: [ovirt-users] Host non operationnal due to an iSCSI problem

2016-07-19 Thread Alex Crow
On 19/07/16 09:52, Alexis HAUSER wrote: Hi, I just added a second host but it can't become operational, because it can't access to the iSCSI storage domain. My first question : is it normal or not, is RHEV really able to manage the fact an iSCSI LUN can be accessed from multiple hosts ?

Re: [ovirt-users] Host non operationnal due to an iSCSI problem

2016-07-19 Thread Alex Crow
On 19/07/16 10:38, Alexis HAUSER wrote: Sounds like a possible networking problem. Have you assigned IP addresses to the storage interfaces on this new host? hum, What do you mean by storage interfaces ? The other host on the same network can access it. If you're using VLANs, are they

Re: [ovirt-users] Host non operationnal due to an iSCSI problem

2016-07-19 Thread Alex Crow
On 19/07/16 11:13, Alexis HAUSER wrote: I don't understand. iSCSI is a network storage protocol. What do you mean by "I access it directly"? When you set up the first host with an iSCSI storage domain, you would have had to point it to an IP address, "discover" the LUNs and then attach to

Re: [ovirt-users] Host non operationnal due to an iSCSI problem

2016-07-19 Thread Alex Crow
On 19/07/16 15:22, Alexis HAUSER wrote: I'm still finding this hard to understand. If you are using iSCSI, you /are/ using a server (called the "Target" in SCSI speak). Is the iSCSI storage actually on the first host? It's a Dell bay (or "storage array", I think that's the correct name in

Re: [ovirt-users] How to change DATA to ISO domain

2017-05-02 Thread Alex Crow
Create a new DATA domain with what you really need. Then make that the master and put the old one into maintenance and remove it. That should do what you need. Cheers Alex On 02/05/17 15:13, Langley, Robert wrote: I went to add my ISO domain as the first storage domain. It got created as a

Re: [ovirt-users] Seamless SAN HA failovers with oVirt?

2017-06-06 Thread Alex Crow
I use Open-E in production on standard Intel (Supermicro) hardware. It can work in A/A (only in respect of ovirt, ie one LUN normally active on one server, the other LUN normally stays on the the other node) or A/P mode with multipath. Even in A/P mode it fails over quick enough to avoid VM

Re: [ovirt-users] change CD not working

2018-03-16 Thread Alex Crow
On 15/03/18 18:55, Junaid Jadoon wrote: Ovirt engine and node version are 4.2. "Error while executing action Change CD: Failed to perform "Change CD" operation, CD might be still in use by the VM. Please try to manually detach the CD from withing the VM: 1. Log in to the VM

Re: [ovirt-users] VM has been paused due to NO STORAGE SPACE ERROR ?!?!?!?!

2018-03-16 Thread Alex Crow
On 16/03/18 13:46, Nicolas Ecarnot wrote: Le 16/03/2018 à 13:28, Karli Sjöberg a écrit : Den 16 mars 2018 12:26 skrev Enrico Becchetti :   Dear All,     Does someone had seen that error ? Yes, I experienced it dozens of times on 3.6 (my 4.2 setup has

Re: [ovirt-users] CD drive not showing

2018-03-19 Thread Alex Crow
Maybe try removing the ISO domain and then importing it. Alex On 19/03/18 08:17, Junaid Jadoon wrote: Hi, Cd drive is not showing in windows 7 VM. Please help me out??? ___ Users mailing list Users@ovirt.org