Re: [zones-discuss] Newbie: Just upgraded from 2008.11 to 2009.06 and zone

2009-06-15 Thread Ian
the UID is not your problem. the problem is that uninstalled is not a valid zone state. (sorry, i just checked my sent emails and i did indeed tell you to set the state to uninstalled, my bad.) the proper state is configured. Aha ! That's suberb: thank you. Everything is back up and

Re: [zones-discuss] Newbie: Just upgraded from 2008.11 to 2009.06 and zone

2009-06-14 Thread Edward Pilatowicz
On Sat, Jun 13, 2009 at 02:25:16PM -0700, Ian wrote: this error seems to indicate that the zone state in /etc/zones/index is invalid. (normally people shouldn't edit this file for exactly this reason. ;) what are the contents of this file? I've attached the full file to this

Re: [zones-discuss] Newbie: Just upgraded from 2008.11 to 2009.06 and zone

2009-06-12 Thread Ian
Hi ed, hm. detach is failing because attach never marked any zone dataset as active. could you file a bug against detach to make it more robust in the face of failiures? Sure. to work around this problem you might just want to edit /etc/zones/index and change the zone state to

Re: [zones-discuss] Newbie: Just upgraded from 2008.11 to 2009.06 and zone

2009-06-12 Thread Edward Pilatowicz
On Fri, Jun 12, 2009 at 01:03:17PM -0700, Ian wrote: Hi ed, hm. detach is failing because attach never marked any zone dataset as active. could you file a bug against detach to make it more robust in the face of failiures? Sure. to work around this problem you might just want

Re: [zones-discuss] Newbie: Just upgraded from 2008.11 to 2009.06 and zone

2009-06-12 Thread Ian
once you've changed the state to uninstalled, you don't need to do a detach. just do: zoneadm -z lt;zonegt; attach -u -d lt;zbe_datasetgt; Unfortunately, it doesn't like that either: # zoneadm -z web attach -u -d /space/zones/web/ROOT/zbe zoneadm: web: could not get state: No such

Re: [zones-discuss] Newbie: Just upgraded from 2008.11 to 2009.06 and zone

2009-06-12 Thread Edward Pilatowicz
On Fri, Jun 12, 2009 at 01:50:16PM -0700, Ian wrote: once you've changed the state to uninstalled, you don't need to do a detach. just do: zoneadm -z lt;zonegt; attach -u -d lt;zbe_datasetgt; Unfortunately, it doesn't like that either: # zoneadm -z web attach -u -d