On Tue, 11 Mar 2025 16:49:49 GMT, Anthony Scarpino <ascarp...@openjdk.org> wrote:
>> Hi, >> >> I need a review for the following change. Naming conventions for EdDSA and >> XDH have inconsistencies between DisabledAlgorithms and KeyPairGenerator. >> These internal changes help make it more consistent when parsing the actual >> curve being used vs the broader algorithm name. >> >> thanks >> >> Tony > > Anthony Scarpino has updated the pull request incrementally with one > additional commit since the last revision: > > check for dup test/jdk/sun/security/util/AlgorithmConstraints/DisabledAlgorithmPermits.java line 138: > 136: > System.out.print("\tpermits(Set.of(CryptoPrimitive.SIGNATURE), \"" + > 137: tc.testAlgo + "\", null): " + > 138: (r = dac.permits(Set.of(CryptoPrimitive.SIGNATURE), I find this construct hard to read. I suggest we do `boolean r = dac.permits(Set.of(CryptoPrimitive.SIGNATURE), tc.testAlgo, null)` above and just use `r` in the `print` statement. test/jdk/sun/security/util/AlgorithmConstraints/DisabledAlgorithmPermits.java line 162: > 160: > System.out.print("\tpermits(Set.of(CryptoPrimitive.SIGNATURE), " + > 161: tc.testAlgo + " privkey): " + > 162: (r = dac.permits(Set.of(CryptoPrimitive.SIGNATURE), k)) + Same as above. ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/23647#discussion_r2001844217 PR Review Comment: https://git.openjdk.org/jdk/pull/23647#discussion_r2001844627