On Fri, 21 Mar 2025 20:36:47 GMT, Anthony Scarpino <ascarp...@openjdk.org> wrote:
>> Hi, >> >> I need a review for the following change. Naming conventions for EdDSA and >> XDH have inconsistencies between DisabledAlgorithms and KeyPairGenerator. >> These internal changes help make it more consistent when parsing the actual >> curve being used vs the broader algorithm name. >> >> thanks >> >> Tony > > Anthony Scarpino has updated the pull request incrementally with one > additional commit since the last revision: > > comments on test src/java.base/share/classes/sun/security/util/KeyUtil.java line 183: > 181: * DisabledAlgorithmConstraints (DAC), this distinction is important. > 182: * "EdDSA" means all curves for DAC, but when using it with > 183: * KeyPairGenerator, "EdDSA" means "Ed25519". Maybe just say this allows more precise check for DAC. For `KeyPairGenerator`, "EdDSA" by default means "Ed25519", but you can always call `init(NamedParameterSpec.ED448)` to change it. test/jdk/sun/security/util/AlgorithmConstraints/DisabledAlgorithmPermits.java line 8: > 6: * under the terms of the GNU General Public License version 2 only, as > 7: * published by the Free Software Foundation. Oracle designates this > 8: * particular file as subject to the "Classpath" exception as provided The copyright notice for a test does not need the "Classpath" exception. test/jdk/sun/security/util/AlgorithmConstraints/DisabledAlgorithmPermits.java line 173: > 171: record TestCase(int testType, String testAlgo, boolean expected) { > 172: TestCase(String testAlgo, boolean expected) { > 173: this( 0, testAlgo, expected); Remove the space before '0'. ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/23647#discussion_r2012820050 PR Review Comment: https://git.openjdk.org/jdk/pull/23647#discussion_r2012807533 PR Review Comment: https://git.openjdk.org/jdk/pull/23647#discussion_r2012810741