On Wed, 12 Aug 2026 20:05:57 GMT, Chris Plummer <[email protected]> wrote:

>> Yasumasa Suenaga has updated the pull request incrementally with one 
>> additional commit since the last revision:
>> 
>>   Improve OopField::getOffset
>
> src/jdk.hotspot.agent/share/classes/sun/jvm/hotspot/oops/InstanceKlass.java 
> line 893:
> 
>> 891:   }
>> 892: 
>> 893:   public Address getAdrInlineKlassMembers() {
> 
> Suggestion:
> 
>   public Address getAddressOfInlineKlassMembers() {

I named it to follow HotSpot field name (`_adr_inline_klass_members`).
I think it is better your suggestion if we can, but I'm concern a bit not to 
follow HotSpot manner. Is it ok?

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/32310#discussion_r3771537900

Reply via email to