On Thu, 3 Sep 2026 16:58:51 GMT, Stefan Karlsson <[email protected]> wrote:
>> JEP 401 delivered the preview feature of Value Objects. >> >> During the lifetime of the Valhalla project there were many ideas and names, >> and at one point the value types were called inline types. The HotSpot code >> was changed to use the name "inline types" instead of "value types" (and >> inline klass instead of value klass) >> [JDK-8249257](https://bugs.openjdk.org/browse/JDK-8249257). >> >> Later the concept and name "inline type" were dropped, but HotSpot retained >> the name. This causes confusion when working with the code. Some reasons: >> >> 1) There's no obvious connection to what's described in JEP 401 or the Java >> code. >> >> 2) It is easy to incorrectly assume that these are types that have been >> flattened (inlined) into other objects. >> >> 3) The name clash with C++'s concept of inlining >> >> My proposal is that we revert back to talking about "values" instead of >> "inlines", and that we do this before JDK 28 ships, so that we don't have a >> release where we use the "inline" terminology. >> >> --------- >> - [x] I confirm that I make this contribution in accordance with the >> [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai). > > Stefan Karlsson has updated the pull request with a new target base due to a > merge or a rebase. The pull request now contains eight commits: > > - Merge remote-tracking branch 'upstream/master' into > valhalla_rename_inline_to_value > - inline_alloc -> value_type_alloc > - Rename PrintInlineLayout > - Rename inline_args functions > - Fix alignments > - Fix inline entry point names > - Small fixes > - 8391728: Rename inline klass / type to value klass / type to match Java > side of JEP 401 I poked around at the InlineLayoutInfo name, and this class is used as a per-value field layout descriptor. The fields don't have to be flattened, so a name with Flat in it would be wrong. I've used the name ValueFieldLayoutInfo to make it clearer that we are working with value fields. I hope this is an OK choice of name. Let me know if you think that I should give it another name. ------------- PR Comment: https://git.openjdk.org/jdk/pull/32673#issuecomment-5530189386
