> JEP 401 delivered the preview feature of Value Objects. > > During the lifetime of the Valhalla project there were many ideas and names, > and at one point the value types were called inline types. The HotSpot code > was changed to use the name "inline types" instead of "value types" (and > inline klass instead of value klass) > [JDK-8249257](https://bugs.openjdk.org/browse/JDK-8249257). > > Later the concept and name "inline type" were dropped, but HotSpot retained > the name. This causes confusion when working with the code. Some reasons: > > 1) There's no obvious connection to what's described in JEP 401 or the Java > code. > > 2) It is easy to incorrectly assume that these are types that have been > flattened (inlined) into other objects. > > 3) The name clash with C++'s concept of inlining > > My proposal is that we revert back to talking about "values" instead of > "inlines", and that we do this before JDK 28 ships, so that we don't have a > release where we use the "inline" terminology. > > --------- > - [x] I confirm that I make this contribution in accordance with the [OpenJDK > Interim AI Policy](https://openjdk.org/legal/ai).
Stefan Karlsson has updated the pull request incrementally with one additional commit since the last revision: Rename inline_args functions ------------- Changes: - all: https://git.openjdk.org/jdk/pull/32673/files - new: https://git.openjdk.org/jdk/pull/32673/files/34bb43eb..6fe8496e Webrevs: - full: https://webrevs.openjdk.org/?repo=jdk&pr=32673&range=02 - incr: https://webrevs.openjdk.org/?repo=jdk&pr=32673&range=01-02 Stats: 149 lines in 26 files changed: 0 ins; 0 del; 149 mod Patch: https://git.openjdk.org/jdk/pull/32673.diff Fetch: git fetch https://git.openjdk.org/jdk.git pull/32673/head:pull/32673 PR: https://git.openjdk.org/jdk/pull/32673
