Hi Phil,

thank for your help. No error about java heap space, but tried to configure 
taskomatic memory like you said without success.

I setup the kickstart part long time ago, just using satellite redhat doc.

----- Mail original -----
De: "P Cookson" <p.cook...@bham.ac.uk>
À: "spacewalk-list" <spacewalk-list@redhat.com>
Envoyé: Vendredi 8 Mars 2019 16:43:23
Objet: Re: [Spacewalk-list] Really slow unresponsive GUI

Hi Lionel

Have you looked in /var/log/rhn/rhn_taskomatic_daemon.log too? After seeing 
"java.lang.OutOfMemoryError: Java heap space" messages, in there, I changed 
config for Taskomatic but not sure if this is relevant for you?

Current maxmemory (Xmx) can be seen by checking status of Taskomatic:

# systemctl status taskomatic.service

I increased from 256 to 4096:

# grep taskomatic.java.maxmemory /etc/rhn/rhn.conf
taskomatic.java.maxmemory=4096
#

Then re-started Spacewalk:

# spacewalk-service restart

Also, I've noted you've said something about using Kickstart. After patching 
for some time I need to start looking at provisioning, too, so if you have any 
notes/links about setup that would be useful.


Regards
Phil

-----Original Message-----
From: spacewalk-list-boun...@redhat.com <spacewalk-list-boun...@redhat.com> On 
Behalf Of caig...@cines.fr
Sent: 08 March 2019 14:59
To: spacewalk-list <spacewalk-list@redhat.com>
Subject: [Spacewalk-list] Really slow unresponsive GUI

Hi,

i'm writing here because i've a strange behaviour with no clue on how to 
resolve it. 
There is no load on CPU, ram is mostly free, no IO wait, no processus stuck a 
100%. In log file (tomcat/postresql,...) nothing about error or warning.
No recent modification on the system.

When i want to access spacewalk web interface (or API) this one sometimes 
answer after a very long time, and sometimes get error 500. Same behaviour with 
the spacecmd cli command.

I really don't understand because i've another spacewalk on another server and 
this one work like a charm.

My setup : VM with 2vpcu 8Gb RAM near 200 clients spacewalk 2.8, used only for 
patching and sometimes kickstart new server.
 JAVA_OPTS -Xms2048m -Xmx2048m, tried with 4096 but no difference.

I don't know which log to put here due to the fact i found no error trace.

For now the only solution I imagine is to backup and restore to a new server 
freshly installed my spacewalk.

Thank you for help.

--
Lionel Caignec 

Centre Informatique National de l' Enseignement Supérieur 
950 rue de Saint Priest 
34097 MONTPELLIER Cedex 5 
Tel : (33) 04 67 14 14 14
Fax : (33)04 67 52 37 63 
https://www.cines.fr

_______________________________________________
Spacewalk-list mailing list
Spacewalk-list@redhat.com
https://www.redhat.com/mailman/listinfo/spacewalk-list

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

_______________________________________________
Spacewalk-list mailing list
Spacewalk-list@redhat.com
https://www.redhat.com/mailman/listinfo/spacewalk-list

Reply via email to