Hi Chris

I have the same version in my vertualenv with python version 2.7.8 and 
I tried both on linux and windows, and they are the same, not text inside 
the tags was extracted into pot file. very strange....
Problem with virtualenv ?


在 2016年10月17日星期一 UTC+8下午9:39:07,Christoph Zwerschke写道:
> Am 17.10.2016 um 14:56 schrieb Mingcai SHEN: 
> > But it just can extract {% trans %} {% endtrans %} or {{ gettext('') }} 
> > from the template files into the pot file. 
> You meant *can't* extract, not *can* extract, right? 
> I just tried it with a newly created project, and this simple template: 
> <html> 
> {{ gettext('Hello gettext!') }} 
> {% trans %}Hello trans!{% endtrans %} 
> </html> 
> Both texts were copied to the i18n/*.pot file. 
> I have used Python 2.7, TG 2.3.9, Babel 2.3.4 and Jinja2 2.8. 
> Are you using any different versions? Also, does it work for you with a 
> newly created project and the above simple template? 
> -- Chris 

You received this message because you are subscribed to the Google Groups 
"TurboGears Trunk" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to turbogears-trunk+unsubscr...@googlegroups.com.
To post to this group, send email to turbogears-trunk@googlegroups.com.
Visit this group at https://groups.google.com/group/turbogears-trunk.
For more options, visit https://groups.google.com/d/optout.

Reply via email to