Last July I installed oauth-php to display items from my user timeline
on my website home page. I then copied the setup to another website
with another Twitter account and both have been working fine.

Then a few days ago both websites started returning error code 401,
"This method requires authentication." I can successfully run the
request_token command, but when I run the statuses/user_timeline
command I receive this error.

After experimenting with my own code for a while, I went back to
oauth's Twitter example code here:
http://code.google.com/p/oauth-php/source/browse/trunk/example/client/twoleggedtwitter.php.
This worked fine when accessing the public timeline, but when I
changed it to access the user timeline, I received the same
authentication error.

I've updated to the latest version of oauth, but that made no
difference. I also reset my consumer key and consumer secret key and
that made no difference, either.

Can someone tell me what might have changed in the last few days, or
how I should proceed with troubleshooting this?

-- 
Twitter developer documentation and resources: https://dev.twitter.com/doc
API updates via Twitter: https://twitter.com/twitterapi
Issues/Enhancements Tracker: https://code.google.com/p/twitter-api/issues/list
Change your membership to this group: 
https://groups.google.com/forum/#!forum/twitter-development-talk

Reply via email to