The rpc deamon will run as root, but when it spawns a udt process to fulfil
your uniobjects process it will spawn it as the user you use in the
uniobjects session.

-----Original Message-----
[] On Behalf Of douglas chanco
Sent: 24 July 2012 15:25
To: U2 Users List
Subject: [U2] uniobjects running as?

hey everyone,
       does anyone happen to know what user the uniobjects connection is
running as?  I would think root, but that doesn't seem to be correct as when
I run a subversion command as root it works fine but when I run it from a
uniobjects connection (via c# calling a pick subroutine) I get prompted to
accept a self signed certificate (yeah yeah I know......)  anyway I accepted
it from the command line (so I don't get prompted anymore) as a specific
user and as root (this is all proof of concept test, so if it pans out I
will get a valid certificate).

I am going to modify the pick subroutine to try and "figure out" what user
is calling the pick subroutine as well as modify my shell script with expect
so that it {A}ccepts the certificate but I thought I would ask the "guru's"
on here (you know who you are!) in case expect gives me fits ........



U2-Users mailing list
No virus found in this message.
Checked by AVG -
Version: 2012.0.2197 / Virus Database: 2437/5150 - Release Date: 07/23/12

U2-Users mailing list

Reply via email to