I'll keep that refresh option in mind.
Still a hassle and I would prefer if they would just get rid of that 'feature'. I also noticed that unassigned variable error that pops up for all functions including CALL that return a new variable. Some people may regard assigning a value before you use a function as good coding standard, I don't see the point, though. I haven't tried this in anger, but I recall that BDT treats all files as data files and you can edit data as well. Maybe this is a feature they could add to keep Dict files and hashed files separate so you don't have to look for the BP within 1000 data files every time.

I have been using an external editor (mv developer) for several years now.
I always save the program to disk, open it with ED, add a blank line somewhere and file it with FIBC.
That takes care of PRC.
Locking works when you open a program externally, so the only chance that someone could snatch the program ab incorporate it into another project is in that short period between saving in the external editor and opening it with ED on the UD server for the first time. Since I am the only UD programmer in the company it is virtually impossible that will ever happen.
Well, and as long as you have OS.ED you can bypass PRC anyway.
OK, if you NEVER EVER fix data with ED then you could probably remove it, but who would voluntarily block the only fire escape?

We have a really old version of PRC (3.9) and I can't make a business case to invest in new software.
There are other tools like mv.SSIS that I'd rather get first.
Especially since tools like Rocket's Metadata Manager don't seem to work or I am too stupid to install them properly. I managed to get at least VSG to work on one SQL Server 2008 box, but that is a really primitive tool and I hate it.

And I am still looking for a way to read data from a relational database in a Basic program.


On 06/06/2013 18:30, Tom Whitmore wrote:
Hi Mecki,

One think that I always do with BDT is right-click on the program, select 
refresh, then open the program.  That seems to be the only way to make sure I 
have the current version.

Currently, BDT is sort of working with PRC but it isn't honoring "file 
ownership" so I'm unable to let the programmers use BDT.  You do need to get some 
programs from Susan for things to work as I have it now.  I'm told the latest version of 
PRC supports BDT.  We are currently testing the new version of PRC but I haven't had an 
opportunity to try BDT on this version..

As far as false errors, the latest version of BDT is greatly improved.  
However, I have noticed couple of false errors:
1) if the numeric subroutine label does not have a ":" BDT doesn't recognize 
the label (like 99*).
2) LOCATE(J,ORIG.PH,2;XXXPOS) THEN FOUND=1 ELSE FOUND=0 , BDT will report that 
XXXPOS was never assigned a value.  There are other instances of this type of 
problem.

One thing I wish I could do is edit records in hashed files, but I don't see 
how to accomplish this.

Tom Whitmore
RATEX Business Solutions

-----Original Message-----
From: u2-users-boun...@listserver.u2ug.org 
[mailto:u2-users-boun...@listserver.u2ug.org] On Behalf Of Mecki Foerthmann
Sent: Thursday, June 06, 2013 12:06 PM
To: U2 Users List
Subject: [U2] How do I get the U2 Metadata Manager to work

Ever since we finally upgraded UniData at work I have been trying out the new 
tools and don't seem to have much fun with them.
The best one is XAdmin and I use it a lot these days.

IMHO the interface is a bit crude and clunky, but I guess that's Eclipse and 
you can't do much about that.
The BDT is not of much use since I need to make tweaks of the program using AE 
(even if it only to make PRC work) but when I then open it again in BDT it 
reverts to the old version. Looks like it keeps that in memory on my PC so any 
changes made on the server are lost.
Looks nice and shiny but the syntax check isn't really working either.
99% of the errors shown turn out to be no errors at all.

The latest one I tried is the Metadata Manager.
It installed fine and I can connect to the server and the database no problem.
I can see the files and the dictionaries and can even change data on the server 
but that's it.
The metadata tools I want to use are all greyed out, so what am I doing wrong?

As stated in the Help I ran MIGRATE.SQL on the server but all I achieved is 
that I now cannot change anything using the old Avante Batch Schema Generation 
process. It goes through the motions but just hangs up at the end now.

So at the end I am not overly impressed.
_______________________________________________
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users
_______________________________________________
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


_______________________________________________
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users

Reply via email to