Yes, I understood (or assumed) that the "II" was the SB+ system, just not WHY 
it thought something was corrupt.

I found the error message just like you said in DMCONT ERROR.  I have never 
seen this before.  The record looks like a bunch of generic error messages that 
can be used as needed.

I just tried logging in as rbadmin (the Redback UNIX id), cd'ed over to the 
TEST.DATA account, typed udt, then used the iConnect login/pw for SB.  I got in 
just fine.  Not sure if that was a good thing or a bad thing.

Now the question is: what conditions are occurring via the web site (w/ the 
error) that I have not been able to replicate manually?


-----Original Message-----
From: u2-users-boun...@listserver.u2ug.org 
[mailto:u2-users-boun...@listserver.u2ug.org] On Behalf Of Dave Davis
Sent: Monday, November 25, 2013 1:39 PM
To: U2 Users List
Subject: Re: [U2] Mysterious Error Message

"II" is whatever SB+ system it is logging into.

Whatever SB+ user is being used to log in doesn't have access to the account.

The message is stored in the ERROR item of the DMCONT file - attribute 115 - so 
you won't find that using ESEARCH on a BP file.

Haven't used redback so I don't know what that uses to log into SB.  Have used 
remote processes though - and get these kinds of errors sometime if the user or 
group security tree doesn't allow us to get into where we are trying to go.

-----Original Message-----
From: u2-users-boun...@listserver.u2ug.org 
[mailto:u2-users-boun...@listserver.u2ug.org] On Behalf Of Israel, John R.
Sent: Monday, November 25, 2013 1:28 PM
To: U2 Users List
Subject: Re: [U2] Mysterious Error Message

Yes - the LOGIN paragraphs are the same.

Yes - the iConnect agents are essentially the same (paths are obviously 
different) and they are all enabled.  The last change I made to iConnect was 
3-4 weeks ago to map a new field and that worked (and is still working in LIVE).

I have done an ESEARCH on all the BP files I can think of in Redback, iConnect 
& the Avanté account itself.  Even looking through source codes and object 
code, I cannot find "RECORD CORRUPT" anywhere.  Maybe I missed something, maybe 
it is more cryptic than I would expect, maybe something else.  Bottom line: I 
do not have a clue what program is causing this, what "II" record it thinks is 
corrupt, etc.


-----Original Message-----
From: u2-users-boun...@listserver.u2ug.org 
[mailto:u2-users-boun...@listserver.u2ug.org] On Behalf Of Cook, Amy
Sent: Monday, November 25, 2013 1:17 PM
To: U2 Users List
Subject: Re: [U2] Mysterious Error Message

Hi John,
ok, so let's think this through...
RedBack is using an iConnect agent to login through SB+ and execute the screen.
That message is an SB+ message.

So...my first question would be - are the LOGIN paragraphs the same between 
accounts where it's working and where it's not?
The 2nd would be - is the iconnect Agent, as defined the Site setup the same 
between sites? Is that agent enabled? (I'm assuming the backend iConnect 
accounts are shared per realm?)

-----Original Message-----
From: u2-users-boun...@listserver.u2ug.org 
[mailto:u2-users-boun...@listserver.u2ug.org] On Behalf Of Israel, John R.
Sent: Monday, November 25, 2013 8:46 AM
To: U2 Users List
Subject: [U2] Mysterious Error Message

We use UniData/HPUX w/ SB and Redback.  We are running Epicor's Avanté which 
uses iConnect.
For arguments sake, I have 3 UniData accounts: TEST, PILOT & LIVE.
I have 3 web sites (TEST, PILOT & LIVE) that connect as you would expect.
3-4 weeks ago, a change was made in Sales Order Entry in SB.  I had to make a 
minor tweak for this to work via the web sites.  All was good with all three 
web sites.
Due to unrelated issues, our TEST account has a temporary stand-alone copy of 

Other people on my team have made a few changes in SB Sales Order Entry and 
asked that I verify that the web site still worked.  One change was in TEST and 
another (untested) one was in PILOT.  Order Entry was now failing on both web 
sites, but LIVE was still working.  The change in PILOT was unrolled, but we 
still had the problem.

The actual error we are getting in the Redback log is "II RECORD CORRUP! - 

If the problem were only in TEST, I would blame my local copy of DMSECURITY.  
Since the problem is also in PILOT but NOT in LIVE (which share the standard 
DMSECURITY file), this tells me it is not the DMSECURITY file, but rather 
something that is local to each account.

Has anyone seen this before?  Any thoughts or suggestions?

U2-Users mailing list
U2-Users mailing list
U2-Users mailing list

Dave Davis
Team Lead, Research & Development

P: 614-875-4910 x108
F: 614-875-4088
E: dda...@harriscomputer.com

        6110 Enterprise Parkway
Grove City, OH

This message is intended exclusively for the individual or entity to which it 
is addressed. This communication may contain information that is proprietary, 
privileged or confidential or otherwise legally exempt from disclosure. If you 
are not the named addressee, you are not authorized to read, print, retain, 
copy or disseminate this message or any part of it. If you have received this 
message in error, please notify the sender immediately by e-mail and delete all 
copies of the message.

U2-Users mailing list
U2-Users mailing list

Reply via email to