cloud-init-output.log after manually rebooting the machine.

** Changed in: cloud-init (Ubuntu)
       Status: Incomplete => New

** Attachment added: "cloud-init-output.log"
   
https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1761294/+attachment/5101804/+files/cloud-init-output.log

** Also affects: ifupdown (Ubuntu)
   Importance: Undecided
       Status: New

** Description changed:

  I deployed Xenial in this machine with MAAS. After deployment i had re-
  configured interfaces manually (on /etc/network/interfaces), and removed
  /etc/network/interfaces.d. At some point, I upgraded the machine from
  Xenial to Bionic, and everything was working just fine with /e/n/i.
  
  About 2/3 weeks ago, I dist-upgraded bionic for the latest packages, and
  after reboot, networking didn't come up.
  
+ 
  To recover the machine, what i did is:
  
- 1. From the console, bring up the interfaces.
- 2. Brought up eno1 manually & added an IP address manually (ip addr add)
- 3. Configured netplan interfaces
- 4. Run sudo netplan apply with the following config:
+ 1. From the console, brought up the interfaces manually (eno1)
+ 2. added an IP address manually (ip addr add)
+ 3. Configured netplan and applied the config: 
  
  network:
-     version: 2
-     renderer: networkd
-     ethernets:
-         eno1:
-             dhcp4: no
-             dhcp6: no
-             addresses: [192.168.1.13/24]
-             gateway4: 192.168.1.1
-             nameservers:
-                 addresses: [8.8.8.8, 8.8.4.4]
-         usb0:
-             dhcp4: no
-     bridges:
-         br0:
-             interfaces: [usb0]
-             dhcp4: no
-             addresses: [10.90.90.1/24]
-             parameters:
-                 stp: false
-                 forward-delay: 0
-                 max-age: 0
+     version: 2
+     renderer: networkd
+     ethernets:
+         eno1:
+             dhcp4: no
+             dhcp6: no
+             addresses: [192.168.1.13/24]
+             gateway4: 192.168.1.1
+             nameservers:
+                 addresses: [8.8.8.8, 8.8.4.4]
+         usb0:
+             dhcp4: no
+     bridges:
+         br0:
+             interfaces: [usb0]
+             dhcp4: no
+             addresses: [10.90.90.1/24]
+             parameters:
+                 stp: false
+                 forward-delay: 0
+                 max-age: 0
  
  5. Interfaces dont get configured correctly:
  
  1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group 
default qlen 1000
-     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
-     inet 127.0.0.1/8 scope host lo
-        valid_lft forever preferred_lft forever
-     inet6 ::1/128 scope host 
-        valid_lft forever preferred_lft forever
+     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
+     inet 127.0.0.1/8 scope host lo
+        valid_lft forever preferred_lft forever
+     inet6 ::1/128 scope host
+        valid_lft forever preferred_lft forever
  17: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP 
group default qlen 1000
-     link/ether ec:a8:6b:fd:ac:70 brd ff:ff:ff:ff:ff:ff
-     inet 192.168.1.13/24 scope global eno1
-        valid_lft forever preferred_lft forever
-     inet6 fe80::eea8:6bff:fefd:ac70/64 scope link 
-        valid_lft forever preferred_lft forever
+     link/ether ec:a8:6b:fd:ac:70 brd ff:ff:ff:ff:ff:ff
+     inet 192.168.1.13/24 scope global eno1
+        valid_lft forever preferred_lft forever
+     inet6 fe80::eea8:6bff:fefd:ac70/64 scope link
+        valid_lft forever preferred_lft forever
  19: usb0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP 
group default qlen 1000
-     link/ether 00:0e:c6:88:b7:9f brd ff:ff:ff:ff:ff:ff
-     inet6 fe80::20e:c6ff:fe88:b79f/64 scope link 
-        valid_lft forever preferred_lft forever
+     link/ether 00:0e:c6:88:b7:9f brd ff:ff:ff:ff:ff:ff
+     inet6 fe80::20e:c6ff:fe88:b79f/64 scope link
+        valid_lft forever preferred_lft forever
  22: wlp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group 
default qlen 1000
-     link/ether c4:d9:87:5b:42:62 brd ff:ff:ff:ff:ff:ff
+     link/ether c4:d9:87:5b:42:62 brd ff:ff:ff:ff:ff:ff
  
  6. on reboot, the machine goes back to have no networking again, at all.
+ 
+ Note that I also have /e/n/i configured.

** Changed in: netplan.io (Ubuntu)
   Importance: Critical => Undecided

** Summary changed:

- Network configuration doesn't survive reboots
+ Network configuration doesn't survive reboots after bionic dist-upgrade

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761294

Title:
  Network configuration doesn't survive reboots after bionic dist-
  upgrade

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1761294/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to