Andre Schnabel schrieb:

-------- Original-Nachricht --------
Von: "Wolfgang Jäth" <[email protected]>
....
Der Bug (angesichts des Missverständnisspotentials möchte ich bei dieser
Bezeichnung bleiben) liegt also ausschließlich in der Opberfläche aka der nicht ausreichend präzisen Benennung des Feldes (nur 'Leerzellen zulassen' statt z.B. 'Leerzellen im Detektiv als gültig zulassen' o. ä.). Gips dafür schon ein Issue

meines Wissens nicht.

(falls eine reine Umbenennung überhaupt
ein solches braucht)

Ja, braucht es! Weil "so eine einfache Umbenennung" etwas komplexer ist, als man glaubt. Die erste Frage ist, ob nur die deutsche Übersetzung falsch ist, oder das englische Original. Falls Englisch, muss dort geändert ... dann alle Sprachen nachgezogen werden.
Zusätzlich muss geprüft werden, ob die Hilfe (und wenn ja - wo) angepasst 
werden muss.

Jein; zuerst müsste geprüft werden, ob sich die Option /nur/ in der von Stefan erwähnten Art auswirkt, oder ob es noch andere Bereiche betrifft (ansonsten wäre die neue Benennung ja auch wieder falsch). Und bereits hier übersteigt das zumindest /mein/ Wissen. Deswegen habe ich auch nur vage von 'anstoßen' gesprochen.

Wenn jemand präzise sagen kann, was wo wie geändert werden muss, bitte Issue 
öffnen (ich hab's ehrlich gesagtr nur überflogen und nicht wirklich kapiert).

Es geht darum, daß unter 'Daten => Gültigkeit' auf der Karteikarte 'Kriterien' eine Option ('Leerzellen zulassen') existiert, die aber nicht generell gilt, sonder nur(?) eine Auswirkung im Datendetektiv hat, ohne daß auf diese Einschränkung irgendwie hingewiesen wird. Alle anderen Optionen auf sämtlichen Karteikarten in diesem Dialog gelten dagegen generell. Das kann einen unbedarften User (in dem Fall mich) zu einer fehlerhaften Annahme verleiten.

Wolf 'ist zwar nur eine Kleinigkeit, aber dafür auch äußerst einfach zu
beheben' gang

André 'der schon zu oft gesehen hat dass Änderungen die klein aussehen komplexe 
Auswirkung haben können .. und wenn es schief geht tut das Millionen von 
Anwendern weh'

Yepp: jedoch es scheint sich wohl hier wirklich nur um ein reines Problem der Benennung zu handeln. Ich kann aber leider nicht sagen, ob nur in der deutschen Oberfläche, und was eventuell eine sinnvollere Beschriftung wäre (s. o.).

IMHO sollte der Autor der Option bzw. des Dialoges nach einer präzisen Benennung gefragt werden; er sollte eigentlich am besten wissen, welche Funktionalität hinter dieser Otpion steckt. Aber natürlich ist das ganze eher ein Schönheitsfehler als ein richtiges Problem. Trotzdem sollte es nicht einfach völlig in der Versenkung verschwinden (daher meine Frage nach einem Issue).

Wolfgang
--


---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Antwort per Email an