So I have reinstalled by doing: 
engine-cleanup 
rm -rf /home/iso 
rm -rf /home/storage 
rm /etc/exports 
export LANG=en_US.UTF-8 
engine-setup

Now when asked I have select NFS for the default storage type.

I've done the 5th step at 
http://blog.jebpages.com/archives/up-and-running-with-ovirt-3-1-edition/ .
(Copy and paste - BEGIN)
click on the storage tab and highlight the iso domain you created during the 
setup-script. In the pane that appears below, choose the “Data Center” tab, 
click “Attach,” check the box next to your local data center, and hit “OK.” 
Once the iso domain is finished attaching, click “Activate” to, uh, activate it.
(Copy and paste - END)

I've taken a moment to check /var/log/messages and I have noticed:

Nov 27 14:14:25 server vdsm Storage.LVM WARNING lvm vgs failed: 5 [] ['  Volume 
group "033a2b87-def7-4c27-ab74-9860531f2ed4" not found']
Nov 27 14:14:25 server vdsm Storage.StorageDomain WARNING Resource namespace 
033a2b87-def7-4c27-ab74-9860531f2ed4_imageNS already registered
Nov 27 14:14:25 server vdsm Storage.StorageDomain WARNING Resource namespace 
033a2b87-def7-4c27-ab74-9860531f2ed4_volumeNS already registered
Nov 27 14:14:25 server kernel: [136736.468680] ata1: hard resetting link
Nov 27 14:14:25 server kernel: [136736.772691] ata1: SATA link up 3.0 Gbps 
(SStatus 123 SControl 300)
Nov 27 14:14:25 server kernel: [136736.775827] ata1.00: configured for UDMA/133
Nov 27 14:14:25 server kernel: [136736.775831] ata1: EH complete
Nov 27 14:14:25 server kernel: [136736.776038] ata2: hard resetting link
Nov 27 14:14:25 server kernel: [136737.081179] ata2: SATA link up 3.0 Gbps 
(SStatus 123 SControl 300)
Nov 27 14:14:25 server kernel: [136737.084182] ata2.00: configured for UDMA/133
Nov 27 14:14:25 server kernel: [136737.084187] ata2: EH complete
Nov 27 14:14:25 server kernel: [136737.084420] ata3: limiting SATA link speed 
to 1.5 Gbps
Nov 27 14:14:25 server kernel: [136737.084425] ata3: hard resetting link
Nov 27 14:14:26 server kernel: [136737.388525] ata3: SATA link down (SStatus 0 
SControl 310)
Nov 27 14:14:26 server kernel: [136737.388537] ata3: EH complete
Nov 27 14:14:26 server kernel: [136737.388778] ata4: limiting SATA link speed 
to 1.5 Gbps
Nov 27 14:14:26 server kernel: [136737.388783] ata4: hard resetting link
Nov 27 14:14:26 server kernel: [136737.692934] ata4: SATA link down (SStatus 0 
SControl 310)
Nov 27 14:14:26 server kernel: [136737.692944] ata4: EH complete
Nov 27 14:14:26 server kernel: [136737.693138] ata5: limiting SATA link speed 
to 1.5 Gbps
Nov 27 14:14:26 server kernel: [136737.693142] ata5: hard resetting link
Nov 27 14:14:26 server kernel: [136737.997324] ata5: SATA link down (SStatus 0 
SControl 310)
Nov 27 14:14:26 server kernel: [136737.997334] ata5: EH complete
Nov 27 14:14:26 server kernel: [136737.997587] ata6: limiting SATA link speed 
to 1.5 Gbps
Nov 27 14:14:26 server kernel: [136737.997592] ata6: hard resetting link
Nov 27 14:14:27 server kernel: [136738.301820] ata6: SATA link down (SStatus 0 
SControl 310)
Nov 27 14:14:27 server kernel: [136738.301832] ata6: EH complete
Nov 27 14:14:27 server vdsm Storage.LVM WARNING lvm vgs failed: 5 [] ['  Volume 
group "c20da291-baf5-480a-b314-b775a6dde6e8" not found']
Nov 27 14:14:27 server vdsm Storage.StorageDomain WARNING Resource namespace 
c20da291-baf5-480a-b314-b775a6dde6e8_imageNS already registered
Nov 27 14:14:27 server vdsm Storage.StorageDomain WARNING Resource namespace 
c20da291-baf5-480a-b314-b775a6dde6e8_volumeNS already registered
Nov 27 14:14:27 server vdsm Storage.LVM WARNING lvm vgs failed: 5 [] ['  Volume 
group "033a2b87-def7-4c27-ab74-9860531f2ed4" not found']

Any ways I've decided to reboot just to see if everything went ok. When 
examining Storage tab I see how local-iso-share (my ISO domain type) is shown 
as green (activated) and then red (maintenance).

Taking a look at /var/log/messages I've seen:



Nov 27 14:26:38 server vdsm Storage.LVM WARNING lvm vgs failed: 5 [] [' Volume 
group "c20da291-baf5-480a-b314-b775a6dde6e8" not found'] 
Nov 27 14:26:38 server vdsm Storage.StorageDomain WARNING Resource namespace 
c20da291-baf5-480a-b314-b775a6dde6e8_imageNS already registered 
Nov 27 14:26:38 server vdsm Storage.StorageDomain WARNING Resource namespace 
c20da291-baf5-480a-b314-b775a6dde6e8_volumeNS already registered 
Nov 27 14:26:38 server vdsm Storage.HSM ERROR Could not disconnect from 
storageServer 

What am I missing?

Thank you.

----- Mensaje original ----- 


De: "Adrian Gibanel" <adrian.giba...@btactic.com> 
Para: users@ovirt.org 
Enviados: Martes, 27 de Noviembre 2012 11:10:48 
Asunto: Re: [Users] Lvm vgs failed on allinone setup 

If iSCSI is the problem I think I will reinstall oVirt by choosing NFS for 
default storage and not iSCSI. 

----- Mensaje original ----- 

> De: "Latchezar Filtchev" <lat...@aubg.bg> 
> Para: "Adrian Gibanel" <adrian.giba...@btactic.com>, users@ovirt.org 
> Enviados: Martes, 27 de Noviembre 2012 10:50:22 
> Asunto: RE: [Users] Lvm vgs failed on allinone setup 

> Hi, 

> I also had a problems with disappearing of iSCSI storage. This might 
> help: 

> http://www.sysarchitects.com/iscsi_target_on_rhel6 

> I was not able to solve my problem by manipulating /etc/lvm/lvm.conf. 
> I reinstalled my test environment without LVM. Now after restart 
> iSCSI storage does not disappear. 

> Best, 
> Latcho 

> -- 
> Latchezar Filtchev 
> IT Manager 
> http://www.aubg.bg 

> -----Original Message----- 
> From: users-boun...@ovirt.org [mailto:users-boun...@ovirt.org] On 
> Behalf Of Adrian Gibanel 
> Sent: Monday, November 26, 2012 7:50 PM 
> To: users@ovirt.org 
> Subject: [Users] Lvm vgs failed on allinone setup 

> Hi, 

> I'm trying to setup an oVirt 3.1 allinone system as described at: 
> http://blog.jebpages.com/archives/up-and-running-with-ovirt-3-1-edition/ 
> . 

> The main differences between my article and my setup are: 

> * I've downgraded ovirt-engine-sdk to 3.1 as suggested. 
> * I've selected ISCSI instead of NFS when running engine-setup and 
> answering to the: The default storage question. (I can change that 
> to NFS if needed, I think I used ISCSI because I had seen it in 
> another howto). 
> * Hacked all_in_one_100.py to increase waitForHostUp timeout ( 
> http://blog.jebpages.com/archives/up-and-running-with-ovirt-3-1-edition/#comment-705803414
>  
> ) 

> So when I first install it I go to attach local storage to local 
> datacenter as described in 5th setp in 
> http://blog.jebpages.com/archives/up-and-running-with-ovirt-3-1-edition/ 
> and everything seems to work fine. 

> My problem happens when I reboot. (I just rebooted to make sure 
> everything was setup fine.). 
> Then the local storage (named iso) isn't attached to the local 
> datacenter any more. 
> I've checked /var/log/messages and I've found what I think it's the 
> problem: 
> --- 

> Nov 25 23:54:03 server vdsm Storage.LVM WARNING lvm vgs failed: 5 [] 
> [' 
> Volume group "e2e3cb9c-a664-4fda-be0c-428b239e7e66" not found'] 

> Nov 25 23:54:03 server vdsm TaskManager.Task ERROR 
> Task=`e75609f0-7322-4845-9cfc-1fb18e0ad3fc`::Unexpected error 

> Nov 25 23:54:03 server vdsm Storage.Dispatcher.Protect ERROR 
> {'status': {'message': "Storage domain does not exist: 
> ('e2e3cb9c-a664-4fda-be0c-428b239e7e66',)", 'code': 358}} 
> --- 

> The place where I initially placed iso and storage was /home/iso and 
> /home/storage where /home was a normal ext4 partition. 
> In order to try to fix this problem and maybe increase oVirt 
> capabilites now /home is an ext4 partition but not a normal one but 
> mounted over an LV one. 
> As you can see the problem has not been fixed. 

> So I either need some help on how to fix this. I don't know. Some 
> ideas. 
> * What's oVirt expecting when it searches a Volume group. 
> * What command is it trying to run? 
> * I've tried to search the script which might do the search but I've 
> been unable to find it. 
> * Does oVirt expect any special partitioning layout regarding lvm? 

> Thank you for any idea you could have. 

> -- 
> -- 
> Adrián Gibanel 



-- 

-- 
Adrián Gibanel 
I.T. Manager 

+34 675 683 301 
www.btactic.com 



Ens podeu seguir a/Nos podeis seguir en: 

i 


Abans d´imprimir aquest missatge, pensa en el medi ambient. El medi ambient és 
cosa de tothom. / Antes de imprimir el mensaje piensa en el medio ambiente. El 
medio ambiente es cosa de todos. 

AVIS: 
El contingut d'aquest missatge i els seus annexos és confidencial. Si no en sou 
el destinatari, us fem saber que està prohibit utilitzar-lo, divulgar-lo i/o 
copiar-lo sense tenir l'autorització corresponent. Si heu rebut aquest missatge 
per error, us agrairem que ho feu saber immediatament al remitent i que 
procediu a destruir el missatge . 

AVISO: 
El contenido de este mensaje y de sus anexos es confidencial. Si no es el 
destinatario, les hacemos saber que está prohibido utilizarlo, divulgarlo y/o 
copiarlo sin tener la autorización correspondiente. Si han recibido este 
mensaje por error, les agradeceríamos que lo hagan saber inmediatamente al 
remitente y que procedan a destruir el mensaje . 
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to