Think I found some more clues.

Thread-21910::DEBUG::2014-12-17 11:26:07,277::lvm::288::Storage.Misc.excCmd::(cmd) /usr/bin/sudo -n /sbin/lvm vgs --config ' devices { preferred_names = ["^/dev/mapper/"] ignore_suspended_devices=1 write_cache_state=0 disable_after_error_count=3 obtain_device_list_from_udev=0 filter = [ '\''r|.*|'\'' ] } global { locking_type=1 prioritise_write_locks=1 wait_for_locks=1 use_lvmetad=0 } backup { retain_min = 50 retain_days = 0 } ' --noheadings --units b --nosuffix --separator '|' --ignoreskippedcluster -o uuid,name,attr,size,free,extent_size,extent_count,free_count,tags,vg_mda_size,vg_mda_free,lv_count,pv_count,pv_name 3ba06bee-861e-4868-8e89-f29f785bab65 (cwd None) Thread-21910::DEBUG::2014-12-17 11:26:07,348::lvm::288::Storage.Misc.excCmd::(cmd) FAILED: <err> = ' Volume group "3ba06bee-861e-4868-8e89-f29f785bab65" not found\n Skipping volume group 3ba06bee-861e-4868-8e89-f29f785bab65\n'; <rc> = 5 Thread-21910::WARNING::2014-12-17 11:26:07,350::lvm::370::Storage.LVM::(_reloadvgs) lvm vgs failed: 5 [] [' Volume group "3ba06bee-861e-4868-8e89-f29f785bab65" not found', ' Skipping volume group 3ba06bee-861e-4868-8e89-f29f785bab65'] Thread-21910::DEBUG::2014-12-17 11:26:07,351::lvm::407::Storage.OperationMutex::(_reloadvgs) Operation 'lvm reload operation' released the operation mutex

But I still don't understand what it's trying to do. Just to recap, I do see it create the dir and mount the device. But when it fails it umounts everything.

I tried to manually create the DIR it is expecting, but ovirt seems to remove it and re-create it which then ends up with root:root. I can see this as when I add the storage I run watch ls -lh and can see it all occur.

Any help would still be greatly appreciated!

On 12/16/14 19:46, Julian De Marchi wrote:
On 16/12/14 17:20, Aharon Canan wrote:
Did you "chown 36:36" the folder to get the right permissions for
adding to ovirt?

That's the thing. Ovirt actually creates that dir when I go and try to
add the storage. It mounts the LVM device to that dir then fails. In the
logs I posted at http://pastebin.com/fzN9ktAX you can see it is failing
with a permission denied error. The command that is above the error is
touch. I think it is trying to touch a file to ensure all is well and
when that fails it gives the error.

If I knew where in the code to prefix the touch command with sudo and
add a line to the sudoers entry I can test this idea.

[...]

----- Original Message -----

From: "Julian De Marchi" <jul...@jdcomputers.com.au>
To: users@ovirt.org
Sent: Tuesday, December 16, 2014 4:40:04 AM
Subject: Re: [ovirt-users] [STORAGE] Adding posix compliant FS

On 12/16/14 08:57, Julian De Marchi wrote:
Heya--

I'm using ovirt 3.5 and trying to add a posix compliant FS to a node in
my cluster.

The storage I'm trying to add is contained within LVM. Below is a link
to my log files on the node where I'm trying to attach the storage.

http://pastebin.com/fzN9ktAX

I've read the ovirt manual for adding posix compliant storage and
believe I'm doing everything correct.

Any help to get this storage added would be great thanks and if I forgot
to include any info please ask.

More info to add. I was doing an "ls" on the dir it does the mount in
and saw the dir was owned by root:root with different perms to the ones
mounted via NFS.

[root@blade01 libvirt]# ls /rhev/data-center/mnt/ -lh
total 20K
drwxrwxrwx 4 root root 4.0K Dec 11 09:00 10.106.200.100:_VM__IMAGES
drwxrwxrwx 3 root root 4.0K Oct 17 09:42 10.106.200.22:_opt_vmexport
drwxrwxrwx 4 root root 4.0K Oct 17 09:39
10.106.200.22:_var_lib_libvirt_images
drwxr-xr-x 3 root root 4.0K Dec 15 16:52 _dev_mapper_VolGroup-lv__images

This could explain why the touch command fails.

Still at a loss over the issue though.

_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to