On 12/18/14 18:23, Gianluca Cecchi wrote:
On Thu, Dec 18, 2014 at 7:12 AM, Vered Volansky <ve...@redhat.com> wrote:

Hey Vered,

IIUC the you have a self-created lvm, to which you're trying to
connect as
posix using ovirt.
If that's the case please try to manually change the device's
to 36:36 under /dev/<your_VG>.
If that doesn't work try the actual device it's mapped to (which is
vdsm actually tries to mount).
If that also doesn't work please send us the output of:
ls -lh /dev/<your_VG> .

Still failed mate after a chmod 36:36. The thing is though, it _does_
mount the device for a moment before failing and unmounting it...
Is this the same behaviour as before?

[root@blade01 ~]# ls /dev/VolGroup/lv_images -lh
lrwxrwxrwx 1 root root 7 Dec 15 16:52 /dev/VolGroup/lv_images -> ../dm-2

I see /dev/VolGroup/lv_images are still root:root.
Please chown 36:36 as well.

Please state the all the chown you tried.

Possibly a starting point for automating LVM device permissions setting is


and in particular the possibility to add, under /lib/udev/rules, a
customized file based on the one found in

Not tried myself though...

I don't think permissions for the device are the root cause of the issue. The way I see it behave when I try and mount it is:

vdsm will mount the device(If I'm quick I can see this with a LS). It then tries to write some kind of test file(I'm guessing) and as the mount point is still owned by root when vdsm tries to do the touch to test it fails. Then vdsm backs out and I get the failed to add storage error.


Users mailing list

Reply via email to