On Fri, Dec 18, 2015 at 2:26 PM, Sandro Bonazzola <sbona...@redhat.com>
wrote:

>
>
>>
> You can't put the only existing host in maintenance since Hosted Engine is
> running on it and it can't migrate
>
>
>
>> Or should I simply
>> - shutdown the VMs in my Datacenter
>> - shutdown engine VM
>> - stop vdsmd on host
>> - update host to both CentOS 7.2 and oVirt 3.6.1 packages with:
>>   # yum update
>> - reboot host
>> - verify vdsmd is ok
>> - exit the global maintenance mode and wait for a few minutes the engine
>> VM should on this fresh upgraded host
>> - hopefully the host will come up again as active and I can start my VMs
>> ?
>>
>>
>
> - shutdown the VMs in your Datacenter
> - move the host to local maintenance
> - shutdown engine VM
> - yum update
> - reboot
> - exit maintenance
>
>
>
>>
>>
After solving the engine VM part (see dedicated thread) I continued and
follow the steps indicated for the host.

After reboot and exiting maintenance I found the hosted_storage domain in
state "unattached" and not "maintenance" as in another test I have done
(note that in in that test there were not true data domains configured
apart the hosted_storage...)
I also got some exceptions inside the GUI when going into storage tab on
hosted_storage line. See:
https://drive.google.com/file/d/0BwoPbcrMv8mvYmdQYVM0dkRJaGM/view?usp=sharing

Uncaught exception occurred. Please try reloading the page. Details:
(TypeError) __gwt$exception: <skipped>: c is null

I tried to attach the hosted_storage but then the engine VM went down
I did wait for about 10 minutes and the VM was not restarted.
Is there any reason for ithe environment  to "automatically" go back into
maintenance?
Because as soon as I run again the command

hosted-engine --set-maintenance --mode=none

the engine VM was started again.....
Is there any command to see the current state of maintenance
(none/local/global)?

Anyway the hosted_storage domain still is in unattached state...

BTW: even if the host has been updated:

[root@ractor ]# yum update
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: ba.mirror.garr.it
 * extras: ba.mirror.garr.it
 * ovirt-3.6: ftp.nluug.nl
 * ovirt-3.6-epel: epel.besthosting.ua
 * updates: ba.mirror.garr.it
No packages marked for update
[root@ractor ]#

Inside the webadmin gui  in hosts tab I still see the icon indicating
"update available" for it
And in action items: "a new version is available" message

In software subtab the host is detected as:
OS Version: RHEL - 7 - 2.1511.el7.centos.2.10
Kernel Version: 3.10.0 - 327.3.1.el7.x86_64
KVM Version: 2.3.0 - 31.el7_2.4.1
LIBVIRT Version: libvirt-1.2.17-13.el7_2.2
VDSM Version: vdsm-4.17.13-0.el7.centos
SPICE Version: 0.12.4 - 15.el7
CEPH Version: librbd1-0.80.7-3.el7
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to