On 08/08/2016 10:22 AM, Simone Tiraboschi wrote:
On Sun, Aug 7, 2016 at 3:42 PM, Arsène Gschwind
<arsene.gschw...@unibas.ch> wrote:
Hi,

I have an oVirt setup with 2 server using hosted-engine, both server
resgistered properly the hosted-engine using :
# hosted-engine --deploy

but for some reason the second isn't recognized as a host for hosted-engine
and I'm not able to migrate the hosted-engine.
The error I get when trying to migrate:

Cannot migrate VM. There is no host that satisfies current scheduling
constraints. See below for details:
The host xxxxxx did not satisfy internal filter HA because it is not a
Hosted Engine host..

I've tried to redeploy the hosted-engine but this will fail since the host
already exists in the management DB.
I've tried to redeploy the host using the GUI when editing the Host and set
DEPLOY at Hosted Engine but in that case the Event just says the
configuration was updated but nothing happens.

Is there a way to check if the host is registered as hosted-engine host?
Can you please execute hosted-engine --vm-status on the problematic host?
Here's the result from the host where hosted engine is running:

Status up-to-date                  : True
Hostname                           : xxxxxx
Host ID                            : 1
Engine status : {"health": "good", "vm": "up", "detail": "up"}
Score                              : 3400
stopped                            : False
Local maintenance                  : False
crc32                              : 3c9dd013
Host timestamp                     : 82115
Extra metadata (valid at timestamp):
    metadata_parse_version=1
    metadata_feature_version=1
    timestamp=82115 (Mon Aug  8 10:44:12 2016)
    host-id=1
    score=3400
    maintenance=False
    state=EngineUp
    stopped=False

And this is from the problematic host:

Status up-to-date                  : False
Hostname                           : xxxxxxxx
Host ID                            : 1
Engine status                      : unknown stale-data
Score                              : 3400
stopped                            : False
Local maintenance                  : False
crc32                              : 6c959fce
Host timestamp                     : 82149
Extra metadata (valid at timestamp):
    metadata_parse_version=1
    metadata_feature_version=1
    timestamp=82149 (Mon Aug  8 10:44:45 2016)
    host-id=1
    score=3400
    maintenance=False
    state=EngineUp
    stopped=False


Do you see any hosted-engine score for it in the engine?
It seems the score is the same on both host

Thanks,
Arsène

How could I register it correctly?

Let me know if you need any logs.
Thanks for any hint.

Regards,
Arsène


_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to