2016-01-22 16:06 GMT+03:00 Christoph P.U. Kukulies <k...@kukulies.org>:
> Windows 7:
> Today I installed Java 8 on my windows 7 machine and did an upgrade of the
> CMS at the same time (from OpenCMS 9.5.2 to 9.5.3).
> After the Java update and the CMS update suddenly my tomcat 6.0.39 didn't
> start any longer. The service gave an error at start time:
> Der Dienst "Apache Tomcat 6.0 Tomcat6" wurde mit folgendem
> dienstspezifischem Fehler beendet: Unzulässige Funktion..
> My thoughts came to tomcat6 possibly not being compatible with Java8 and so
> I decided to install tomcat 7.0 which started fine.
> When starting my CMS system again I now found that it did some unpleasant
> things for which I wanted to rule out tomcat7 being the culprit
> and switch the jvm.dll in the tomcat7 configurator to the jre1.7 jvm.dll.
> Then suddenly I got the same error as under tomcat6.0 when I tried to start
> tomcat7 again.
> Could it be that the Java8 installer screws the existing Java 7 ? Or does it
> change some global parameters that tomcat reads at start time.

1. That "The service "Apache Tomcat 6.0 Tomcat6" terminated with
service-specific error: Incorrect function .." error (thanks to Google
Translate)  is coming from service wrapper, not from Tomcat itself.

Tomcat own errors are logged into textual log files, they are not
shown as a message window. See the log files in Tomcat's logs
directory. There is separate file for the service there.

Note that service wrapper (tomcat6.exe, tomcat7.exe) must be the same
32 vs 64 bit version as the Java jvm dll that you are using.  My guess
is that this mismatch is the reason for the error that you are

The Tomcat-[version].exe installer automatically detects 32 vs. 64bit
architecture by the jvm that you choose during installation, and
installs that version of wrapper.  If you download Tomcat as a zip
file, the only difference between "32-bit" and "64-bit" Windows zip
archives is the version of service wrapper and the version of

2. If no jvm.dll is configured, or configured jvm.dll is not found
then the service wrapper tries to use the default (latest) JVM
configured in the system.

That default jvm changes when you upgrade from java 7 to java 8.

Also Java 8 installer usually asks (prompts) you to uninstall old
versions of java. You may have uninstalled the old version and it is
no longer found.

Best regards,
Konstantin Kolinko

To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
For additional commands, e-mail: users-h...@tomcat.apache.org

Reply via email to