Am 25.01.2016 um 19:34 schrieb George Sexton:

On 1/25/2016 3:52 AM, Christoph P.U. Kukulies wrote:
Thanks. Will give that a try.

How can I tell, which java engine Tomcat is actually using?

At a CMD prompt I'm getting:

C:\> java -version
java version "1.8.0_71"
Java(TM) SE Runtime Environment (build 1.8.0_71-b15)
Java HotSpot(TM) 64-Bit Server VM (build 25.71-b15, mixed mode)

If you have a utility that shows what open files the Tomcat process has, that would work. Alternatively, get the Manager application running and see what information it provides under the Server Status screen.

That made me ask myself, whether the parameters and settings I can see and set through the manager (tomcat6w.exe) are those that the
Windows7 service really "sees" at startup.

Would like to have added -Xmx768m to the startup parameters. Looking into the registry HKLM\System\CurrentControlSet\Services\tomcat6 I can only see the ImagePath that is started ("c:\Program Files\Apache_Group\Tomcat_6.0.39\bin\tomcat6.exe" //RS//Tomcat6), the paramters
Key is empty.

Or does tomcat6w write these parameters elsewhere?



At Am 22.01.2016 um 18:28 schrieb George Sexton:

On 1/22/2016 6:06 AM, Christoph P.U. Kukulies wrote:
Windows 7:

Today I installed Java 8 on my windows 7 machine and did an upgrade of the CMS at the same time (from OpenCMS 9.5.2 to 9.5.3). After the Java update and the CMS update suddenly my tomcat 6.0.39 didn't start any longer. The service gave an error at start time:

Der Dienst "Apache Tomcat 6.0 Tomcat6" wurde mit folgendem dienstspezifischem Fehler beendet: Unzulässige Funktion..

I've seen this on Windows when upgrading the JRE. The solution that worked for me (multiple times) was to uninstall Java, and then re-install it. Make sure you grab the correct version (x86, x64) to go with your Tomcat install.

My thoughts came to tomcat6 possibly not being compatible with Java8 and so I decided to install tomcat 7.0 which started fine.

When starting my CMS system again I now found that it did some unpleasant things for which I wanted to rule out tomcat7 being the culprit and switch the jvm.dll in the tomcat7 configurator to the jre1.7 jvm.dll.

Then suddenly I got the same error as under tomcat6.0 when I tried to start tomcat7 again.

Could it be that the Java8 installer screws the existing Java 7 ? Or does it change some global parameters that tomcat reads at start time.



To unsubscribe, e-mail:
For additional commands, e-mail:

Reply via email to