[X] Other suggestion:

I agree with Martin's points, especially the 3rd one (span should have no CSS 
class).

To ease extending of FeedbackPanel I'd suggest to delegate #newItem() of the 
nested MessageListView to a new protected method #newMessageItem() in 
FeedbackPanel. (Similar to DataTable#newRowItem())

Best regards
Sven


On 10/29/2012 08:53 AM, Martin Grigorov wrote:
Hi,

[X] Other suggestion: (please specify)

Here is what I think it should be:
- <div> element should have class "feedbackPanel" (this is already the case)
- <li> element(s) should have class that specifies the feedback
message level (currently by default Wicket sets "feedbackPanelLEVEL",
but this is configurable with
org.apache.wicket.markup.html.panel.FeedbackPanel#getCSSClass(FeedbackMessage))
- the <span> should not have class at all (currently it has the same
class as the <li> element)
- the styling should be done with CSS selectors (e.g.
div.feedbackPanel; div.feedbackPanel li.alert-warn; div.feedbackPanel
li.alert-warn span; ...)
- if custom markup is needed then a custom FeedbackPanel is needed
(one that extends from the default FeedbackPanel or a completely new
one, it depends on the use case)


On Sun, Oct 28, 2012 at 6:03 PM, Sebastien <seb...@gmail.com> wrote:
Hi,

To sum-up this thread: we have a (not huge, but still) design issue that
annoys several users. A patch* has been provided but some questions
remains...
Given this, I would suggest a kind-of vote about the several points
discussed earlier, in order to enlighten the dev-team about the preferred
choice of their (beloved) users.**

Here are some possible options:
[ ] Please apply the patch as-is. It currently provides 2 methods
(#getListCSSClass and #getLabelCSSClass), #getCSSClass is marked a
deprecated until marked as private (or removed)
[ ] Do not apply the patch as-is, #getCSSClass should be kept (not marked
as deprecated)
[ ] Do not apply the patch as-is, I do not agree with the 2 method names. I
would have preferred: (please specify)
[ ] This is not an issue; this does not need to be "corrected"
[ ] Other suggestion: (please specify)

Thanks in advance for your contribution,
Sebastien

(*) https://issues.apache.org/jira/browse/WICKET-4831
(**) Sure, dev-team opinion is also kindly asked! :)




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org
For additional commands, e-mail: users-h...@wicket.apache.org

Reply via email to