On Thu, Sep 8, 2016 at 6:49 PM, alx_0x41 <loki-...@yandex.ru> wrote:

> Hi Everyone,
> I've been testing XWiki for a few days and there are several problems with
> both GWT and CKEditor editors.
> With the CKEditor:
> 1. In 95% of cases the tree view button in the "add link" dialog is not
> working. In the google developer console I see the following messages when
> opening the editor:
> tree.js:1 Uncaught SyntaxError: Unexpected token <
> hierarchy.js:1 Uncaught TypeError: b is not a function

You have a problem with the document tree which is not related to the
CKEditor editor. The document tree is used in various places, like the
breadcrumb, the navigation panel, etc. Don't you have the same errors in
the JavaScript console when in view mode? Something prevents the tree from
loading. Did you install any extensions? Did you write any JavaScript
extensions? I've seen this problem once caused by an extension that was
loading jQuery from CDN instead of using the version bundled with XWiki. I
have a clean install of 8.3M1 and the tree view loads all the time on

If you want to help debugging then you can replace your minified version of
hierarchy.js (from the XWiki WAR) with the unminified version
so that we get a better error message.

> Seems like in Chrome that happens more often then in Firefox. Tried both
> production-like WAR installation and the versions from the "graphical
> installer for all platfroms" - both 8.2 and 8.3-M1.
> 2. Sometimes the editor just does not show up at all - the editor load
> progress indicator inside the page is rotating and nothing happens. Could
> not find and error messages. Seems that this does not depend on any
> particular page contents - sometimes it happens, sometimes not. Tried
> cleaning the browser cache, but that did not help.
> 3. The similar problem with the "source" button. Very often it just shows
> the empty page. If I click it about 5 times on/off then sometimes the
> contents finally appears, but sometimes I get the raw HTML contents of the
> whole current page inside the text box.
> After giving up with CKEditor I tried the GWT editor (although I believe
> that since the CKEditor became the default one, the GWT might soon became
> deprecated).
> But here I met another problem: if I format any cell in a table with either
> "forecolor" or "backcolor" the removeformat command does not remove these
> colors. It only works if I switch to the source and put a space between '|'
> and '(%'.
> I'm really frustrated, because the table color formating is one of the main
> reasons I started looking for a new wiki engine for our company and after
> spending almost two weeks on the evaluation of different products I came to
> the conclusion that XWiki is currently the best one around.
> So any help would be very appreciated.
> --
> View this message in context: http://xwiki.475771.n2.nabble.
> com/Problems-with-both-WYSIWYG-editors-tp7601122.html
> Sent from the XWiki- Users mailing list archive at Nabble.com.
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
users mailing list

Reply via email to