On Tue, Jan 17, 2017 at 10:58 AM, Marius Dumitru Florea
<mariusdumitru.flo...@xwiki.com> wrote:
> On Mon, Jan 16, 2017 at 8:06 PM, shouldbe q931 <shouldbeq...@gmail.com>
> wrote:
>> Hi All,
>> On an infrequently maintained xwiki instance (.deb on Ubuntu), which
>> was running 8.4.1, the default editor is WYSIWYG
>> In Administration | Edit Mode Settings | DEFAULT EDITOR, the dropdown
>> box contains Wysiwyg and Text, and does NOT contain CKEditor
> That's normal. Below "Default Editor" you should have "Default WYSIWYG
> Editor" as in
> http://extensions.xwiki.org/xwiki/bin/view/Extension/Administration+Application#HEditModeSettings
> . That is the property that should list CKEditor as a possible value. But
> CKEditor should be the default WYSIWYG editor in XWiki 8.4.1 even if you
> leave this property unset.

The edit mode looks like


>> If a page in the wiki is selected, the edit icon has the options in
>> the dropdown for WYSIWYG, CKEditor, Wiki & Inline form, then below it,
>> Objects and Class.
> XWiki 8.4.1 is using CKEditor 1.9 which doesn't extend the edit menu, see
> http://jira.xwiki.org/browse/CKEDITOR-96 .
>> If CKEditor is selected, the edit window is not
>> shown.

If I try to edit a (blank) page with CK editor


> Did you upgrade to 8.4.1 from a previous version? It may be the case that
> CKEditor was not upgraded properly. Or maybe you didn't clear the browser
> cache.

Yes it was updated, but I couldn't tell you what the previous version
was, I think it started out as a 2.x.x release

>> I tried an update to 8.4.4, and there is no change in Administration |
>> Edit Mode Settings | DEFAULT EDITOR, but when a page is edited, it now
>> shows in the place where I would expect to see the edit window the
>> below
>> Content
>> #ckeditor($parameters)
> It seems CKEditor was still not upgraded properly.

As ckeditor shows as "Installed as a dependency", how might I go about
upgrading it properly ?




Reply via email to